]> git.pld-linux.org Git - packages/python3-pytest-check.git/blame - python-pytest-check.spec
- new
[packages/python3-pytest-check.git] / python-pytest-check.spec
CommitLineData
026b4219
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: pytest plugin that allows multiple failures per test
7Summary(pl.UTF-8): Wtyczka pytesta pozwalająca na wiele niepowodzeń z jednego testu
8Name: python-pytest-check
9# keep 0.2.x for python2 support
10Version: 0.2.1
11Release: 1
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/pytest-check/
15Source0: https://files.pythonhosted.org/packages/source/p/pytest-check/pytest-check-%{version}.tar.gz
16# Source0-md5: 21297eac5d350062aac1fc4eb1d081e5
17URL: https://pypi.org/project/pytest-check/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%endif
22%if %{with python3}
23BuildRequires: python3-modules >= 1:3.4
24BuildRequires: python3-setuptools
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28Requires: python-modules >= 1:2.7
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33A pytest plugin that allows multiple failures per test.
34
35This plugin was a rewrite and a rename of pytest-expect.
36
37%description -l pl.UTF-8
38Wtyczka pytesta pozwalająca na wiele niepowodzeń z jednego testu.
39
40Ta wtyczka była przepisaną wtyczką pytest-expect, z nową nazwą.
41
42%package -n python3-pytest-check
43Summary: pytest plugin that allows multiple failures per test
44Summary(pl.UTF-8): Wtyczka pytesta pozwalająca na wiele niepowodzeń z jednego testu
45Group: Libraries/Python
46Requires: python3-modules >= 1:3.4
47
48%description -n python3-pytest-check
49A pytest plugin that allows multiple failures per test.
50
51This plugin was a rewrite and a rename of pytest-expect.
52
53%description -n python3-pytest-check -l pl.UTF-8
54Wtyczka pytesta pozwalająca na wiele niepowodzeń z jednego testu.
55
56Ta wtyczka była przepisaną wtyczką pytest-expect, z nową nazwą.
57
58%prep
59%setup -q -n pytest-check-%{version}
60
61%build
62%if %{with python2}
63%py_build
64%endif
65
66%if %{with python3}
67%py3_build
68%endif
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%if %{with python2}
74%py_install
75
76%py_postclean
77%endif
78
79%if %{with python3}
80%py3_install
81%endif
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%if %{with python2}
87%files
88%defattr(644,root,root,755)
89%doc README.rst
90%{py_sitescriptdir}/pytest_check
91%{py_sitescriptdir}/pytest_check-%{version}-py*.egg-info
92%endif
93
94%if %{with python3}
95%files -n python3-pytest-check
96%defattr(644,root,root,755)
97%doc README.rst
98%{py3_sitescriptdir}/pytest_check
99%{py3_sitescriptdir}/pytest_check-%{version}-py*.egg-info
100%endif
This page took 0.054996 seconds and 4 git commands to generate.