]> git.pld-linux.org Git - packages/python-pymongo.git/blame - python-pymongo.spec
- new package
[packages/python-pymongo.git] / python-pymongo.spec
CommitLineData
29da83ef
JK
1#
2# Conditional build:
3%bcond_with tests # run tests (seem broken)
4
5%define module pymongo
6Summary: Python driver for MongoDB
7Summary(pl.UTF-8): Sterownik Pythona do MongoDB
8Name: python-%{module}
9Version: 2.2
10Release: 1
11License: Apache v2.0
12Group: Development/Languages/Python
13Source0: http://pypi.python.org/packages/source/p/pymongo/%{module}-%{version}.tar.gz
14# Source0-md5: 101dd4ae59bdd487f67b3a3968a82c8c
15URL: http://api.mongodb.org/python/current/
16BuildRequires: python-devel
17BuildRequires: python-distribute
18BuildRequires: rpm-pythonprov
19Requires: python-libs
20Requires: python-modules
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The PyMongo distribution contains tools for interacting with MongoDB
25database from Python. The bson package is an implementation of the
26BSON format for Python. The pymongo package is a native Python driver
27for MongoDB. The gridfs package is a gridfs implementation on top of
28pymongo.
29
30%prep
31%setup -q -n %{module}-%{version}
32
33%build
34CC="%{__cc}" \
35CFLAGS="%{rpmcflags}" \
36%{__python} setup.py build
37
38%{?with_tests:%{__python} setup.py test}
39
40%install
41rm -rf $RPM_BUILD_ROOT
42%{__python} setup.py install \
43 --skip-build \
44 --optimize=2 \
45 --root=$RPM_BUILD_ROOT
46
47install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
50%py_comp $RPM_BUILD_ROOT%{py_sitedir}
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
57%doc README.rst PKG-INFO doc/api doc/examples doc/*.rst
58%dir %{py_sitedir}/bson
59%{py_sitedir}/bson/*.py*
60%attr(755,root,root) %{py_sitedir}/bson/*.so
61%dir %{py_sitedir}/gridfs
62%{py_sitedir}/gridfs/*.py*
63%dir %{py_sitedir}/pymongo
64%{py_sitedir}/pymongo/*.py*
65%attr(755,root,root) %{py_sitedir}/pymongo/*.so
66%{py_sitedir}/*-*.egg-info
This page took 0.189482 seconds and 4 git commands to generate.