]> git.pld-linux.org Git - packages/python-pylint-django.git/blame - python-pylint-django.spec
tests: BR: python-pylint-plugin-utils
[packages/python-pylint-django.git] / python-pylint-django.spec
CommitLineData
b9950901
JK
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7%define module pylint-django
8Summary: Pylint plugin for hangling Django code
9# Name must match the python module/package name (as in 'import' statement)
10Name: python-%{module}
11Version: 0.7.1
f3bef41f 12Release: 2
b9950901
JK
13License: GPL v2
14Group: Libraries/Python
15Source0: https://pypi.python.org/packages/source/p/pylint-django/%{module}-%{version}.tar.gz
16# Source0-md5: 4e170e1276bb00ad4996f24daae1786e
17URL: https://github.com/landscapeio/pylint-django
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules
22BuildRequires: python-setuptools
f3bef41f 23%{?with_tests:BuildRequires: python-pylint-plugin-utils}
b9950901
JK
24%endif
25%if %{with python3}
26BuildRequires: python3-modules
27BuildRequires: python3-setuptools
f3bef41f 28%{?with_tests:BuildRequires: python3-pylint-plugin-utils}
b9950901
JK
29%endif
30Requires: python-modules
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35pylint-django is a Pylint plugin to aid Pylint in recognising and
36understandingerrors caused when using the Django framework.
37
38%package -n python3-%{module}
39Summary: Pylint plugin for hangling Django code
40Group: Libraries/Python
41Requires: python3-modules
42
43%description -n python3-%{module}
44pylint-django is a Pylint plugin to aid Pylint in recognising and
45understandingerrors caused when using the Django framework.
46
47%prep
48%setup -q -n %{module}-%{version}
49
50%build
51%if %{with python2}
52%py_build %{?with_tests:test}
53%endif
54
55%if %{with python3}
56%py3_build %{?with_tests:test}
57%endif
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%if %{with python2}
63%py_install
64
65%py_postclean
66%endif
67
68%if %{with python3}
69%py3_install
70%endif
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%if %{with python2}
76%files
77%defattr(644,root,root,755)
78%{py_sitescriptdir}/pylint_django
79%if "%{py_ver}" > "2.4"
80%{py_sitescriptdir}/pylint_django-%{version}-py*.egg-info
81%endif
82%endif
83
84%if %{with python3}
85%files -n python3-%{module}
86%defattr(644,root,root,755)
87%{py3_sitescriptdir}/pylint_django
88%{py3_sitescriptdir}/pylint_django-%{version}-py*.egg-info
89%endif
This page took 0.067025 seconds and 4 git commands to generate.