]> git.pld-linux.org Git - packages/python-pygtk.git/blame - python-pygtk.spec
- reincarnation for pygtk 2.0 (now 1.99.x versions)
[packages/python-pygtk.git] / python-pygtk.spec
CommitLineData
b7c81cf4 1
2#
3# todo:
4# 1. libglade subpackage (needs libglade2)
5# 2. descriptions and summaries
6# 3. review subpackages content and dependencies (does gtk require atk
7# and pango modules? more?)
8# 4. numpy?
9#
10
11%include /usr/lib/rpm/macros.python
12%define module pygtk
13
14Summary: P
15Summary(pl): P
16Name: python-%{module}
17Version: 1.99.7
18Release: 0.1
19License: GPL
20Group: Development/Languages/Python
21Source0: %{module}-%{version}.tar.gz
22URL: http://daa.com.au/~james/pygtk
23%requires_eq python-modules
24BuildRequires: gtk+-devel
25BuildRequires: atk-devel
26BuildRequires: pango-devel
27BuildRequires: rpm-pythonprov
28BuildRequires: python-devel
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32N/A
33
34%description -l pl
35N/A
36
37%package gobject
38Summary: GObject
39Summary(pl): GObject
40Group: Development/Languages/Python
41
42%description gobject
43N/A
44
45%description gobject -l pl
46N/A
47
48%package gtk
49Summary: GTK
50Summary(pl): GTK
51Group: Development/Languages/Python
52Requires: %{name}-gobject = %{version}
53
54%description gtk
55N/A
56
57%description gtk -l pl
58N/A
59
60%package atk
61Summary: atk
62Summary(pl): atk
63Group: Development/Languages/Python
64Requires: %{name}-gobject = %{version}
65
66%description atk
67N/A
68
69%description atk -l pl
70N/A
71
72%package pango
73Summary: pango
74Summary(pl): pango
75Group: Development/Languages/Python
76Requires: %{name}-gobject = %{version}
77
78%description pango
79N/A
80
81%description pango -l pl
82N/A
83
84%prep
85%setup -q -n %{module}-%{version}
86
87%build
88%configure
89%{__make}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93install -d $RPM_BUILD_ROOT
94
95%{__make} install DESTDIR=$RPM_BUILD_ROOT
96
97install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
98cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}
99
100gzip -9nf README ChangeLog NEWS MAPPING TODO THREADS AUTHORS
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
106%defattr(644,root,root,755)
107%doc *.gz
108%attr(755,root,root) %{_bindir}/*
109%{_includedir}/pygtk-2.0
110
111%dir %{_datadir}/%{module}
112%dir %{_datadir}/%{module}/2.0
113%dir %{_datadir}/%{module}/2.0/codegen
114%dir %{_datadir}/%{module}/2.0/defs
115%{_datadir}/%{module}/2.0/codegen/*.py[co]
116
117%{_pkgconfigdir}/*.pc
118%{_examplesdir}/%{name}
119
120%files gobject
121%defattr(644,root,root,755)
122%attr(755,root,root) %{py_sitedir}/gobject*.so
123%attr(755,root,root) %{py_sitedir}/gobject*.la
124
125%files gtk
126%defattr(644,root,root,755)
127%{_datadir}/%{module}/2.0/defs/gtk*
128%{_datadir}/%{module}/2.0/defs/gdk*
129%dir %{py_sitedir}/gtk
130%attr(755,root,root) %{py_sitedir}/gtk/*.so
131%attr(755,root,root) %{py_sitedir}/gtk/*.la
132%{py_sitedir}/gtk/*.py[co]
133
134%files atk
135%defattr(644,root,root,755)
136%{_datadir}/%{module}/2.0/defs/atk*
137%attr(755,root,root) %{py_sitedir}/atk*.so
138%attr(755,root,root) %{py_sitedir}/atk*.la
139
140%files pango
141%defattr(644,root,root,755)
142%{_datadir}/%{module}/2.0/defs/pango*
143%attr(755,root,root) %{py_sitedir}/pango*.so
144%attr(755,root,root) %{py_sitedir}/pango*.la
This page took 0.0387 seconds and 4 git commands to generate.