]> git.pld-linux.org Git - packages/python-pygtk.git/blame - python-pygtk.spec
- fixed build requirement
[packages/python-pygtk.git] / python-pygtk.spec
CommitLineData
b7c81cf4 1
2#
3# todo:
4# 1. libglade subpackage (needs libglade2)
5# 2. descriptions and summaries
6# 3. review subpackages content and dependencies (does gtk require atk
7# and pango modules? more?)
8# 4. numpy?
9#
10
11%include /usr/lib/rpm/macros.python
12%define module pygtk
13
14Summary: P
15Summary(pl): P
16Name: python-%{module}
17Version: 1.99.7
18Release: 0.1
19License: GPL
20Group: Development/Languages/Python
3cff1401 21Source0: ftp://ftp.gtk.org/pub/gtk/python/v1.3/%{module}-%{version}.tar.gz
b7c81cf4 22URL: http://daa.com.au/~james/pygtk
23%requires_eq python-modules
76417dbc 24BuildRequires: gtk+2-devel
25BuildRequires: libglade2-devel
b7c81cf4 26BuildRequires: atk-devel
27BuildRequires: pango-devel
28BuildRequires: rpm-pythonprov
29BuildRequires: python-devel
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33N/A
34
35%description -l pl
36N/A
37
38%package gobject
39Summary: GObject
40Summary(pl): GObject
41Group: Development/Languages/Python
42
43%description gobject
44N/A
45
46%description gobject -l pl
47N/A
48
49%package gtk
50Summary: GTK
51Summary(pl): GTK
52Group: Development/Languages/Python
53Requires: %{name}-gobject = %{version}
54
55%description gtk
56N/A
57
58%description gtk -l pl
59N/A
60
61%package atk
62Summary: atk
63Summary(pl): atk
64Group: Development/Languages/Python
65Requires: %{name}-gobject = %{version}
66
67%description atk
68N/A
69
70%description atk -l pl
71N/A
72
73%package pango
74Summary: pango
75Summary(pl): pango
76Group: Development/Languages/Python
77Requires: %{name}-gobject = %{version}
78
79%description pango
80N/A
81
82%description pango -l pl
83N/A
84
85%prep
86%setup -q -n %{module}-%{version}
87
88%build
89%configure
90%{__make}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94install -d $RPM_BUILD_ROOT
95
96%{__make} install DESTDIR=$RPM_BUILD_ROOT
97
98install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
99cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}
100
101gzip -9nf README ChangeLog NEWS MAPPING TODO THREADS AUTHORS
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%files
107%defattr(644,root,root,755)
108%doc *.gz
109%attr(755,root,root) %{_bindir}/*
110%{_includedir}/pygtk-2.0
111
112%dir %{_datadir}/%{module}
113%dir %{_datadir}/%{module}/2.0
114%dir %{_datadir}/%{module}/2.0/codegen
115%dir %{_datadir}/%{module}/2.0/defs
116%{_datadir}/%{module}/2.0/codegen/*.py[co]
117
118%{_pkgconfigdir}/*.pc
119%{_examplesdir}/%{name}
120
121%files gobject
122%defattr(644,root,root,755)
123%attr(755,root,root) %{py_sitedir}/gobject*.so
124%attr(755,root,root) %{py_sitedir}/gobject*.la
125
126%files gtk
127%defattr(644,root,root,755)
128%{_datadir}/%{module}/2.0/defs/gtk*
129%{_datadir}/%{module}/2.0/defs/gdk*
130%dir %{py_sitedir}/gtk
131%attr(755,root,root) %{py_sitedir}/gtk/*.so
132%attr(755,root,root) %{py_sitedir}/gtk/*.la
133%{py_sitedir}/gtk/*.py[co]
134
135%files atk
136%defattr(644,root,root,755)
137%{_datadir}/%{module}/2.0/defs/atk*
138%attr(755,root,root) %{py_sitedir}/atk*.so
139%attr(755,root,root) %{py_sitedir}/atk*.la
140
141%files pango
142%defattr(644,root,root,755)
143%{_datadir}/%{module}/2.0/defs/pango*
144%attr(755,root,root) %{py_sitedir}/pango*.so
145%attr(755,root,root) %{py_sitedir}/pango*.la
This page took 0.101506 seconds and 4 git commands to generate.