]> git.pld-linux.org Git - packages/python-pyflakes.git/blame - python-pyflakes.spec
- up to 0.8.1
[packages/python-pyflakes.git] / python-pyflakes.spec
CommitLineData
a4ae4119
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
20c0205c 5%define module pyflakes
62420600 6Summary: Passive checker of Python programs
dddde51f 7Summary(pl.UTF-8): Pasywny program do sprawdzania programów w Pythonie
20c0205c 8Name: python-%{module}
84f80587 9Version: 0.8.1
e2c1b84e 10Release: 1
62420600
KK
11License: MIT
12Group: Development/Tools
20c0205c 13Source0: http://pypi.python.org/packages/source/p/pyflakes/%{module}-%{version}.tar.gz
84f80587 14# Source0-md5: 905fe91ad14b912807e8fdc2ac2e2c23
62420600 15URL: http://www.divmod.org/projects/pyflakes
a4ae4119 16BuildRequires: python-TwistedCore
62420600 17BuildRequires: python-devel
a4ae4119 18%{?with_tests:BuildRequires: rpm-pythonprov}
62420600
KK
19BuildRequires: rpmbuild(macros) >= 1.219
20%pyrequires_eq python-modules
20c0205c
ER
21Provides: pyflakes = %{version}-%{release}
22Obsoletes: pyflakes < 0.4.0-2
62420600
KK
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Pyflakes is a simple program which checks Python source files for
28errors. It is similar to PyChecker in scope, but differs in that it
29does not execute the modules to check them. This is both safer and
30faster, although it does not perform as many checks. Unlike PyLint,
31Pyflakes checks only for logical errors in programs; it does not
32perform any checks on style.
33
d3ebe99a
JR
34%description -l pl.UTF-8
35Pyflakes to prosty program sprawdzający pliki źródłowe Pythona pod
36kątem błędów. Jest podobny do PyCheckera jeśli chodzi o zakres
37działania, ale różni się tym, że nie wykonuje modułów przy sprawdzaniu
38ich. Jest to zarówno bardziej bezpieczne, jak i szybze, choć nie
20c0205c
ER
39sprawdza tak wielu rzeczy. W przeciwieństwie do PyLinta Pyflakes szuka
40tylko błędów logicznych w programach; nie sprawdza stylu.
01fa6f59 41
62420600 42%prep
20c0205c 43%setup -q -n %{module}-%{version}
62420600 44
a4ae4119
ER
45%build
46%{__python} setup.py build
47
48%if %{with tests}
49trial pyflakes/test
50%endif
51
62420600
KK
52%install
53rm -rf $RPM_BUILD_ROOT
20c0205c 54%{__python} setup.py install \
62420600
KK
55 --optimize=2 \
56 --root=$RPM_BUILD_ROOT
57
58%py_postclean
59
20c0205c
ER
60rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/pyflakes/test
61
62420600
KK
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
20c0205c 67%attr(755,root,root) %{_bindir}/pyflakes
62420600 68%{py_sitescriptdir}/pyflakes
20c0205c
ER
69%if "%{py_ver}" > "2.4"
70%{py_sitescriptdir}/pyflakes-%{version}-*.egg-info
71%endif
This page took 0.091516 seconds and 4 git commands to generate.