]> git.pld-linux.org Git - packages/python-pluggy.git/blame - python-pluggy.spec
- updated to 0.6.0
[packages/python-pluggy.git] / python-pluggy.spec
CommitLineData
5f61b62e 1#
1e47850e 2# Conditional build:
1e47850e
MK
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7%define module pluggy
8Summary: Plugin and hook calling mechanisms for Python
9Summary(pl.UTF-8): Mechanizmy wtyczek dla Pythona
10Name: python-%{module}
73aad6e5
JB
11Version: 0.6.0
12Release: 1
1e47850e
MK
13License: MIT
14Group: Libraries/Python
73aad6e5
JB
15#Source0Download: https://pypi.org/simple/pluggy/
16Source0: https://files.pythonhosted.org/packages/source/p/pluggy/pluggy-%{version}.tar.gz
17# Source0-md5: ffdde7c3a5ba9a440404570366ffb6d5
18URL: https://pypi.org/project/pluggy/
1e47850e
MK
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.714
21%if %{with python2}
73aad6e5 22BuildRequires: python-modules >= 1:2.7
6239e403 23BuildRequires: python-setuptools
73aad6e5
JB
24%if %{with tests}
25BuildRequires: python-pytest
26%endif
1e47850e
MK
27%endif
28%if %{with python3}
73aad6e5 29BuildRequires: python3-modules >= 1:3.4
6239e403 30BuildRequires: python3-setuptools
73aad6e5
JB
31%if %{with tests}
32BuildRequires: python3-pytest
1e47850e 33%endif
73aad6e5
JB
34%endif
35Requires: python-modules >= 1:2.7
1e47850e
MK
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40Plugin manager as used by pytest but stripped of pytest specific
41details.
42
43%description -l pl.UTF-8
44Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
45specyficznych dla pytest.
46
47%package -n python3-%{module}
48Summary: Plugin and hook calling mechanisms for Python
49Summary(pl.UTF-8): Mechanizmy wtyczek dla Pythona
50Group: Libraries/Python
73aad6e5 51Requires: python3-modules >= 1:3.4
1e47850e
MK
52
53%description -n python3-%{module}
54Plugin manager as used by pytest but stripped of pytest specific
55details.
56
57%description -n python3-%{module} -l pl.UTF-8
58Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
59specyficznych dla pytest.
60
1e47850e
MK
61%prep
62%setup -q -n %{module}-%{version}
63
64%build
65%if %{with python2}
73aad6e5
JB
66%py_build
67
68%if %{with tests}
69%{__python} -m pytest testing
70%endif
1e47850e
MK
71%endif
72
73%if %{with python3}
73aad6e5 74%py3_build
1e47850e 75
73aad6e5
JB
76%if %{with tests}
77%{__python3} -m pytest testing
78%endif
1e47850e
MK
79%endif
80
81%install
82rm -rf $RPM_BUILD_ROOT
73aad6e5 83
1e47850e
MK
84%if %{with python2}
85%py_install
73aad6e5 86
1e47850e
MK
87%py_postclean
88%endif
89
90%if %{with python3}
91%py3_install
92%endif
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%if %{with python2}
98%files
99%defattr(644,root,root,755)
73aad6e5
JB
100%doc LICENSE README.rst
101%{py_sitescriptdir}/pluggy
102%{py_sitescriptdir}/pluggy-%{version}-py*.egg-info
1e47850e 103%endif
1e47850e
MK
104
105%if %{with python3}
106%files -n python3-%{module}
107%defattr(644,root,root,755)
73aad6e5
JB
108%doc LICENSE README.rst
109%{py3_sitescriptdir}/pluggy
110%{py3_sitescriptdir}/pluggy-%{version}-py*.egg-info
1e47850e 111%endif
This page took 0.084588 seconds and 4 git commands to generate.