]> git.pld-linux.org Git - packages/python-persistent.git/blame - python-persistent.spec
up to 4.6.4
[packages/python-persistent.git] / python-persistent.spec
CommitLineData
dc7756b6
MK
1# TODO:
2# - check test failures: FAIL: test_ring_impl (persistent.tests.test_picklecache.PickleCacheTests)
3# - fix docs: Could not import extension repoze.sphinx.autointerface (exception: No module named 'repoze')
16944033 4# - delete/packages /usr/lib64/python*/site-packages/persistent/tests/
dc7756b6
MK
5# Conditional build:
6%bcond_with doc # don't build doc
7%bcond_with tests # do not perform "make test"
8%bcond_without python2 # CPython 2.x module
9%bcond_without python3 # CPython 3.x module
10
11%define module persistent
12%define pypi_name %{module}
13
14Summary: Automatic persistence for Python objects
15Summary(pl.UTF-8): Automytczne trwałe obiekty w Pythonie
16Name: python-%{module}
583156cd
JP
17Version: 4.6.4
18Release: 1
dc7756b6
MK
19License: ZPL 2.1
20Group: Libraries/Python
0dbf35fe
JB
21#Source0Download: https://pypi.org/simple/persistent/
22Source0: https://files.pythonhosted.org/packages/source/p/persistent/%{pypi_name}-%{version}.tar.gz
583156cd 23# Source0-md5: 6878fd3a3008fb5b7da7a374155fd6c2
dc7756b6
MK
24URL: http://www.zope.org/Products/ZODB
25BuildRequires: rpm-pythonprov
dc7756b6
MK
26BuildRequires: rpmbuild(macros) >= 1.714
27%if %{with python2}
28BuildRequires: python-devel
0dbf35fe 29BuildRequires: python-setuptools
dc7756b6
MK
30%endif
31%if %{with python3}
32BuildRequires: python3-devel
0dbf35fe 33BuildRequires: python3-setuptools
dc7756b6 34%endif
dc7756b6
MK
35Requires: python-modules
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39
40%description -l pl.UTF-8
41
42%package -n python3-%{module}
0dbf35fe
JB
43Summary: Automatic persistence for Python objects
44Summary(pl.UTF-8): Automytczne trwałe obiekty w Pythonie
dc7756b6
MK
45Group: Libraries/Python
46Requires: python3-modules
47
48%description -n python3-%{module}
49
50%description -n python3-%{module} -l pl.UTF-8
51
52%package apidocs
53Summary: %{module} API documentation
54Summary(pl.UTF-8): Dokumentacja API %{module}
55Group: Documentation
56
57%description apidocs
58API documentation for %{module}.
59
60%description apidocs -l pl.UTF-8
61Dokumentacja API %{module}.
62
63%prep
64%setup -q -n %{module}-%{version}
65
66%build
67%if %{with python2}
68%py_build %{?with_tests:test}
69%endif
70
71%if %{with python3}
72%py3_build %{?with_tests:test}
73%endif
74
75%if %{with doc}
76cd docs
77%{__make} -j1 html
78rm -rf _build/html/_sources
79%endif
80
81%install
82rm -rf $RPM_BUILD_ROOT
83%if %{with python2}
84%py_install
85%py_postclean
86%endif
87
88%if %{with python3}
89%py3_install
90%endif
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with python2}
96%files
97%defattr(644,root,root,755)
98%doc README.rst CHANGES.rst
99%dir %{py_sitedir}/%{module}
100%{py_sitedir}/%{module}/*.py[co]
f3408e2e 101%{py_sitedir}/%{module}/*.[ch]
dc7756b6
MK
102%attr(755,root,root) %{py_sitedir}/%{module}/*.so
103%{py_sitedir}/%{module}-%{version}-py*.egg-info
16944033
MK
104%dir %{py_incdir}/persistent/
105%{py_incdir}/persistent/cPersistence.h
106%{py_incdir}/persistent/ring.h
dc7756b6
MK
107%endif
108
109%if %{with python3}
110%files -n python3-%{module}
111%defattr(644,root,root,755)
112%doc README.rst CHANGES.rst
113%dir %{py3_sitedir}/%{module}
114%{py3_sitedir}/%{module}/*.py
f3408e2e 115%{py3_sitedir}/%{module}/*.[ch]
dc7756b6
MK
116%attr(755,root,root) %{py3_sitedir}/%{module}/*.so
117%{py3_sitedir}/%{module}/__pycache__
118%{py3_sitedir}/%{module}-%{version}-py*.egg-info
16944033
MK
119%dir %{py3_incdir}/persistent/
120%{py3_incdir}/persistent/cPersistence.h
121%{py3_incdir}/persistent/ring.h
dc7756b6
MK
122%endif
123
124%if %{with doc}
125%files apidocs
126%defattr(644,root,root,755)
127%doc docs/_build/html/*
128%endif
This page took 0.106522 seconds and 4 git commands to generate.