]> git.pld-linux.org Git - packages/python-pefile.git/blame - python-pefile.spec
- disable python3 here
[packages/python-pefile.git] / python-pefile.spec
CommitLineData
fc4a5ee6
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
39d7c2a9 4%bcond_with python3 # CPython 3.x module (built from python3-pefile.spec)
fc4a5ee6
JB
5
6Summary: Python PE parsing module
7Summary(pl.UTF-8): Moduł Pythona do analizy PE
8Name: python-pefile
39d7c2a9 9# keep 2019.x here for python2 support
fc4a5ee6
JB
10Version: 2019.4.18
11Release: 1
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/pefile/
15Source0: https://files.pythonhosted.org/packages/source/p/pefile/pefile-%{version}.tar.gz
16# Source0-md5: e328272bc82ddc3170316250e37027ad
17URL: https://pypi.org/project/pefile/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.5
20BuildRequires: python-setuptools
21%endif
22%if %{with python3}
23BuildRequires: python3-modules >= 1:3.2
24BuildRequires: python3-setuptools
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28Requires: python-modules >= 1:2.5
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33pefile is a multi-platform Python module to parse and work with
34Portable Executable (aka PE) files. Most of the information contained
35in the PE headers is accessible as well as all sections' details and
36their data.
37
38%description -l pl.UTF-8
39pefile to wieloplatformowy moduł Pythona do analizy i pracy z plikami
40Portable Executable (PE). Umożliwia dostęp do większości informacji
41zawartych w nagłówkach PE, a także szczegółów oraz danych wszystkich
42sekcji.
43
44%package -n python3-pefile
45Summary: Python PE parsing module
46Summary(pl.UTF-8): Moduł Pythona do analizy PE
47Group: Libraries/Python
48Requires: python3-modules >= 1:3.2
49
50%description -n python3-pefile
51pefile is a multi-platform Python module to parse and work with
52Portable Executable (aka PE) files. Most of the information contained
53in the PE headers is accessible as well as all sections' details and
54their data.
55
56%description -n python3-pefile -l pl.UTF-8
57pefile to wieloplatformowy moduł Pythona do analizy i pracy z plikami
58Portable Executable (PE). Umożliwia dostęp do większości informacji
59zawartych w nagłówkach PE, a także szczegółów oraz danych wszystkich
60sekcji.
61
62%prep
63%setup -q -n pefile-%{version}
64
65%build
66%if %{with python2}
67%py_build
68%endif
69
70%if %{with python3}
71%py3_build
72%endif
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%if %{with python2}
78%py_install
79
80%py_postclean
81%endif
82
83%if %{with python3}
84%py3_install
85%endif
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%if %{with python2}
91%files
92%defattr(644,root,root,755)
93%doc LICENSE README
94%{py_sitescriptdir}/ordlookup
95%{py_sitescriptdir}/pefile.py[co]
96%{py_sitescriptdir}/peutils.py[co]
97%{py_sitescriptdir}/pefile-%{version}-py*.egg-info
98%endif
99
100%if %{with python3}
101%files -n python3-pefile
102%defattr(644,root,root,755)
103%doc LICENSE README
104%{py3_sitescriptdir}/ordlookup
105%{py3_sitescriptdir}/pefile.py
106%{py3_sitescriptdir}/peutils.py
107%{py3_sitescriptdir}/__pycache__/pefile.cpython-*.py[co]
108%{py3_sitescriptdir}/__pycache__/peutils.cpython-*.py[co]
109%{py3_sitescriptdir}/pefile-%{version}-py*.egg-info
110%endif
This page took 0.104288 seconds and 4 git commands to generate.