]> git.pld-linux.org Git - packages/python-pebble.git/blame - python-pebble.spec
rebuild with python 3.10
[packages/python-pebble.git] / python-pebble.spec
CommitLineData
84bfbd89
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Threading and multiprocessing eye-candy
8Summary(pl.UTF-8): Miłe dla oka wątli i wieloprocesowość
9Name: python-pebble
10Version: 4.4.0
471c4f7f 11Release: 4
84bfbd89
JB
12License: LGPL v3+
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/pebble/
15Source0: https://files.pythonhosted.org/packages/source/p/pebble/Pebble-%{version}.tar.gz
16# Source0-md5: c8c06548a13af018bfa247ae1ecdd844
17URL: https://pypi.org/project/Pebble/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.5
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-futures
25%endif
26%endif
27%if %{with python3}
28BuildRequires: python3-modules >= 1:3.2
29BuildRequires: python3-setuptools
30%endif
31Requires: python-modules >= 1:2.5
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Pebble provides a neat API to manage threads and processes within an
37application.
38
39%description -l pl.UTF-8
40Pebble udostępnia schludne API do zarządzania wątkami i procesami
41wewnątrz aplikacji.
42
43%package -n python3-pebble
44Summary: Threading and multiprocessing eye-candy
45Summary(pl.UTF-8): Miłe dla oka wątli i wieloprocesowość
46Group: Libraries/Python
47Requires: python3-modules >= 1:3.2
48
49%description -n python3-pebble
50Pebble provides a neat API to manage threads and processes within an
51application.
52
53%description -n python3-pebble -l pl.UTF-8
54Pebble udostępnia schludne API do zarządzania wątkami i procesami
55wewnątrz aplikacji.
56
57%prep
58%setup -q -n Pebble-%{version}
59
60%build
61%if %{with python2}
62%py_build
63
64%if %{with tests}
65%{__python} -m unittest discover -s test
66%endif
67%endif
68
69%if %{with python3}
70%py3_build
71
72%if %{with tests}
73%{__python3} -m unittest discover -s test
74%endif
75%endif
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%if %{with python2}
81%py_install
82
83%py_postclean
84%endif
85
86%if %{with python3}
87%py3_install
88%endif
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%if %{with python2}
94%files
95%defattr(644,root,root,755)
96%doc README.rst
97%{py_sitescriptdir}/pebble
98%{py_sitescriptdir}/Pebble-%{version}-py*.egg-info
99%endif
100
101%if %{with python3}
102%files -n python3-pebble
103%defattr(644,root,root,755)
104%doc README.rst
105%{py3_sitescriptdir}/pebble
106%{py3_sitescriptdir}/Pebble-%{version}-py*.egg-info
107%endif
This page took 0.10638 seconds and 4 git commands to generate.