]> git.pld-linux.org Git - packages/python-parallax.git/blame - python-parallax.spec
rebuild with python 3.10
[packages/python-parallax.git] / python-parallax.spec
CommitLineData
ef4f3fbb
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Parallax Python 2 module - execute commands and copy files over SSH to multiple machines at once
7Summary(pl.UTF-8): Moduł Pythona 2 Parallax - wykonywanie poleceń i kopiowanie plików przez SSH na wielu maszynach jednocześnie
8Name: python-parallax
9Version: 1.0.1
c6385024 10Release: 6
ef4f3fbb
JB
11License: BSD
12Group: Libraries/Python
13#Source0Download: https://pypi.python.org/simple/parallax
14Source0: https://files.pythonhosted.org/packages/source/p/parallax/parallax-%{version}.tar.gz
15# Source0-md5: d8fccb7c3465c19edb4b1a1836c15b75
16URL: https://pypi.python.org/pypi/parallax
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19BuildRequires: sed >= 4.0
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.6
22BuildRequires: python-setuptools
23%endif
24%if %{with python3}
25BuildRequires: python3-modules >= 1:3.2
26BuildRequires: python3-setuptools
27%endif
28Requires: python-modules >= 1:2.6
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Parallax SSH provides an interface to executing commands on multiple
34nodes at once using SSH. It also provides commands for sending and
35receiving files to multiple nodes using SCP.
36
37%description -l pl.UTF-8
38Parallax SSH udostępnia interfejs do wykonywania poleceń na wielu
39maszynach jednocześnie przy użyciu SSH. Udostępnia także polecenia do
40wysyłania i odbierania plików na wielu maszynach przy użyciu SCP
41
42%package -n python3-parallax
43Summary: Parallax Python 3 module - execute commands and copy files over SSH to multiple machines at once
44Summary(pl.UTF-8): Moduł Pythona 3 Parallax - wykonywanie poleceń i kopiowanie plików przez SSH na wielu maszynach jednocześnie
45Group: Libraries/Python
46Requires: python3-modules >= 1:3.2
47
48%description -n python3-parallax
49Parallax SSH provides an interface to executing commands on multiple
50nodes at once using SSH. It also provides commands for sending and
51receiving files to multiple nodes using SCP.
52
53%description -n python3-parallax -l pl.UTF-8
54Parallax SSH udostępnia interfejs do wykonywania poleceń na wielu
55maszynach jednocześnie przy użyciu SSH. Udostępnia także polecenia do
56wysyłania i odbierania plików na wielu maszynach przy użyciu SCP
57
58%prep
59%setup -q -n parallax-%{version}
60
61%build
62%if %{with python2}
63%py_build
64%{__sed} -i -e "s,'/usr/bin/parallax-askpass','/usr/bin/parallax-askpass-2'," build-2/lib/parallax/askpass_client.py
65%endif
66
67%if %{with python3}
68%py3_build
69%{__sed} -i -e "s,'/usr/bin/parallax-askpass','/usr/bin/parallax-askpass-3'," build-3/lib/parallax/askpass_client.py
70%endif
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75%if %{with python3}
76%py3_install
77%{__mv} $RPM_BUILD_ROOT%{_bindir}/parallax-askpass{,-3}
78%endif
79
80%if %{with python2}
81%py_install
82
83%py_postclean
84%{__mv} $RPM_BUILD_ROOT%{_bindir}/parallax-askpass{,-2}
85%endif
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%if %{with python2}
91%files
92%defattr(644,root,root,755)
93%doc AUTHORS COPYING README.md
94%attr(755,root,root) %{_bindir}/parallax-askpass-2
95%{py_sitescriptdir}/parallax
96%{py_sitescriptdir}/parallax-%{version}-py*.egg-info
97%endif
98
99%if %{with python3}
100%files -n python3-parallax
101%defattr(644,root,root,755)
102%doc AUTHORS COPYING README.md
103%attr(755,root,root) %{_bindir}/parallax-askpass-3
104%{py3_sitescriptdir}/parallax
105%{py3_sitescriptdir}/parallax-%{version}-py*.egg-info
106%endif
This page took 0.053915 seconds and 4 git commands to generate.