]> git.pld-linux.org Git - packages/python-osc.git/blame - python-osc.spec
rebuild with python 3.10
[packages/python-osc.git] / python-osc.spec
CommitLineData
3a0e0702
JK
1#
2#
3# Conditional build:
4%bcond_without tests # unit tests
5
6%define module pythonosc
7%define egg_name python_osc
8%define pypi_name python-osc
9Summary: Open Sound Control server and client implementations in pure Python
10Name: python-osc
11Version: 1.7.0
d98b6db7 12Release: 5
3a0e0702
JK
13License: public domain
14Group: Libraries/Python
15Source0: https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16# Source0-md5: d2d72048be1c98c226e55a62e284b976
17URL: https://github.com/attwad/python-osc
18BuildRequires: python3-modules
19BuildRequires: python3-setuptools
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Open Sound Control server and client implementations in pure Python.
27
28%package -n python3-osc
29Summary: Open Sound Control server and client implementations in pure Python
30Group: Libraries/Python
31Requires: python3-modules
32
33%description -n python3-osc
34Open Sound Control server and client implementations in pure Python.
35
36%prep
37%setup -q -n %{pypi_name}-%{version}
38
39%build
40%py3_build %{?with_tests:test}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44
45%py3_install
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files -n python3-osc
51%defattr(644,root,root,755)
52%doc LICENSE.txt README.rst
53%{py3_sitescriptdir}/%{module}
54%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.143368 seconds and 4 git commands to generate.