]> git.pld-linux.org Git - packages/python-oauthlib.git/blame - python-oauthlib.spec
use epoch 1 for python3 package
[packages/python-oauthlib.git] / python-oauthlib.spec
CommitLineData
ed0588c6
JK
1# Conditional build:
2%bcond_without python2 # build python 2 module
3%bcond_without python3 # build python 3 module
4#
fd8b22ee 5%define module oauthlib
ed0588c6
JK
6Summary: A generic, spec-compliant, thorough implementation of the OAuth request-signing logic
7Name: python-%{module}
bf1397ad 8Version: 2.0.7
decab7a0 9Release: 2
ed0588c6
JK
10License: BSD
11Group: Development/Languages/Python
12Source0: https://pypi.python.org/packages/source/o/oauthlib/%{module}-%{version}.tar.gz
bf1397ad 13# Source0-md5: 1fca21cda1c106ff4c5110cc355dca22
ed0588c6
JK
14URL: https://pypi.python.org/pypi/oauthlib
15%if %{with python2}
bf1397ad 16BuildRequires: python-setuptools
ed0588c6
JK
17BuildRequires: python-modules >= 1:2.6
18%endif
19%if %{with python3}
bf1397ad 20BuildRequires: python3-setuptools
5cae27c9 21BuildRequires: python3-modules >= 1:3.2
ed0588c6
JK
22%endif
23BuildRequires: rpm-pythonprov
c74b3761 24BuildRequires: rpmbuild(macros) >= 1.710
ed0588c6
JK
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29OAuthLib is a generic utility which implements the logic of OAuth
30without assuming a specific HTTP request object. Use it to graft OAuth
31support onto your favorite HTTP library. If you're a maintainer of
32such a library, write a thin veneer on top of OAuthLib and get OAuth
33support for very little effort.
34
35%package -n python3-oauthlib
36Summary: A generic, spec-compliant, thorough implementation of the OAuth request-signing logic
37Group: Development/Languages/Python
38
39%description -n python3-oauthlib
40OAuthLib is a generic utility which implements the logic of OAuth
41without assuming a specific HTTP request object. Use it to graft OAuth
42support onto your favorite HTTP library. If you're a maintainer of
43such a library, write a thin veneer on top of OAuthLib and get OAuth
44support for very little effort.
45
46%prep
47%setup -q -n %{module}-%{version}
48
49%build
50%if %{with python2}
fd8b22ee 51%py_build
ed0588c6
JK
52%endif
53
54%if %{with python3}
fd8b22ee 55%py3_build
ed0588c6
JK
56%endif
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%if %{with python2}
fd8b22ee 62%py_install
ed0588c6
JK
63%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
64%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
65%py_postclean
66%endif
67
68%if %{with python3}
fd8b22ee 69%py3_install
ed0588c6
JK
70%endif
71
ed0588c6
JK
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%if %{with python2}
76%files
77%defattr(644,root,root,755)
bf1397ad 78%doc README.rst CHANGELOG.rst
ed0588c6
JK
79%{py_sitescriptdir}/%{module}
80%if "%{py_ver}" > "2.4"
81%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
82%endif
83%endif
84
85%if %{with python3}
86%files -n python3-oauthlib
87%defattr(644,root,root,755)
bf1397ad 88%doc README.rst CHANGELOG.rst
ed0588c6
JK
89%{py3_sitescriptdir}/%{module}
90%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
91%endif
This page took 0.191103 seconds and 4 git commands to generate.