]> git.pld-linux.org Git - packages/python-numpydoc.git/blame - python-numpydoc.spec
- release 3 (by relup.sh)
[packages/python-numpydoc.git] / python-numpydoc.spec
CommitLineData
27a21b56 1# NOTE: for versions >= 1.0 see python3-numpydoc.spec
c2447f6d
JB
2#
3# Conditional build:
4%bcond_without tests # unit tests
5%bcond_without python2 # CPython 2.x module
27a21b56 6%bcond_with python3 # CPython 3.x module (built from python3-numpydoc.spec)
c2447f6d
JB
7
8Summary: Sphinx extension to support docstrings in Numpy format
9Summary(pl.UTF-8): Rozszerzenie Sphinksa do obsług docstringów w formacie Numpy
10Name: python-numpydoc
27a21b56 11# NOTE: keep 0.x here for python2 support
c2447f6d 12Version: 0.9.2
5e08cd6a 13Release: 3
c2447f6d
JB
14License: BSD
15Group: Libraries/Python
16#Source0Download: https://pypi.org/simple/numpydoc/
17Source0: https://files.pythonhosted.org/packages/source/n/numpydoc/numpydoc-%{version}.tar.gz
18# Source0-md5: d3320d808b8776727bac05b32fb24c82
19URL: https://pypi.org/project/numpydoc/
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.7
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-Sphinx >= 1.6.5
25BuildRequires: python-jinja2 >= 2.3
26BuildRequires: python-pytest
27%endif
28%endif
29%if %{with python3}
30BuildRequires: python3-modules >= 1:3.4
31BuildRequires: python3-setuptools
32%if %{with tests}
33BuildRequires: python3-Sphinx >= 1.6.5
34BuildRequires: python3-jinja2 >= 2.3
35BuildRequires: python3-pytest
36%endif
37%endif
38BuildRequires: rpm-pythonprov
39BuildRequires: rpmbuild(macros) >= 1.714
40Requires: python-modules >= 1:2.7
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45This package provides the numpydoc Sphinx extension for handling
46docstrings formatted according to the NumPy documentation format. The
47extension also adds the code description directives "np:function",
48"np-c:function", etc.
49
50%description -l pl.UTF-8
51Ten pakiet zawiera rozszerzenie Sphinksa do obsługi docstringów
52sformatowanych zgodnie z formatem dokumentacji NumPy. Rozszerzenie
53dodaje także dyrektywy opisu kodu "np:function", "np-c:function" itp.
54
55%package -n python3-numpydoc
56Summary: Sphinx extension to support docstrings in Numpy format
57Summary(pl.UTF-8): Rozszerzenie Sphinksa do obsług docstringów w formacie Numpy
58Group: Libraries/Python
59Requires: python3-modules >= 1:3.4
60
61%description -n python3-numpydoc
62This package provides the numpydoc Sphinx extension for handling
63docstrings formatted according to the NumPy documentation format. The
64extension also adds the code description directives "np:function",
65"np-c:function", etc.
66
67%description -n python3-numpydoc -l pl.UTF-8
68Ten pakiet zawiera rozszerzenie Sphinksa do obsługi docstringów
69sformatowanych zgodnie z formatem dokumentacji NumPy. Rozszerzenie
70dodaje także dyrektywy opisu kodu "np:function", "np-c:function" itp.
71
72%prep
73%setup -q -n numpydoc-%{version}
74
75%build
76%if %{with python2}
77%py_build
78
79%if %{with tests}
80%{__python} -m pytest numpydoc/tests
81%endif
82%endif
83
84%if %{with python3}
85%py3_build
86
87%if %{with tests}
88%{__python3} -m pytest numpydoc/tests
89%endif
90%endif
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with python2}
96%py_install
97
bc69b252 98%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/numpydoc/tests
c2447f6d
JB
99%py_postclean
100%endif
101
102%if %{with python3}
103%py3_install
bc69b252
JB
104
105%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/numpydoc/tests
c2447f6d
JB
106%endif
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%if %{with python2}
112%files
113%defattr(644,root,root,755)
114%doc LICENSE.txt README.rst
115%{py_sitescriptdir}/numpydoc
116%{py_sitescriptdir}/numpydoc-%{version}-py*.egg-info
117%endif
118
119%if %{with python3}
120%files -n python3-numpydoc
121%defattr(644,root,root,755)
122%doc LICENSE.txt README.rst
123%{py3_sitescriptdir}/numpydoc
124%{py3_sitescriptdir}/numpydoc-%{version}-py*.egg-info
125%endif
This page took 0.128144 seconds and 4 git commands to generate.