]> git.pld-linux.org Git - packages/python-numpy.git/blame - python-numpy.spec
- updated to 1.6.0
[packages/python-numpy.git] / python-numpy.spec
CommitLineData
87f01f56 1%define module numpy
5e1d6470 2Summary: Python numerical facilities
f1449ed4 3Summary(pl.UTF-8): Moduły do obliczeń numerycznych dla języka Python
82d8e1e3 4Name: python-%{module}
85179ece
JB
5Version: 1.6.0
6Release: 1
83090946 7Epoch: 1
31aec831 8License: BSD
afceca96 9Group: Libraries/Python
e527b87b 10Source0: http://downloads.sourceforge.net/numpy/%{module}-%{version}.tar.gz
85179ece 11# Source0-md5: e0993c74cb8e83292e560eac1a9be8e9
abd2761d 12URL: http://sourceforge.net/projects/numpy/
a8cca3fe 13BuildRequires: lapack-devel >= 3.1.1-2
969d7b9d 14BuildRequires: python-devel
a335318b 15BuildRequires: rpm-pythonprov
c8e56905 16%pyrequires_eq python-libs
83090946
JB
17# -- dropped some time ago
18Obsoletes: python-numpy-Properties
19# -- dropped some time ago, should have been released as separate package, but wasn't
20Obsoletes: python-numpy-kinds
4dafe483
JB
21# old subpackage, merged into main
22Obsoletes: python-numpy-FFT
e527b87b 23# -- dropped during Numeric->numpy transition (ma in main now?)
83090946
JB
24Obsoletes: python-numpy-MA
25Obsoletes: python-numpy-RNG
fed64725 26Requires: pydoc
87f01f56 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6c72420e
JR
28
29%description
30NumPy is a collection of extension modules to provide high-performance
31multidimensional numeric arrays to the Python programming language.
32
7511f32d
JR
33%description -l pl.UTF-8
34Pakiet umożliwia wydajne obliczenia numeryczne na macierzach
03eb708a 35wielowymiarowych.
6a1c76a9 36
82d8e1e3 37%package devel
6a1c76a9 38Summary: C header files for numerical modules
f1449ed4 39Summary(pl.UTF-8): Pliki nagłówkowe języka C modułów numerycznych
d3c60c72 40Group: Development/Languages/Python
c8e56905 41%pyrequires_eq python-devel
83090946 42Requires: %{name} = %{epoch}:%{version}-%{release}
82d8e1e3 43
44%description devel
6a1c76a9 45C header files for numerical modules.
46
7511f32d
JR
47%description devel -l pl.UTF-8
48Pliki nagłówkowe języka C modułów numerycznych.
82d8e1e3 49
03367c91 50%package numarray
25105dcf 51Summary: Array manipulation and computations for python
f1449ed4 52Summary(pl.UTF-8): Operacje i obliczenia na tablicach dla Pythona
25105dcf 53Group: Development/Languages/Python
03367c91
RT
54Requires: %{name} = %{epoch}:%{version}-%{release}
55
56%description numarray
57Numarray provides array manipulation and computational capabilities
58similar to those found in IDL, Matlab, or Octave. Using numarray, it
59is possible to write many efficient numerical data processing
60applications directly in Python without using any C, C++ or Fortran
61code (as well as doing such analysis interactively within Python or
62PyRAF). For algorithms that are not well suited for efficient
63computation using array facilities it is possible to write C functions
64(and eventually Fortran) that can read and write numarray arrays that
65can be called from Python.
66
67Numarray is a re-implementation of an older Python array module called
68Numeric. In general its interface is very similar. It is mostly
69backward compatible and will be becoming more so in future releases.
70
7511f32d
JR
71%description numarray -l pl.UTF-8
72Numarray zapewnia narzędzia do operacji oraz obliczeń na tablicach
73podobne do tych, jakie zapewniają IDL, Matlab czy Octave. Używając
74numarray możliwe jest stworzenie bezpośrednio w Pythonie, nie używając
25105dcf 75wstawek C, C++ czy fortranowych, wielu wydajnych aplikacji do
7511f32d
JR
76przetwarzania danych numerycznych. Dla algorytmów, które nie pracują
77wydajnie z tablicami, możliwe jest napisanie funkcji C, które mogą
78czytać i zapisywać tablice numarray, i które mogą być wywoływane z
03367c91
RT
79poziomu Pythona.
80
7511f32d
JR
81Numarray jest ponowną implementacją starszego modułu Pythona -
82Numeric. Interfejsy tych modułów są do siebie bardzo podobne. Numarray
83jest w większości przypadków kompatybilny wstecz, a sytuacja poprawi
84się w nowszych wersjach.
03367c91
RT
85
86%package numarray-devel
25105dcf 87Summary: Header files for python-numarray
f1449ed4 88Summary(pl.UTF-8): Pliki nagłówkowe dla python-numarray
25105dcf
JB
89Group: Development/Libraries
90Requires: %{name}-devel = %{epoch}:%{version}-%{release}
91Requires: %{name}-numarray = %{epoch}:%{version}-%{release}
03367c91
RT
92
93%description numarray-devel
94Header files for python-numarray.
95
7511f32d
JR
96%description numarray-devel -l pl.UTF-8
97Pliki nagłówkowe dla python-numarray.
03367c91
RT
98
99%package oldnumeric
85179ece
JB
100Summary: Modules providing backward compatibility with old Numeric packages
101Summary(pl.UTF-8): Moduły zapewniające wsteczną kompatybilność ze starymi pakietami Numeric
354ccf14 102Group: Libraries/Python
bfe98c22 103Requires: %{name} = %{epoch}:%{version}-%{release}
03367c91
RT
104
105%description oldnumeric
85179ece 106Modules providing backward compatibility with old Numeric packages.
03367c91 107
7511f32d 108%description oldnumeric -l pl.UTF-8
85179ece
JB
109Moduły zapewniające wsteczną kompatybilność ze starymi pakietami
110Numeric.
03367c91 111
d5273373
RT
112%package -n f2py
113Summary: Fortran to Python interface generator
f1449ed4 114Summary(pl.UTF-8): Generator interfejsów z Fortranu do Pythona
d5273373 115Group: Libraries/Python
bfe98c22 116Requires: %{name} = %{epoch}:%{version}-%{release}
d5273373
RT
117
118%description -n f2py
119Fortran to Python interface generator.
120
7511f32d
JR
121%description -n f2py -l pl.UTF-8
122Generator interfejsów z Fortranu do Pythona.
d5273373 123
6c72420e 124%prep
b254458b 125%setup -q -n %{module}-%{version}
6c72420e
JR
126
127%build
2fc4c2a8
AM
128CC="%{__cc}"; export CC
129CFLAGS="%{rpmcflags}"; export CFLAGS
31aec831 130%{__python} setup.py build
6c72420e
JR
131
132%install
d1d6da54 133rm -rf $RPM_BUILD_ROOT
6ca3085b 134
31aec831 135%{__python} setup.py install \
6ca3085b 136 --root=$RPM_BUILD_ROOT
137
6a274b9f 138%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
139%py_comp $RPM_BUILD_ROOT%{py_sitedir}
83090946 140
85179ece
JB
141%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/%{module}/doc
142%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*/{benchmarks,tests,docs}
83090946 143# already in f2py package
85179ece 144%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{module}/f2py/f2py.1
6c72420e
JR
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
6c72420e 149%files
6febf52f 150%defattr(644,root,root,755)
83090946 151%dir %{py_sitedir}/%{module}
4d445eeb 152%{py_sitedir}/%{module}/*.py
83090946 153%{py_sitedir}/%{module}/*.py[co]
c2261e45 154%dir %{py_sitedir}/%{module}/compat
4d445eeb 155%{py_sitedir}/%{module}/compat/*.py
c2261e45 156%{py_sitedir}/%{module}/compat/*.py[co]
83090946 157%dir %{py_sitedir}/%{module}/core
4d445eeb 158%{py_sitedir}/%{module}/core/*.py
83090946
JB
159%{py_sitedir}/%{module}/core/*.py[co]
160%attr(755,root,root) %{py_sitedir}/%{module}/core/*.so
161%dir %{py_sitedir}/%{module}/distutils
4d445eeb 162%{py_sitedir}/%{module}/distutils/*.py
83090946
JB
163%{py_sitedir}/%{module}/distutils/*.py[co]
164%dir %{py_sitedir}/%{module}/distutils/command
4d445eeb 165%{py_sitedir}/%{module}/distutils/command/*.py
83090946
JB
166%{py_sitedir}/%{module}/distutils/command/*.py[co]
167%dir %{py_sitedir}/%{module}/distutils/fcompiler
4d445eeb 168%{py_sitedir}/%{module}/distutils/fcompiler/*.py
83090946 169%{py_sitedir}/%{module}/distutils/fcompiler/*.py[co]
4dafe483 170%dir %{py_sitedir}/%{module}/fft
4d445eeb 171%{py_sitedir}/%{module}/fft/*.py
4dafe483 172%{py_sitedir}/%{module}/fft/*.py[co]
e527b87b 173%attr(755,root,root) %{py_sitedir}/%{module}/fft/fftpack_lite.so
83090946 174%dir %{py_sitedir}/%{module}/lib
4d445eeb 175%{py_sitedir}/%{module}/lib/*.py
83090946 176%{py_sitedir}/%{module}/lib/*.py[co]
e527b87b 177%attr(755,root,root) %{py_sitedir}/%{module}/lib/_compiled_base.so
83090946 178%dir %{py_sitedir}/%{module}/linalg
4d445eeb 179%{py_sitedir}/%{module}/linalg/*.py
83090946 180%{py_sitedir}/%{module}/linalg/*.py[co]
e527b87b
JB
181%attr(755,root,root) %{py_sitedir}/%{module}/linalg/lapack_lite.so
182%dir %{py_sitedir}/numpy/ma
4d445eeb 183%{py_sitedir}/numpy/ma/*.py
e527b87b 184%{py_sitedir}/numpy/ma/*.py[co]
c2261e45 185%dir %{py_sitedir}/%{module}/matrixlib
4d445eeb 186%{py_sitedir}/%{module}/matrixlib/*.py
c2261e45
JR
187%{py_sitedir}/%{module}/matrixlib/*.py[co]
188%dir %{py_sitedir}/%{module}/polynomial
4d445eeb 189%{py_sitedir}/%{module}/polynomial/*.py
c2261e45 190%{py_sitedir}/%{module}/polynomial/*.py[co]
83090946 191%dir %{py_sitedir}/%{module}/random
4d445eeb 192%{py_sitedir}/%{module}/random/*.py
83090946 193%{py_sitedir}/%{module}/random/*.py[co]
e527b87b 194%attr(755,root,root) %{py_sitedir}/%{module}/random/mtrand.so
83090946 195%dir %{py_sitedir}/%{module}/testing
4d445eeb 196%{py_sitedir}/%{module}/testing/*.py
83090946 197%{py_sitedir}/%{module}/testing/*.py[co]
e527b87b 198%dir %{py_sitedir}/%{module}/tests
4d445eeb 199%{py_sitedir}/%{module}/tests/*.py
e527b87b 200%{py_sitedir}/%{module}/tests/*.py[co]
969d7b9d 201%if "%{py_ver}" > "2.4"
e527b87b 202%{py_sitedir}/numpy-%{version}-py*.egg-info
969d7b9d 203%endif
82d8e1e3 204
205%files devel
206%defattr(644,root,root,755)
83090946 207%{py_sitedir}/%{module}/core/include
c2261e45 208%{py_sitedir}/%{module}/core/lib
83090946 209%{py_sitedir}/%{module}/random/*.h
82d8e1e3 210
03367c91
RT
211%files numarray
212%defattr(644,root,root,755)
03367c91 213%dir %{py_sitedir}/%{module}/numarray
4d445eeb 214%{py_sitedir}/%{module}/numarray/*.py
03367c91 215%{py_sitedir}/%{module}/numarray/*.py[co]
e527b87b 216%attr(755,root,root) %{py_sitedir}/%{module}/numarray/_capi.so
03367c91
RT
217
218%files numarray-devel
219%defattr(644,root,root,755)
e527b87b 220%{py_sitedir}/%{module}/numarray/include
03367c91
RT
221
222%files oldnumeric
223%defattr(644,root,root,755)
224%dir %{py_sitedir}/%{module}/oldnumeric
4d445eeb 225%{py_sitedir}/%{module}/oldnumeric/*.py
e527b87b 226%{py_sitedir}/%{module}/oldnumeric/*.py[co]
d5273373
RT
227
228%files -n f2py
229%defattr(644,root,root,755)
050b082e 230%attr(755,root,root) %{_bindir}/f2py
d5273373 231%dir %{py_sitedir}/%{module}/f2py
4d445eeb 232%{py_sitedir}/%{module}/f2py/*.py
d5273373
RT
233%{py_sitedir}/%{module}/f2py/*.py[co]
234%{py_sitedir}/%{module}/f2py/src
This page took 0.111641 seconds and 4 git commands to generate.