]> git.pld-linux.org Git - packages/python-nose_random.git/blame - python-nose_random.spec
rebuild with tests and docs
[packages/python-nose_random.git] / python-nose_random.spec
CommitLineData
c767b88a
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Random scenario testing in Nose
7Summary(pl.UTF-8): Testowanie losowych scenariuszy w Nose
8Name: python-nose_random
9Version: 1.0.0
a2d1ab60 10Release: 5
c767b88a
JB
11License: MIT
12Group: Libraries/Python
13#Source0Download: https://github.com/fzumstein/nose-random/releases
14Source0: https://github.com/fzumstein/nose-random/archive/%{version}/nose-random-%{version}.tar.gz
15# Source0-md5: 302e05c65601a0239aaf8616f39a4cd4
16URL: https://github.com/fzumstein/nose-random
17%if %{with python2}
18BuildRequires: python-modules >= 1:2.5
19BuildRequires: python-setuptools
20%endif
21%if %{with python3}
22BuildRequires: python3-modules >= 1:3.2
23BuildRequires: python3-setuptools
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27Requires: python-modules >= 1:2.5
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32nose-random is designed to facilitate Monte-Carlo style unit testing.
33The idea is to improve testing by running your code against a large
34number of randomly generated input scenarios.
35
36%description -l pl.UTF-8
37nose-random jest zaprojektowany, aby wspomóc testowanie jednostkowe w
38stylu Monte-Carlo. Idea ta polega na testowaniu przez uruchamianie
39kodu na dużej liczbie losowo wygenerowanych scenariuszy wejściowych.
40
41%package -n python3-nose_random
42Summary: Random scenario testing in Nose
43Summary(pl.UTF-8): Testowanie losowych scenariuszy w Nose
44Group: Libraries/Python
45Requires: python3-modules >= 1:3.2
46
47%description -n python3-nose_random
48nose-random is designed to facilitate Monte-Carlo style unit testing.
49The idea is to improve testing by running your code against a large
50number of randomly generated input scenarios.
51
52%description -n python3-nose_random -l pl.UTF-8
53nose-random jest zaprojektowany, aby wspomóc testowanie jednostkowe w
54stylu Monte-Carlo. Idea ta polega na testowaniu przez uruchamianie
55kodu na dużej liczbie losowo wygenerowanych scenariuszy wejściowych.
56
57%prep
58%setup -q -n nose-random-%{version}
59
60%build
61%if %{with python2}
62%py_build
63%endif
64
65%if %{with python3}
66%py3_build
67%endif
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%if %{with python2}
73%py_install
74
75install -d $RPM_BUILD_ROOT%{_examplesdir}/python-nose_random-%{version}
76cp -p examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-nose_random-%{version}
77
78%py_postclean
79%endif
80
81%if %{with python3}
82%py3_install
83
84install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-nose_random-%{version}
85cp -p examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python3-nose_random-%{version}
86%endif
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%if %{with python2}
92%files
93%defattr(644,root,root,755)
94%doc LICENSE README.md
95%{py_sitescriptdir}/nose_random
96%{py_sitescriptdir}/nose_random-0.0.1-py*.egg-info
97%{_examplesdir}/python-nose_random-%{version}
98%endif
99
100%if %{with python3}
101%files -n python3-nose_random
102%defattr(644,root,root,755)
103%doc LICENSE README.md
104%{py3_sitescriptdir}/nose_random
105%{py3_sitescriptdir}/nose_random-0.0.1-py*.egg-info
106%{_examplesdir}/python3-nose_random-%{version}
107%endif
This page took 0.08883 seconds and 4 git commands to generate.