]> git.pld-linux.org Git - packages/python-nose.git/blame - python-nose.spec
- ver. 1.2.1
[packages/python-nose.git] / python-nose.spec
CommitLineData
4152e925
JB
1%define module nose
2Summary: A unittest extension with automatic discovery, simplified authoring, and output capture
17f3e186 3Summary(pl.UTF-8): Rozszerzenie testów jednostkowych z automatycznym wykrywaniem, prostym tworzeniem i przechwytywaniem wyjścia
7a4b823d 4Name: python-%{module}
3fc655fa 5Version: 1.2.1
6Release: 1
7a4b823d 7License: LGPL
4152e925 8Group: Libraries/Python
4d98eb48 9Source0: http://pypi.python.org/packages/source/n/%{module}/%{module}-%{version}.tar.gz
3fc655fa 10# Source0-md5: 735e3f1ce8b07e70ee1b742a8a53585a
4d98eb48 11URL: http://pypi.python.org/pypi/nose
552ed67c 12BuildRequires: python-devel
57dece19 13BuildRequires: python-devel-tools >= 1:2.5
e7ca811c 14BuildRequires: python-setuptools >= 0.6-0.c5
4d98eb48 15BuildRequires: python3-devel
16BuildRequires: python3-devel-tools >= 1:2.5
17BuildRequires: python3-distribute
4152e925
JB
18BuildRequires: rpm-pythonprov
19%pyrequires_eq python-devel-tools
20BuildArch: noarch
7a4b823d 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
4152e925
JB
24nose provides an alternate test discovery and running process for
25unittest, one that is intended to mimic the behavior of py.test as
26much as is reasonably possible without resorting to magic. By default,
27nose will run tests in files or directories under the current working
28directory whose names include "test". nose also supports doctest tests
29and may optionally provide a test coverage report.
30
dc177ea3
JR
31%description -l pl.UTF-8
32nose dostarcza alternatywny proces wykrywania i uruchamiania testów
33dla testów jednostkowych (unittest), mający przypominać zachowanie
34py.test na ile to możliwe bez uciekania się do magii. Domyślnie nose
35uruchamia testy z tych plików lub katalogów od bieżącego katalogu,
36których nazwa zawiera "test". Obsługuje także testy doctest i
37opcjonalnie przedstawia raport pokrycia testów.
7a4b823d 38
4d98eb48 39%package -n python3-%{module}
40Summary: Serial port interface module
41Version: %{version}
42Release: %{release}
43Group: Libraries/Python
44
45%description -n python3-%{module}
46nose provides an alternate test discovery and running process for
47unittest, one that is intended to mimic the behavior of py.test as
48much as is reasonably possible without resorting to magic. By default,
49nose will run tests in files or directories under the current working
50directory whose names include "test". nose also supports doctest tests
51and may optionally provide a test coverage report.
52
d5647e41
AM
53%define _duplicate_files_terminate_build 0
54
7a4b823d 55%prep
56%setup -qn %{module}-%{version}
57
58%build
4d98eb48 59%{__python} setup.py build --build-base py2
60%{__python3} setup.py build --build-base py3
552ed67c 61
7a4b823d 62%install
63rm -rf $RPM_BUILD_ROOT
64
4d98eb48 65%{__python} setup.py build \
66 --build-base py2 \
67 install \
68 --root=$RPM_BUILD_ROOT \
69 --optimize=2
70
71%{__python3} setup.py build \
72 --build-base py3 \
73 install \
7a4b823d 74 --root=$RPM_BUILD_ROOT \
75 --optimize=2
4152e925 76
e7ca811c 77mv $RPM_BUILD_ROOT%{_prefix}/man/ $RPM_BUILD_ROOT%{_datadir}
78
4152e925
JB
79%py_postclean
80
7a4b823d 81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
4d98eb48 86%attr(755,root,root) %{_bindir}/nosetests-2.7
7a4b823d 87%{py_sitescriptdir}/%{module}
7502f64b 88%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
d8fb88d9 89%{_mandir}/man1/*
4d98eb48 90
91%files -n python3-%{module}
92%defattr(644,root,root,755)
42c6135b 93%attr(755,root,root) %{_bindir}/nosetests-3.?
4d98eb48 94%{py3_sitescriptdir}/%{module}
95%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
96%{_mandir}/man1/*
This page took 0.076098 seconds and 4 git commands to generate.