]> git.pld-linux.org Git - packages/python-neovim.git/blame - python-neovim.spec
up to 0.4.3
[packages/python-neovim.git] / python-neovim.spec
CommitLineData
1f20e90c
ER
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module neovim
99bb3400 7%define egg_name pynvim
1f20e90c
ER
8Summary: Python client to neovim
9Name: python-%{module}
99bb3400
JP
10Version: 0.4.3
11Release: 1
1f20e90c
ER
12License: Apache v2.0
13Group: Libraries/Python
14Source0: https://github.com/neovim/python-client/archive/%{version}/%{name}-%{version}.tar.gz
99bb3400 15# Source0-md5: b7370a5b3d2177d2b97ca48695ba1ae3
1f20e90c
ER
16URL: https://github.com/neovim/python-client
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with python2}
20BuildRequires: python-modules
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-modules
25BuildRequires: python3-setuptools
26%endif
1f20e90c
ER
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Implements support for Python plugins in nvim
32
33%package -n python3-neovim
34Summary: Python client to neovim
35Group: Libraries/Python
1f20e90c
ER
36
37%description -n python3-neovim
38Implements support for Python plugins in nvim
39
40%prep
99bb3400 41%setup -q -n pynvim-%{version}
1f20e90c
ER
42
43%build
44%if %{with python2}
45%py_build
46%endif
47
48%if %{with python3}
49%py3_build
50%endif
51
52%install
53rm -rf $RPM_BUILD_ROOT
54%if %{with python2}
55%py_install
56%py_postclean
57%endif
58
59%if %{with python3}
60%py3_install
61%endif
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
37cb4f8e 66%if %{with python2}
1f20e90c
ER
67%files
68%defattr(644,root,root,755)
69%doc README.md
70%{py_sitescriptdir}/%{module}
99bb3400 71%{py_sitescriptdir}/pynvim
1f20e90c
ER
72%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
73%endif
74
75%if %{with python3}
76%files -n python3-neovim
77%defattr(644,root,root,755)
78%doc README.md
79%{py3_sitescriptdir}/%{module}
99bb3400 80%{py3_sitescriptdir}/pynvim
1f20e90c
ER
81%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
82%endif
This page took 0.085954 seconds and 4 git commands to generate.