]> git.pld-linux.org Git - packages/python-mypy_extensions.git/blame - python-mypy_extensions.spec
rebuild with python 3.10
[packages/python-mypy_extensions.git] / python-mypy_extensions.spec
CommitLineData
7083c0f7
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Experimental type system extensions for programs checked with the mypy typechecker
7Summary(pl.UTF-8): Eksperymentalne rozszerzenia systemu typowania dla programów sprawdzanych narzędziem mypy
8Name: python-mypy_extensions
9Version: 0.4.3
c9ddafb1 10Release: 3
7083c0f7
JB
11License: MIT
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/mypy-extensions/
14Source0: https://files.pythonhosted.org/packages/source/m/mypy-extensions/mypy_extensions-%{version}.tar.gz
15# Source0-md5: 4163ff73d0db8631c0a78bb55b551c84
16URL: https://pypi.org/project/mypy-extensions/
17%if %{with python2}
18BuildRequires: python-modules >= 1:2.7
19BuildRequires: python-setuptools
20%endif
21%if %{with python3}
22BuildRequires: python3-modules >= 1:3.4
23BuildRequires: python3-setuptools
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27Requires: python-modules >= 1:2.7
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32The "mypy_extensions" module defines experimental extensions to the
33standard "typing" module that are supported by the mypy typechecker.
34
35%description -l pl.UTF-8
36Moduł "mypy_extensions" definiuje eksperymentalne rozszerzenia
37standardowego modułu "typing", obsługiwane przez narzędzie do
38kontroli typów mypy.
39
40%package -n python3-mypy_extensions
41Summary: Experimental type system extensions for programs checked with the mypy typechecker
42Summary(pl.UTF-8): Eksperymentalne rozszerzenia systemu typowania dla programów sprawdzanych narzędziem mypy
43Group: Libraries/Python
44Requires: python3-modules >= 1:3.4
45
46%description -n python3-mypy_extensions
47The "mypy_extensions" module defines experimental extensions to the
48standard "typing" module that are supported by the mypy typechecker.
49
50%description -n python3-mypy_extensions -l pl.UTF-8
51Moduł "mypy_extensions" definiuje eksperymentalne rozszerzenia
52standardowego modułu "typing", obsługiwane przez narzędzie do
53kontroli typów mypy.
54
7083c0f7
JB
55%prep
56%setup -q -n mypy_extensions-%{version}
57
58%build
59%if %{with python2}
60%py_build
61%endif
62
63%if %{with python3}
64%py3_build
65%endif
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%if %{with python2}
71%py_install
72
73%py_postclean
74%endif
75
76%if %{with python3}
77%py3_install
78%endif
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%if %{with python2}
84%files
85%defattr(644,root,root,755)
86%doc LICENSE README.md
87%{py_sitescriptdir}/mypy_extensions.py[co]
88%{py_sitescriptdir}/mypy_extensions-%{version}-py*.egg-info
89%endif
90
91%if %{with python3}
92%files -n python3-mypy_extensions
93%defattr(644,root,root,755)
94%doc LICENSE README.md
95%{py3_sitescriptdir}/mypy_extensions.py
96%{py3_sitescriptdir}/__pycache__/mypy_extensions.cpython-*.py[co]
97%{py3_sitescriptdir}/mypy_extensions-%{version}-py*.egg-info
98%endif
This page took 0.10445 seconds and 4 git commands to generate.