]> git.pld-linux.org Git - packages/python-musicbrainzngs.git/blame - python-musicbrainzngs.spec
rebuild with python 3.10
[packages/python-musicbrainzngs.git] / python-musicbrainzngs.spec
CommitLineData
a93ba8bd
JP
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Python 2 bindings for the MusicBrainz NGS and the Cover Art Archive webservices
7Name: python-musicbrainzngs
623c1dde 8Version: 0.7.1
905b6639 9Release: 2
a93ba8bd
JP
10License: BSD
11Group: Libraries/Python
12#Source0Download: https://pypi.python.org/simple/musicbrainzngs
623c1dde
JP
13Source0: https://files.pythonhosted.org/packages/source/m/musicbrainzngs/musicbrainzngs-%{version}.tar.gz
14# Source0-md5: 3bb83143ddf39a6e6b807a79b9ed97b5
a93ba8bd
JP
15URL: https://python-musicbrainzngs.readthedocs.org/
16%if %{with python2}
17BuildRequires: python-modules >= 1:2.7
18BuildRequires: python-setuptools
19%endif
20%if %{with python3}
21BuildRequires: python3-modules >= 1:3.3
22BuildRequires: python3-setuptools
23%endif
24BuildRequires: rpm-pythonprov
25BuildRequires: rpmbuild(macros) >= 1.714
26Requires: python-modules >= 1:2.7
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31This library implements webservice bindings for the Musicbrainz NGS
32site, also known as /ws/2 and the Cover Art Archive.
33
34%package -n python3-musicbrainzngs
35Summary: Python 3 bindings for the MusicBrainz NGS and the Cover Art Archive webservices
36Group: Libraries/Python
37Requires: python3-modules >= 1:3.3
38
39%description -n python3-musicbrainzngs
40This library implements webservice bindings for the Musicbrainz NGS
41site, also known as /ws/2 and the Cover Art Archive.
42
43%prep
44%setup -q -n musicbrainzngs-%{version}
45
46%build
47%if %{with python2}
48%py_build
49%endif
50
51%if %{with python3}
52%py3_build
53%endif
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%if %{with python2}
59%py_install
60
61%py_postclean
62%endif
63
64%if %{with python3}
65%py3_install
66%endif
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%if %{with python2}
72%files
73%defattr(644,root,root,755)
74%doc CHANGES COPYING README.rst
75%{py_sitescriptdir}/musicbrainzngs
76%{py_sitescriptdir}/musicbrainzngs-%{version}-py*.egg-info
77%endif
78
79%if %{with python3}
80%files -n python3-musicbrainzngs
81%defattr(644,root,root,755)
82%doc CHANGES COPYING README.rst
83%{py3_sitescriptdir}/musicbrainzngs
84%{py3_sitescriptdir}/musicbrainzngs-%{version}-py*.egg-info
85%endif
This page took 0.12245 seconds and 4 git commands to generate.