]> git.pld-linux.org Git - packages/python-monotonic.git/blame - python-monotonic.spec
rebuild with python 3.10
[packages/python-monotonic.git] / python-monotonic.spec
CommitLineData
6de66cc6
JK
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
e1a75b88
JB
6Summary: An implementation of time.monotonic() for Python 2
7Summary(pl.UTF-8): Implementacja time.monotinic() dla Pythona 2
6de66cc6 8Name: python-monotonic
6a3243f7 9Version: 1.6
43d13fba 10Release: 3
e1a75b88 11License: Apache v2.0
6de66cc6 12Group: Libraries/Python
e1a75b88 13#Source0Download: https://pypi.org/simple/monotonic/
6de66cc6 14Source0: https://files.pythonhosted.org/packages/source/m/monotonic/monotonic-%{version}.tar.gz
6a3243f7 15# Source0-md5: 9fbb889cdc67cb909046e8e366c9fea1
e1a75b88 16URL: https://pypi.org/project/monotonic/
6de66cc6
JK
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with python2}
e1a75b88 20BuildRequires: python-modules >= 1:2.5
6de66cc6
JK
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
e1a75b88 24BuildRequires: python3-modules >= 1:3.2
6de66cc6
JK
25BuildRequires: python3-setuptools
26%endif
e1a75b88 27Requires: python-modules >= 1:2.5
6de66cc6
JK
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32This module provides a monotonic() function which returns the value
33(in fractional seconds) of a clock which never goes backwards.
34
35On Python 3.3 or newer, monotonic will be an alias of time.monotonic
36from the standard library. On older versions, it will fall back to an
37equivalent implementation.
38
39%description -l pl.UTF-8
e1a75b88
JB
40Ten moduł udostępnia funkcję monotonic(), zwracającą wartość (w
41ułamkach sekundy) zegara, który nigdy się nie cofa.
42
43Dla Pythona 3.3 lub nowszego monotonic będzie aliasem dla funkcji
44time.monotonic z biblioteki standardowej. Dla starszych wersji
45odwołuje się do równoważnej implementacji.
6de66cc6
JK
46
47%package -n python3-monotonic
e1a75b88
JB
48Summary: An implementation of time.monotonic() for Python < 3.3
49Summary(pl.UTF-8): Implementacja time.monotinic() dla Pythona < 3.3
6de66cc6 50Group: Libraries/Python
e1a75b88 51Requires: python3-modules >= 1:3.2
6de66cc6
JK
52
53%description -n python3-monotonic
54This module provides a monotonic() function which returns the value
55(in fractional seconds) of a clock which never goes backwards.
56
57On Python 3.3 or newer, monotonic will be an alias of time.monotonic
58from the standard library. On older versions, it will fall back to an
59equivalent implementation.
60
e1a75b88
JB
61%description -n python3-monotonic -l pl.UTF-8
62Ten moduł udostępnia funkcję monotonic(), zwracającą wartość (w
63ułamkach sekundy) zegara, który nigdy się nie cofa.
64
65Dla Pythona 3.3 lub nowszego monotonic będzie aliasem dla funkcji
66time.monotonic z biblioteki standardowej. Dla starszych wersji
67odwołuje się do równoważnej implementacji.
68
6de66cc6
JK
69%prep
70%setup -q -n monotonic-%{version}
71
72%build
73%if %{with python2}
e1a75b88 74%py_build
6de66cc6
JK
75%endif
76
77%if %{with python3}
e1a75b88 78%py3_build
6de66cc6
JK
79%endif
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84%if %{with python2}
85%py_install
86
87%py_postclean
88%endif
89
90%if %{with python3}
91%py3_install
92%endif
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%if %{with python2}
98%files
99%defattr(644,root,root,755)
e1a75b88 100%doc README.md
6de66cc6
JK
101%{py_sitescriptdir}/monotonic.py[co]
102%{py_sitescriptdir}/monotonic-%{version}-py*.egg-info
103%endif
104
105%if %{with python3}
106%files -n python3-monotonic
107%defattr(644,root,root,755)
e1a75b88 108%doc README.md
6de66cc6 109%{py3_sitescriptdir}/monotonic.py
e1a75b88 110%{py3_sitescriptdir}/__pycache__/monotonic.cpython-*.py[co]
6de66cc6
JK
111%{py3_sitescriptdir}/monotonic-%{version}-py*.egg-info
112%endif
This page took 0.116714 seconds and 4 git commands to generate.