]> git.pld-linux.org Git - packages/python-medusa.git/blame - python-medusa.spec
initial release
[packages/python-medusa.git] / python-medusa.spec
CommitLineData
750ce8df 1
2%include /usr/lib/rpm/macros.python
3%define pname medusa
4
5%define py_ver 2.3
6%define py_prefix %{_prefix}
7%define py_scriptdir %{py_prefix}/share/python%{py_ver}
8%define py_sitescriptdir %{py_scriptdir}/site-packages
9
10Summary: Framework for writing asynchronous socket-based servers.
11Name: python-%{pname}
12Version: 0.5.4
13Release: 1
14License: UNKNOWN
15Vendor: Robin Dunn <robin@alldunn.com>
16Group: Development/Languages/Python
17Source0: http://www.amk.ca/files/python/%{pname}-%{version}.tar.gz
18# Source0-md5: 5d10505036bc38f8d4cb51d87516e069
19URL: http://www.amk.ca/python/code/medusa.html
20BuildRequires: python-devel >= 2.3
21BuildRequires: rpm-pythonprov
22%pyrequires_eq python-modules
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Medusa is an architecture for very-high-performance TCP/IP servers
27(like HTTP, FTP, and SMTP). Medusa is different from most other servers
28because it runs as a single process, multiplexing I/O with its various
29client and server connections within a single process/thread.
30
31%prep
32%setup -q -n %{pname}-%{version}
33
34%build
35env CFLAGS="%{rpmcflags}" python setup.py build
36
37%install
38rm -rf $RPM_BUILD_ROOT
39python -- setup.py install --root=$RPM_BUILD_ROOT --optimize=2
40
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%files
46%defattr(644,root,root,755)
47%doc README.txt TODO.txt CHANGES.txt LICENSE.txt docs
48%{py_sitescriptdir}/%{pname}
This page took 0.101085 seconds and 4 git commands to generate.