]> git.pld-linux.org Git - packages/python-lazy-object-proxy.git/blame - python-lazy-object-proxy.spec
- disabled python3 here
[packages/python-lazy-object-proxy.git] / python-lazy-object-proxy.spec
CommitLineData
1256c147
JK
1#
2# Conditional build:
747737d3 3%bcond_without doc # Sphinx documentation
1256c147 4%bcond_without python2 # CPython 2.x module
58a0e109 5%bcond_with python3 # CPython 3.x module (built from python3-lazy-object-proxy.spec)
1256c147
JK
6
7%define module lazy-object-proxy
8Summary: A fast and thorough lazy object proxy
747737d3 9Summary(pl.UTF-8): Szybkie i gruntowne leniwe proxy obiektów
1256c147 10Name: python-%{module}
5e0884b7
JB
11# keep 1.6.x here for python2 support
12Version: 1.6.0
cb57130d 13Release: 4
1256c147
JK
14License: BSD
15Group: Libraries/Python
747737d3
JB
16#Source0Download: https://pypi.org/simple/lazy-object-proxy/
17Source0: https://files.pythonhosted.org/packages/source/l/lazy-object-proxy/%{module}-%{version}.tar.gz
5e0884b7 18# Source0-md5: 0b99101615658aa711cb55c8db4930d5
1256c147
JK
19URL: https://github.com/ionelmc/python-lazy-object-proxy
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
747737d3 23BuildRequires: python-devel >= 1:2.7
9e6295ae 24BuildRequires: python-setuptools >= 1:30.3.0
747737d3 25BuildRequires: python-setuptools_scm >= 3.3.1
1256c147
JK
26%endif
27%if %{with python3}
747737d3 28BuildRequires: python3-devel >= 1:3.4
9e6295ae 29BuildRequires: python3-setuptools >= 1:30.3.0
747737d3 30BuildRequires: python3-setuptools_scm >= 3.3.1
1256c147 31%endif
747737d3 32%if %{with doc}
5e0884b7
JB
33BuildRequires: python-sphinx_py3doc_enhanced_theme
34BuildRequires: sphinx-pdg-2 >= 1.3
747737d3
JB
35%endif
36Requires: python-modules >= 1:2.7
1256c147
JK
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40A fast and thorough lazy object proxy.
41
747737d3
JB
42%description -l pl.UTF-8
43Szybkie i gruntowne leniwe proxy obiektów.
44
1256c147
JK
45%package -n python3-%{module}
46Summary: A fast and thorough lazy object proxy
747737d3 47Summary(pl.UTF-8): Szybkie i gruntowne leniwe proxy obiektów
1256c147 48Group: Libraries/Python
747737d3 49Requires: python3-modules >= 1:3.4
1256c147
JK
50
51%description -n python3-%{module}
52A fast and thorough lazy object proxy.
53
747737d3
JB
54%description -n python3-%{module} -l pl.UTF-8
55Szybkie i gruntowne leniwe proxy obiektów.
56
1256c147 57%package apidocs
747737d3
JB
58Summary: API documentation for lazy_object_proxy module
59Summary(pl.UTF-8): Dokumentacja API modułu lazy_object_proxy
1256c147
JK
60Group: Documentation
61
62%description apidocs
747737d3 63API documentation for lazy_object_proxy module.
1256c147
JK
64
65%description apidocs -l pl.UTF-8
747737d3 66Dokumentacja API modułu lazy_object_proxy.
1256c147
JK
67
68%prep
69%setup -q -n %{module}-%{version}
70
71%build
72%if %{with python2}
73%py_build
74%endif
75
76%if %{with python3}
77%py3_build
78%endif
79
80%if %{with doc}
5e0884b7 81sphinx-build-2 -b html docs docs/_build
1256c147
JK
82%endif
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87%if %{with python2}
88%py_install
747737d3 89
1256c147 90%py_postclean
1256c147
JK
91%endif
92
93%if %{with python3}
94%py3_install
1256c147
JK
95%endif
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%if %{with python2}
101%files
102%defattr(644,root,root,755)
747737d3 103%doc AUTHORS.rst CHANGELOG.rst LICENSE README.rst
1256c147
JK
104%dir %{py_sitedir}/lazy_object_proxy
105%{py_sitedir}/lazy_object_proxy/*.py[co]
747737d3 106%attr(755,root,root) %{py_sitedir}/lazy_object_proxy/cext.so
1256c147
JK
107%{py_sitedir}/lazy_object_proxy-%{version}-py*.egg-info
108%endif
109
110%if %{with python3}
111%files -n python3-%{module}
112%defattr(644,root,root,755)
747737d3 113%doc AUTHORS.rst CHANGELOG.rst LICENSE README.rst
1256c147
JK
114%dir %{py3_sitedir}/lazy_object_proxy
115%{py3_sitedir}/lazy_object_proxy/*.py
747737d3 116%attr(755,root,root) %{py3_sitedir}/lazy_object_proxy/cext.cpython-*.so
1256c147
JK
117%{py3_sitedir}/lazy_object_proxy/__pycache__
118%{py3_sitedir}/lazy_object_proxy-%{version}-py*.egg-info
119%endif
120
121%if %{with doc}
122%files apidocs
123%defattr(644,root,root,755)
747737d3 124%doc docs/_build/{_static,*.html,*.js}
1256c147 125%endif
This page took 0.216403 seconds and 4 git commands to generate.