]> git.pld-linux.org Git - packages/python-kombu.git/blame - python-kombu.spec
- updated to 4.6.11, enabled doc and tests
[packages/python-kombu.git] / python-kombu.spec
CommitLineData
44562528
JK
1#
2# Conditional build:
aae8302a
JB
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
44562528
JK
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
be70ea90 8%define module kombu
44562528 9Summary: Messaging library for Python
aae8302a 10Summary(pl.UTF-8): Biblioteka komunikatów dla Pythona
be70ea90 11Name: python-%{module}
aae8302a 12Version: 4.6.11
4f09112b 13Release: 1
be70ea90 14License: BSD-like
15Group: Development/Languages/Python
aae8302a
JB
16#Source0Download: https://pypi.org/simple/kombu/
17Source0: https://files.pythonhosted.org/packages/source/k/kombu/%{module}-%{version}.tar.gz
18# Source0-md5: 759b31d97fc11c4cb16f6d293723e85e
19URL: https://pypi.org/project/kombu/
44562528 20%if %{with python2}
f5b96fc9 21BuildRequires: python-modules >= 1:2.7
aae8302a
JB
22BuildRequires: python-setuptools >= 1:20.6.7
23%if %{with tests}
24BuildRequires: python-Pyro4
25BuildRequires: python-amqp >= 2.6.0
26BuildRequires: python-botocore
27BuildRequires: python-case >= 1.5.2
28BuildRequires: python-importlib_metadata >= 0.18
44562528 29BuildRequires: python-nose
aae8302a
JB
30BuildRequires: python-pytest
31BuildRequires: python-pytz
44562528
JK
32%endif
33%endif
34%if %{with python3}
aae8302a
JB
35BuildRequires: python3-modules >= 1:3.5
36BuildRequires: python3-setuptools >= 1:20.6.7
44562528 37%if %{with tests}
aae8302a
JB
38BuildRequires: python3-Pyro4
39BuildRequires: python3-amqp >= 2.6.0
40BuildRequires: python3-amqp < 2.7
41BuildRequires: python3-botocore
42BuildRequires: python3-case >= 1.5.2
43%if "%{py3_ver}" < "3.8"
44BuildRequires: python3-importlib_metadata >= 0.18
45%endif
44562528 46BuildRequires: python3-nose
44562528 47%endif
65a38e1a 48%endif
aae8302a
JB
49BuildRequires: rpm-pythonprov
50BuildRequires: rpmbuild(macros) >= 1.714
51%if %{with doc}
52BuildRequires: python-amqp
53BuildRequires: python-sphinx_celery
54BuildRequires: python-sphinxcontrib-issuetracker
55BuildRequires: sphinx-pdg-2
44562528 56%endif
aae8302a 57Requires: python-modules >= 1:2.7
be70ea90 58BuildArch: noarch
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
333ebabd 62The aim of Kombu is to make messaging in Python as easy as possible by
44562528 63providing an idiomatic high-level interface for the AMQ protocol, and
333ebabd 64also provide proven and tested solutions to common messaging problems.
be70ea90 65
aae8302a
JB
66%description -l pl.UTF-8
67Celem Kombu jest jak największe ułatwienie wymiany komunikatów w
68Pythonie poprzez dostarczenie idomatycznego, wysokopoziomowego
69interfejsu do protokołu AMQ oraz sprawdzonych rozwiązań powszechnych
70problemów związanych z komunikowaniem.
71
44562528
JK
72%package -n python3-%{module}
73Summary: Messaging library for Python
aae8302a 74Summary(pl.UTF-8): Biblioteka komunikatów dla Pythona
44562528 75Group: Libraries/Python
aae8302a 76Requires: python3-modules >= 1:3.5
44562528
JK
77
78%description -n python3-%{module}
79The aim of Kombu is to make messaging in Python as easy as possible by
80providing an idiomatic high-level interface for the AMQ protocol, and
81also provide proven and tested solutions to common messaging problems.
82
aae8302a
JB
83%description -n python3-%{module} -l pl.UTF-8
84Celem Kombu jest jak największe ułatwienie wymiany komunikatów w
85Pythonie poprzez dostarczenie idomatycznego, wysokopoziomowego
86interfejsu do protokołu AMQ oraz sprawdzonych rozwiązań powszechnych
87problemów związanych z komunikowaniem.
88
44562528 89%package apidocs
aae8302a
JB
90Summary: API documentation for kombu module
91Summary(pl.UTF-8): Dokumentacja API modułu kombu
44562528 92Group: Documentation
aae8302a 93Obsoletes: python3-kombu-apidocs < 5
44562528
JK
94
95%description apidocs
aae8302a 96API documentation for kombu module.
44562528
JK
97
98%description apidocs -l pl.UTF-8
aae8302a 99Dokumentacja API modułu kombu.
65a38e1a 100
be70ea90 101%prep
102%setup -q -n %{module}-%{version}
103
104%build
44562528 105%if %{with python2}
aae8302a 106%py_build
44562528 107
aae8302a
JB
108%if %{with tests}
109PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
110PYTEST_PLUGINS="case.pytest" \
111%{__python} -m pytest t/unit
44562528
JK
112%endif
113%endif
114
115%if %{with python3}
aae8302a 116%py3_build
65a38e1a 117
aae8302a
JB
118%if %{with tests}
119PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
120PYTEST_PLUGINS="case.pytest" \
121%{__python3} -m pytest t/unit
65a38e1a 122%endif
44562528 123%endif
be70ea90 124
aae8302a
JB
125%if %{with doc}
126%{__make} -C docs html \
127 SPHINXBUILD=sphinx-build-2
128%endif
129
be70ea90 130%install
131rm -rf $RPM_BUILD_ROOT
44562528
JK
132
133%if %{with python2}
d357e5f5 134%py_install
be70ea90 135
136%py_postclean
44562528
JK
137%endif
138
139%if %{with python3}
d357e5f5 140%py3_install
44562528 141%endif
be70ea90 142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
65a38e1a 146%if %{with python2}
be70ea90 147%files
14a88007 148%defattr(644,root,root,755)
4f09112b 149%doc AUTHORS FAQ LICENSE README.rst THANKS TODO
14a88007 150%{py_sitescriptdir}/%{module}
14a88007 151%{py_sitescriptdir}/%{module}-*.egg-info
65a38e1a
JK
152%endif
153
154%if %{with python3}
44562528
JK
155%files -n python3-%{module}
156%defattr(644,root,root,755)
4f09112b 157%doc AUTHORS FAQ LICENSE README.rst THANKS TODO
44562528
JK
158%{py3_sitescriptdir}/%{module}
159%{py3_sitescriptdir}/%{module}-*.egg-info
aae8302a 160%endif
44562528
JK
161
162%if %{with doc}
aae8302a 163%files apidocs
44562528 164%defattr(644,root,root,755)
aae8302a 165%doc docs/_build/html/{_modules,_static,reference,userguide,*.html,*.js}
14a88007 166%endif
This page took 0.092438 seconds and 4 git commands to generate.