]> git.pld-linux.org Git - packages/python-kiwisolver.git/blame - python-kiwisolver.spec
- python2 note
[packages/python-kiwisolver.git] / python-kiwisolver.spec
CommitLineData
c72225a9
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Fast implementation of the Cassowary constraint solver
7Summary(pl.UTF-8): Szybka implementacja rozwiązywania układu ograniczeń metodą Cassowary
8Name: python-kiwisolver
b9fc11e7 9# keep 1.1.x here for python2 support
a8d457f7 10Version: 1.1.0
27f73e23 11Release: 7
c72225a9
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/kiwisolver/
15Source0: https://files.pythonhosted.org/packages/source/k/kiwisolver/kiwisolver-%{version}.tar.gz
a8d457f7 16# Source0-md5: fc8a614367f7ba0d34a02fd08c535afc
c72225a9
JB
17URL: https://github.com/nucleic/kiwi
18BuildRequires: libstdc++-devel
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.714
21%if %{with python2}
a8d457f7 22BuildRequires: python-devel >= 1:2.7
c72225a9
JB
23BuildRequires: python-setuptools
24%endif
25%if %{with python3}
a8d457f7 26BuildRequires: python3-devel >= 1:3.4
c72225a9
JB
27BuildRequires: python3-setuptools
28%endif
a8d457f7 29Requires: python-modules >= 1:2.7
c72225a9
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Kiwi is an efficient C++ implementation of the Cassowary constraint
34solving algorithm. Kiwi is an implementation of the algorithm based on
35the seminal Cassowary paper. It is *not* a refactoring of the original
36C++ solver. Kiwi has been designed from the ground up to be
37lightweight and fast. Kiwi ranges from 10x to 500x faster than the
38original Cassowary solver with typical use cases gaining a 40x
39improvement. Memory savings are consistently > 5x.
40
41In addition to the C++ solver, Kiwi ships with hand-rolled Python
42bindings.
43
44%description -l pl.UTF-8
45Kiwi to napisana w C++, wydajna implementacja algorytmu rozwiązywania
46układu ograniczeń Cassowary. Kiwi to implementacja oparta na
47nowatorskim dokumencie Cassowary, nie refaktor oryginalnej
48implementacji w C++. Kiwi zostało od początku napisane z myślą o
49lekkości i szybkości; jest od 10x do 500x szybsze od oryginalnej
50implementacji, w typowych przypadkach osiągając 40-krotne
51przyspieszenie. Oszczędność pamięci jest pięciokrotna.
52
53Poza kodem w C++ Kiwi zawiera ręcznie napisane wiązania Pythona.
54
55%package -n python3-kiwisolver
56Summary: Fast implementation of the Cassowary constraint solver
57Summary(pl.UTF-8): Szybka implementacja rozwiązywania układu ograniczeń metodą Cassowary
58Group: Libraries/Python
a8d457f7 59Requires: python3-modules >= 1:3.4
c72225a9
JB
60
61%description -n python3-kiwisolver
62Kiwi is an efficient C++ implementation of the Cassowary constraint
63solving algorithm. Kiwi is an implementation of the algorithm based on
64the seminal Cassowary paper. It is *not* a refactoring of the original
65C++ solver. Kiwi has been designed from the ground up to be
66lightweight and fast. Kiwi ranges from 10x to 500x faster than the
67original Cassowary solver with typical use cases gaining a 40x
68improvement. Memory savings are consistently > 5x.
69
70In addition to the C++ solver, Kiwi ships with hand-rolled Python
71bindings.
72
73%description -n python3-kiwisolver -l pl.UTF-8
74Kiwi to napisana w C++, wydajna implementacja algorytmu rozwiązywania
75układu ograniczeń Cassowary. Kiwi to implementacja oparta na
76nowatorskim dokumencie Cassowary, nie refaktor oryginalnej
77implementacji w C++. Kiwi zostało od początku napisane z myślą o
78lekkości i szybkości; jest od 10x do 500x szybsze od oryginalnej
79implementacji, w typowych przypadkach osiągając 40-krotne
80przyspieszenie. Oszczędność pamięci jest pięciokrotna.
81
82Poza kodem w C++ Kiwi zawiera ręcznie napisane wiązania Pythona.
83
84%prep
85%setup -q -n kiwisolver-%{version}
86
87%build
88%if %{with python2}
89%py_build
90%endif
91
92%if %{with python3}
93%py3_build
94%endif
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%if %{with python2}
100%py_install
101
102%py_postclean
103%endif
104
105%if %{with python3}
106%py3_install
107%endif
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%if %{with python2}
113%files
114%defattr(644,root,root,755)
a8d457f7 115%doc README.rst releasenotes.rst
c72225a9
JB
116%attr(755,root,root) %{py_sitedir}/kiwisolver.so
117%{py_sitedir}/kiwisolver-%{version}-py*.egg-info
118%endif
119
120%if %{with python3}
121%files -n python3-kiwisolver
122%defattr(644,root,root,755)
a8d457f7 123%doc README.rst releasenotes.rst
c72225a9
JB
124%attr(755,root,root) %{py3_sitedir}/kiwisolver.cpython-*.so
125%{py3_sitedir}/kiwisolver-%{version}-py*.egg-info
126%endif
This page took 0.172424 seconds and 4 git commands to generate.