]> git.pld-linux.org Git - packages/python-kitchen.git/blame - python-kitchen.spec
- release 3 (by relup.sh)
[packages/python-kitchen.git] / python-kitchen.spec
CommitLineData
25c87403
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define module kitchen
25c87403
ER
6Summary: Small, useful pieces of code to make Python coding easier
7Name: python-%{module}
4f667449 8Version: 1.1.1
efd9dac2 9Release: 3
25c87403
ER
10License: LGPL v2+
11Group: Development/Languages
4f667449
ER
12Source0: https://fedorahosted.org/releases/k/i/kitchen/%{module}-%{version}.tar.gz
13# Source0-md5: 059d7ce048ca1d0fb53e6755145137b0
25c87403 14URL: https://fedorahosted.org/kitchen/
4f667449 15BuildRequires: python-modules >= 2.3.1
2b13992b 16BuildRequires: python-setuptools
17BuildRequires: rpm-pythonprov
1a087bf9 18BuildRequires: rpmbuild(macros) >= 1.710
25c87403
ER
19%if %{with tests}
20BuildRequires: python-chardet
21BuildRequires: python-coverage
22BuildRequires: python-nose
9a1a2b7b
ER
23%if %(locale -a | grep -q '^en_US$'; echo $?)
24BuildRequires: glibc-localedb-all
25%endif
25c87403 26%endif
4f667449 27Suggests: python-chardet
25c87403
ER
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32kitchen includes functions to make gettext easier to use, handling
33unicode text easier (conversion with bytes, outputting xml, and
34calculating how many columns a string takes), and compatibility
4f667449
ER
35modules for writing code that uses Python 2.7 modules but needs to run
36on Python 2.3
25c87403
ER
37
38%prep
4f667449 39%setup -q -n %{module}-%{version}
25c87403
ER
40
41# can't find origin of this import
42grep -r 'from test import test_support' tests -l | xargs rm
43
44%build
8fa068e3 45%py_build
25c87403
ER
46
47%if %{with tests}
4f667449 48nosetests-%{py_ver} --with-coverage --cover-package kitchen
25c87403
ER
49%endif
50
51%install
52rm -rf $RPM_BUILD_ROOT
8fa068e3 53%py_install
25c87403
ER
54
55%py_postclean
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc COPYING README NEWS COPYING.LESSER docs
96448bb0 63%dir %{py_sitescriptdir}/kitchen
25c87403
ER
64%{py_sitescriptdir}/kitchen/*.py[co]
65%{py_sitescriptdir}/kitchen/collections
66%{py_sitescriptdir}/kitchen/i18n
4f667449 67%{py_sitescriptdir}/kitchen/iterutils
25c87403
ER
68%{py_sitescriptdir}/kitchen/pycompat24
69%{py_sitescriptdir}/kitchen/pycompat25
70%{py_sitescriptdir}/kitchen/pycompat27
71%{py_sitescriptdir}/kitchen/text
72%{py_sitescriptdir}/kitchen/versioning
73%if "%{py_ver}" > "2.4"
74%{py_sitescriptdir}/kitchen-%{version}*.egg-info
75%endif
This page took 0.081712 seconds and 4 git commands to generate.