]> git.pld-linux.org Git - packages/python-keyczar.git/blame - python-keyczar.spec
new, version 0.71c
[packages/python-keyczar.git] / python-keyczar.spec
CommitLineData
297ff293
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define module keyczar
6Summary: Toolkit for safe and simple cryptography
7Name: python-%{module}
8Version: 0.71c
9Release: 1
10License: Apache v2.0
11Group: Development/Languages
12Source0: http://keyczar.googlecode.com/files/%{name}-%{version}.tar.gz
13# Source0-md5: 57154b1e8ad3f59e2c8296d5d5a516eb
14URL: http://www.keyczar.org/
15BuildRequires: python-Crypto
16BuildRequires: python-devel
17BuildRequires: python-pyasn1
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.219
20Requires: python-Crypto
21Requires: python-pyasn1
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Keyczar is an open source cryptographic toolkit designed to make it
27easier and safer for developers to use cryptography in their
28applications. Keyczar supports authentication and encryption with both
29symmetric and asymmetric keys.
30
31%prep
32%setup -q
33rm -r python_keyczar.egg-info
34
35%build
36%{__python} setup.py build
37
38%if %{with tests}
39cd tests/keyczar_tests
40PYTHONPATH=$PYTHONPATH:../../src/ ./alltests.py
41%endif
42
43%install
44rm -rf $RPM_BUILD_ROOT
45%{__python} setup.py install \
46 --skip-build \
47 --optimize=2 \
48 --root=$RPM_BUILD_ROOT
49
50%py_postclean
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
57%doc README LICENSE doc/pycrypt.pdf
58%{py_sitescriptdir}/keyczar
59%{py_sitescriptdir}/python_keyczar-*.egg-info
This page took 0.10685 seconds and 4 git commands to generate.