]> git.pld-linux.org Git - packages/python-josepy.git/blame - python-josepy.spec
- rel 5; it's noarch package
[packages/python-josepy.git] / python-josepy.spec
CommitLineData
f0634576
MB
1#
2# Conditional build:
3%bcond_without python2 # Python 2.x module
4%bcond_without python3 # Python 3.x module
5#
6%define module josepy
7Summary: JOSE protocol implementation
8Name: python-%{module}
63bd384e 9Version: 1.1.0
9880b586 10Release: 5
f0634576
MB
11License: Apache v2.0
12Group: Development/Languages/Python
63bd384e
JK
13Source0: https://files.pythonhosted.org/packages/source/j/josepy/josepy-%{version}.tar.gz
14# Source0-md5: b582dbfd70ccdbe5926e4dc46ba6719c
f0634576
MB
15URL: https://josepy.readthedocs.io/en/latest/
16%if %{with python2}
17BuildRequires: python-devel >= 1:2.6
18BuildRequires: python-setuptools
19%endif
20%if %{with python3}
21BuildRequires: python3-devel >= 1:3.2
22BuildRequires: python3-setuptools
23%endif
9880b586 24BuildArch: noarch
f0634576
MB
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This package provides JOSE protocol implementation.
29
30%package -n python3-%{module}
31Summary: JOSE protocol implementation in Python 3
32Group: Development/Languages/Python
33
34%description -n python3-%{module}
35This package provides JOSE protocol implementation in Python 3.
36
37%prep
38%setup -q -n %{module}-%{version}
39
40%build
41%if %{with python2}
42%py_build
43%endif
44%if %{with python3}
45%py3_build
46%endif
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%if %{with python3}
52%py3_install
53%endif
54
55%if %{with python2}
56%py_install
57%endif
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%if %{with python2}
63%files
64%defattr(644,root,root,755)
65%attr(755,root,root) %{_bindir}/jws
66%{py_sitescriptdir}/josepy-*-py*.egg-info
67%{py_sitescriptdir}/josepy
68%endif
69
70%if %{with python3}
71%files -n python3-%{module}
72%defattr(644,root,root,755)
73%{py3_sitescriptdir}/josepy-*-py*.egg-info
74%{py3_sitescriptdir}/josepy
75%endif
This page took 0.126043 seconds and 4 git commands to generate.