]> git.pld-linux.org Git - packages/python-jedi.git/blame - python-jedi.spec
- updated to 0.17.2
[packages/python-jedi.git] / python-jedi.spec
CommitLineData
6ea9bb41
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_with tests # unit tests (failing at start as of 0.17.0)
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: An autocompletion tool for Python that can be used for text editors
9Summary(pl.UTF-8): Narzędzie do automatycznego dopełaniania dla Pythona, nadające się do użycia w edytorach
10Name: python-jedi
c59b36ce
JB
11# keep 0.17.x here for python2 support
12Version: 0.17.2
13Release: 1
6ea9bb41
JB
14License: MIT (Jedi), Apache v2.0 (typeshed)
15Group: Libraries/Python
16#Source0Download: https://pypi.org/simple/jedi/
17Source0: https://files.pythonhosted.org/packages/source/j/jedi/jedi-%{version}.tar.gz
c59b36ce 18# Source0-md5: f012668907d76cebe9c4766f3b806fcf
6ea9bb41
JB
19URL: https://pypi.org/project/jedi/
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.7
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-colorama
25BuildRequires: python-docopt
26BuildRequires: python-parso >= 0.7.0
c59b36ce 27BuildRequires: python-parso < 0.8.0
6ea9bb41 28BuildRequires: python-pytest >= 3.9.0
c59b36ce 29BuildRequires: python-pytest < 5
6ea9bb41
JB
30%endif
31%endif
32%if %{with python3}
33BuildRequires: python3-modules >= 1:3.5
34BuildRequires: python3-setuptools
35%if %{with tests}
36BuildRequires: python3-colorama
37BuildRequires: python3-docopt
38BuildRequires: python3-parso >= 0.7.0
c59b36ce 39BuildRequires: python3-parso < 0.8.0
6ea9bb41 40BuildRequires: python3-pytest >= 3.9.0
c59b36ce 41BuildRequires: python3-pytest < 5
6ea9bb41
JB
42%endif
43%endif
44BuildRequires: rpm-pythonprov
45BuildRequires: rpmbuild(macros) >= 1.714
46%if %{with doc}
c59b36ce
JB
47BuildRequires: python-parso >= 0.7.0
48BuildRequires: sphinx-pdg-2
6ea9bb41
JB
49%endif
50Requires: python-modules >= 1:2.7
51BuildArch: noarch
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
55Jedi is a static analysis tool for Python that is typically used in
56IDEs/editors plugins. Jedi has a focus on autocompletion and goto
57functionality. Other features include refactoring, code search and
58finding references.
59
60%description -l pl.UTF-8
61Jedi to narzędzie do statycznej analizy kodu dla Pythona, zwykle
62używane w IDE i wtyczkach do edytorów. Jedi skupia się na funkcjach
63automatycznego dopełniania oraz przemieszczania po kodzie. Pozostałe
64funkcje obejmują refaktorowanie, przeszukiwanie kodu i wyszukiwanie
65odwołań.
66
67%package -n python3-jedi
68Summary: An autocompletion tool for Python that can be used for text editors
69Summary(pl.UTF-8): Narzędzie do automatycznego dopełaniania dla Pythona, nadające się do użycia w edytorach
70Group: Libraries/Python
71Requires: python3-modules >= 1:3.5
72
73%description -n python3-jedi
74Jedi is a static analysis tool for Python that is typically used in
75IDEs/editors plugins. Jedi has a focus on autocompletion and goto
76functionality. Other features include refactoring, code search and
77finding references.
78
79%description -n python3-jedi -l pl.UTF-8
80Jedi to narzędzie do statycznej analizy kodu dla Pythona, zwykle
81używane w IDE i wtyczkach do edytorów. Jedi skupia się na funkcjach
82automatycznego dopełniania oraz przemieszczania po kodzie. Pozostałe
83funkcje obejmują refaktorowanie, przeszukiwanie kodu i wyszukiwanie
84odwołań.
85
86%package apidocs
87Summary: API documentation for Python jedi module
88Summary(pl.UTF-8): Dokumentacja API modułu Pythona jedi
89Group: Documentation
90
91%description apidocs
92API documentation for Python jedi module.
93
94%description apidocs -l pl.UTF-8
95Dokumentacja API modułu Pythona jedi.
96
97%prep
98%setup -q -n jedi-%{version}
99
100%build
101%if %{with python2}
102%py_build
103
104%if %{with tests}
c59b36ce 105PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
6ea9bb41
JB
106%{__python} -m pytest
107%endif
108%endif
109
110%if %{with python3}
111%py3_build
112
113%if %{with tests}
c59b36ce 114PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
6ea9bb41
JB
115%{__python3} -m pytest
116%endif
117%endif
118
119%if %{with doc}
120%{__make} -C docs html \
c59b36ce 121 SPHINXBUILD=sphinx-build-2
6ea9bb41
JB
122%endif
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127%if %{with python2}
128%py_install
129
130%py_postclean
131%endif
132
133%if %{with python3}
134%py3_install
135%endif
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%if %{with python2}
141%files
142%defattr(644,root,root,755)
143%doc AUTHORS.txt CHANGELOG.rst LICENSE.txt README.rst
144%{py_sitescriptdir}/jedi
145%{py_sitescriptdir}/jedi-%{version}-py*.egg-info
146%endif
147
148%if %{with python3}
149%files -n python3-jedi
150%defattr(644,root,root,755)
151%doc AUTHORS.txt CHANGELOG.rst LICENSE.txt README.rst
152%{py3_sitescriptdir}/jedi
153%{py3_sitescriptdir}/jedi-%{version}-py*.egg-info
154%endif
155
156%if %{with doc}
157%files apidocs
158%defattr(644,root,root,755)
159%doc docs/_build/html/{_images,_modules,_static,docs,*.html,*.js}
160%endif
This page took 0.095427 seconds and 4 git commands to generate.