]> git.pld-linux.org Git - packages/python-httpbin.git/blame - python-httpbin.spec
- rebuild with python 3.8
[packages/python-httpbin.git] / python-httpbin.spec
CommitLineData
5523d769
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module template
7Summary: HTTP Request and Response Service
8Summary(pl.UTF-8): Usługa żądań i odpowiedzi HTTP
9Name: python-httpbin
10Version: 0.5.0
26adebd8 11Release: 3
5523d769
JB
12License: ISC
13Group: Libraries/Python
14#Source0Download: https://pypi.python.org/simple/httpbin
15Source0: https://files.pythonhosted.org/packages/source/h/httpbin/httpbin-%{version}.tar.gz
16# Source0-md5: 923793df99156caa484975ade96ee115
17URL: https://github.com/Runscope/httpbin
18%if %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
19BuildRequires: glibc-localedb-all
20%endif
21%if %{with python2}
22BuildRequires: python-modules >= 1:2.7
23BuildRequires: python-setuptools
24%endif
25%if %{with python3}
26BuildRequires: python3-modules >= 1:3.4
27BuildRequires: python3-setuptools
28%endif
29BuildRequires: rpm-pythonprov
30BuildRequires: rpmbuild(macros) >= 1.714
31Requires: python-modules >= 1:2.7
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36HTTP Request and Response Service.
37
38%description -l pl.UTF-8
39Usługa żądań i odpowiedzi HTTP.
40
41%package -n python3-httpbin
42Summary: HTTP Request and Response Service
43Summary(pl.UTF-8): Usługa żądań i odpowiedzi HTTP
44Group: Libraries/Python
45Requires: python3-modules >= 1:3.4
46
47%description -n python3-httpbin
48HTTP Request and Response Service.
49
50%description -n python3-httpbin -l pl.UTF-8
51Usługa żądań i odpowiedzi HTTP.
52
53%prep
54%setup -q -n httpbin-%{version}
55
56%build
57%if %{with python2}
58%py_build
59%endif
60
61%if %{with python3}
62LC_ALL=C.UTF-8 %py3_build
63%endif
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68%if %{with python2}
69%py_install
70
71%py_postclean
72%endif
73
74%if %{with python3}
75LC_ALL=C.UTF-8 %py3_install
76%endif
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%if %{with python2}
82%files
83%defattr(644,root,root,755)
84%doc AUTHORS LICENSE README.rst
85%{py_sitescriptdir}/httpbin
86%{py_sitescriptdir}/httpbin-%{version}-py*.egg-info
87%endif
88
89%if %{with python3}
90%files -n python3-httpbin
91%defattr(644,root,root,755)
92%doc AUTHORS LICENSE README.rst
93%{py3_sitescriptdir}/httpbin
94%{py3_sitescriptdir}/httpbin-%{version}-py*.egg-info
95%endif
This page took 0.071355 seconds and 4 git commands to generate.