]> git.pld-linux.org Git - packages/python-gnome-desktop.git/blame - python-gnome-desktop.spec
- x32 rebuild
[packages/python-gnome-desktop.git] / python-gnome-desktop.spec
CommitLineData
489ec8ac 1#
e76fbfa2 2# NOTE: evince, brasero and mediaprofiles are disabled because these things have
1549bbe2 3# been ported to GTK+3. It's not practical to mix GTK+2 and GTK+3 bindings
4# in gnome-python2-desktop, so for now we'll just have to disable the GTK+3
5# stuff.
6#
489ec8ac 7# Conditional builds:
8%bcond_without totem # disable totem support
203f9c42 9
7990939f 10%define module gnome-python-desktop
11%define pygtk_req 2:2.12.0
12%define gnome_python_req 2.26.0
489ec8ac 13Summary: GNOME bindings for Python
fae593d7 14Summary(pl.UTF-8): Wiązania Pythona do bibliotek GNOME
489ec8ac 15Name: python-gnome-desktop
b5e111da 16Version: 2.32.0
8c00da31 17Release: 12
489ec8ac 18License: GPL v2/LGPL v2.1 (see COPYING)
19Group: Libraries/Python
b5e111da
MB
20Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-python-desktop/2.32/%{module}-%{version}.tar.bz2
21# Source0-md5: 0e73fa80ace5c861777e0b523c6ead9d
5a7a66c8 22BuildRequires: GConf2-devel >= 2.22.0
f91e641b
MB
23BuildRequires: autoconf >= 2.53
24BuildRequires: automake
3aa81263 25BuildRequires: evolution-data-server-devel
e76fbfa2 26BuildRequires: gnome-desktop2-devel >= 2.10.0
5a7a66c8 27BuildRequires: gnome-vfs2-devel >= 2.22.0
038d16bb 28BuildRequires: gtk+2-devel >= 2:2.12.0
c601274c 29BuildRequires: gtksourceview-devel >= 1.8.4
511919dc 30BuildRequires: libgnome-keyring-devel >= 2.22.0
038d16bb 31BuildRequires: libgnomeprintui-devel >= 2.18.1
511919dc 32BuildRequires: libgnomeui-devel
5a7a66c8
PZ
33BuildRequires: libgtop-devel >= 2.22.0
34BuildRequires: librsvg-devel >= 1:2.22.0
f91e641b 35BuildRequires: libtool
e76fbfa2 36BuildRequires: libwnck2-devel >= 2.22.0
489ec8ac 37BuildRequires: pkgconfig
489ec8ac 38BuildRequires: python-devel >= 1:2.3.2
39BuildRequires: python-gnome-devel >= %{gnome_python_req}
b9136f5d 40BuildRequires: python-pycairo-devel
489ec8ac 41BuildRequires: python-pygtk-devel >= %{pygtk_req}
3aa81263 42BuildRequires: rpm-pythonprov
5db94723 43BuildRequires: rpmbuild(macros) >= 1.336
5a7a66c8 44%{?with_totem:BuildRequires: totem-pl-parser-devel >= 1.6.0}
203f9c42 45Requires: python-modules
f91e641b 46Obsoletes: python-evolution
e76fbfa2
MB
47Obsoletes: python-gnome-applet
48Obsoletes: python-gnome-desktop-applet
49Obsoletes: python-gnome-desktop-brasero
50Obsoletes: python-gnome-desktop-evince
f91e641b 51Obsoletes: python-gnome-desktop-evolution
e76fbfa2 52Obsoletes: python-gnome-desktop-mediaprofiles
1766d07d 53Obsoletes: python-gnome-desktop-nautilus-cd-burner
e76fbfa2
MB
54Obsoletes: python-gnome-extras-applet
55Obsoletes: python-gnome-extras-mediaprofiles
1766d07d 56Obsoletes: python-gnome-extras-nautilus-cd-burner
489ec8ac 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
60
61%description
62GNOME bindings for Python.
63
a487a53a
JR
64%description -l pl.UTF-8
65Wiązania Pythona do bibliotek GNOME.
489ec8ac 66
67%package devel
68Summary: Development files for GNOME bindings for Python
fae593d7 69Summary(pl.UTF-8): Pliki programistyczne wiązań Pythona do GNOME
489ec8ac 70Group: Libraries/Python
b9136f5d 71Requires: %{name}-libwnck = %{version}-%{release}
489ec8ac 72Requires: %{name}-print = %{version}-%{release}
7a9f52d8 73Requires: python-gnome-devel >= %{gnome_python_req}
489ec8ac 74Requires: python-pygtk-devel >= %{pygtk_req}
74434baa 75Obsoletes: python-gnome-extras-devel < 2.13.3
489ec8ac 76
77%description devel
78Development files for GNOME bindings for Python.
79
a487a53a
JR
80%description devel -l pl.UTF-8
81Pliki programistyczne wiązań Pythona do GNOME.
489ec8ac 82
ae9443b7
MB
83%package apidocs
84Summary: GNOME bindings for Python API documentation
85Summary(pl.UTF-8): Dokumentacja API wiązań Pythona do GNOME
86Group: Documentation
87Requires: gtk-doc-common
203f9c42
ER
88%if "%{_rpmversion}" >= "5"
89BuildArch: noarch
90%endif
ae9443b7
MB
91
92%description apidocs
93GNOME bindings for Python API documentation.
94
95%description apidocs -l pl.UTF-8
96Dokumentacja API wiązań Pythona do GNOME.
97
489ec8ac 98%package examples
99Summary: Example programs for python-gnome-desktop
fae593d7 100Summary(pl.UTF-8): Przykładowe programy do python-gnome-desktop
489ec8ac 101Group: Libraries/Python
102Requires: %{name}-devel = %{version}-%{release}
103
104%description examples
105This package contains example programs for python-gnome-desktop.
106
a487a53a
JR
107%description examples -l pl.UTF-8
108Ten pakiet zawiera przykładowe programy dla python-gnome-desktop.
489ec8ac 109
489ec8ac 110%package gtksourceview
111Summary: Gtksourceview bindings for Python
fae593d7 112Summary(pl.UTF-8): Wiązania Pythona do biblioteki gtksourceview
489ec8ac 113Group: Libraries/Python
114Requires: %{name}-print = %{version}-%{release}
74434baa 115Obsoletes: python-gnome-extras-gtksourceview
489ec8ac 116
117%description gtksourceview
118Gtksourceview bindings for Python.
119
a487a53a
JR
120%description gtksourceview -l pl.UTF-8
121Wiązania Pythona do biblioteki gtksourceview.
489ec8ac 122
f5ea4fde 123%package keyring
124Summary: GNOME keyring bindings for Python
fae593d7 125Summary(pl.UTF-8): Wiązania Pythona do biblioteki GNOME keyring
f5ea4fde 126Group: Libraries/Python
038d16bb 127Requires: python-pygobject >= 2.14.0
f5ea4fde 128
129%description keyring
130GNOME keyring bindings for Python.
131
a487a53a
JR
132%description keyring -l pl.UTF-8
133Wiązania Pythona do biblioteki GNOME keyring.
f5ea4fde 134
489ec8ac 135%package libgtop
136Summary: Libgtop bindings for Python
fae593d7 137Summary(pl.UTF-8): Wiązania Pythona do biblioteki libgtop
489ec8ac 138Group: Libraries/Python
038d16bb 139Requires: python-pygobject >= 2.14.0
74434baa 140Obsoletes: python-gnome-extras-libgtop
489ec8ac 141
142%description libgtop
143Libgtop bindings for Python.
144
a487a53a
JR
145%description libgtop -l pl.UTF-8
146Wiązania Pythona do biblioteki libgtop.
489ec8ac 147
b9136f5d 148%package librsvg
901d8dbb 149Summary: Librsvg bindings for Python
fae593d7 150Summary(pl.UTF-8): Wiązania Pythona do biblioteki librsvg
901d8dbb 151Group: Libraries/Python
5a7a66c8 152Requires: librsvg >= 1:2.22.0
901d8dbb 153
154%description librsvg
155Librsvg bindings for Python.
156
a487a53a
JR
157%description librsvg -l pl.UTF-8
158Wiązania Pythona do biblioteki librsvg.
901d8dbb 159
489ec8ac 160%package libwnck
161Summary: Libwnck bindings for Python
fae593d7 162Summary(pl.UTF-8): Wiązania Pythona do biblioteki libwnck
489ec8ac 163Group: Libraries/Python
164Requires: python-pygtk-gtk >= %{pygtk_req}
74434baa 165Obsoletes: python-gnome-extras-libwnck
489ec8ac 166
167%description libwnck
168Libwnck bindings for Python.
169
a487a53a
JR
170%description libwnck -l pl.UTF-8
171Wiązania Pythona do biblioteki libwnck.
489ec8ac 172
489ec8ac 173%package print
174Summary: GNOME Print bindings for Python
fae593d7 175Summary(pl.UTF-8): Wiązania Pythona do biblioteki GNOME obsługi drukowania
489ec8ac 176Group: Libraries/Python
177Requires: %{name} = %{version}-%{release}
178Requires: python-gnome-canvas >= %{gnome_python_req}
74434baa
JB
179Provides: python-gnome-print
180Provides: python-gnome-print-ui
c0d3bd83 181Obsoletes: python-gnome-extras-print
489ec8ac 182Obsoletes: python-gnome-print
183Obsoletes: python-gnome-print-ui
489ec8ac 184
185%description print
186GNOME Print bindings for Python.
187
a487a53a
JR
188%description print -l pl.UTF-8
189Wiązania Pythona do biblioteki GNOME obsługi drukowania.
489ec8ac 190
191%package totem
192Summary: Totem bindings for Python
fae593d7 193Summary(pl.UTF-8): Wiązania Pythona do biblioteki totem
489ec8ac 194Group: Libraries/Python
195Requires: python-gnome-vfs >= %{gnome_python_req}
196Requires: python-pygtk-gtk >= %{pygtk_req}
74434baa 197Obsoletes: python-gnome-extras-totem
489ec8ac 198
199%description totem
200Totem bindings for Python.
201
a487a53a
JR
202%description totem -l pl.UTF-8
203Wiązania Pythona do biblioteki totem.
489ec8ac 204
205%prep
206%setup -q -n %{module}-%{version}
207
208%build
f91e641b
MB
209%{__libtoolize}
210%{__aclocal}
211%{__autoconf}
212%{__autoheader}
213%{__automake}
214%configure \
215 --disable-applet \
216 --disable-braseromedia \
217 --disable-braseroburn \
218 --disable-bugbuddy \
219 --disable-evolution \
220 --disable-evolution_ecal \
221 --disable-evince \
222 --disable-mediaprofiles \
223 --disable-nautilusburn
224%{__make}
489ec8ac 225
226%install
227rm -rf $RPM_BUILD_ROOT
489ec8ac 228install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
229
f91e641b
MB
230%{__make} install \
231 DESTDIR=$RPM_BUILD_ROOT
b5a4f299 232
5bc130fe
MB
233%py_comp $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0
234%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0
235
489ec8ac 236cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
237
f91e641b 238%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/*.{py,la}}
489ec8ac 239
5db94723 240# wscript doesn't allow to pass proper gtk-doc dir
d2fc46fd
SS
241if [ ! -d $RPM_BUILD_ROOT%{_gtkdocdir} ]; then
242 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
243 mv $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
244fi
245
489ec8ac 246%clean
247rm -rf $RPM_BUILD_ROOT
248
249%files
250%defattr(644,root,root,755)
251%doc AUTHORS COPYING ChangeLog NEWS
e76fbfa2
MB
252%dir %{py_sitedir}/gtk-2.0/gnomedesktop
253%attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomedesktop/_gnomedesktop.so
254%{py_sitedir}/gtk-2.0/gnomedesktop/__init__.py[co]
489ec8ac 255
256%files devel
257%defattr(644,root,root,755)
677c2f10 258%{pydefsdir}/*.defs
7fc7bd73 259%{_pkgconfigdir}/gnome-python-desktop-2.0.pc
489ec8ac 260
ae9443b7
MB
261%files apidocs
262%defattr(644,root,root,755)
1f77c041
JB
263%{_gtkdocdir}/pygnomeprint
264%{_gtkdocdir}/pygnomeprintui
265%{_gtkdocdir}/pygtksourceview
ae9443b7 266
489ec8ac 267%files examples
268%defattr(644,root,root,755)
269%{_examplesdir}/%{name}-%{version}
270
489ec8ac 271%files gtksourceview
272%defattr(644,root,root,755)
273%attr(755,root,root) %{py_sitedir}/gtk-2.0/gtksourceview.so
489ec8ac 274
f5ea4fde 275%files keyring
276%defattr(644,root,root,755)
acace6bb 277%attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomekeyring.so
f5ea4fde 278
489ec8ac 279%files libgtop
280%defattr(644,root,root,755)
281%attr(755,root,root) %{py_sitedir}/gtk-2.0/gtop.so
282
901d8dbb 283%files librsvg
284%defattr(644,root,root,755)
285%attr(755,root,root) %{py_sitedir}/gtk-2.0/rsvg.so
286
489ec8ac 287%files libwnck
288%defattr(644,root,root,755)
289%attr(755,root,root) %{py_sitedir}/gtk-2.0/wnck.so
290
489ec8ac 291%files print
292%defattr(644,root,root,755)
293%dir %{py_sitedir}/gtk-2.0/gnomeprint
677c2f10
JB
294%attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomeprint/_print.so
295%attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomeprint/ui.so
296%{py_sitedir}/gtk-2.0/gnomeprint/__init__.py[co]
489ec8ac 297
298%if %{with totem}
299%files totem
300%defattr(644,root,root,755)
301%dir %{py_sitedir}/gtk-2.0/totem
677c2f10
JB
302%attr(755,root,root) %{py_sitedir}/gtk-2.0/totem/plparser.so
303%{py_sitedir}/gtk-2.0/totem/__init__.py[co]
489ec8ac 304%endif
This page took 0.109727 seconds and 4 git commands to generate.