]> git.pld-linux.org Git - packages/python-geventhttpclient.git/blame - python-geventhttpclient.spec
- updated to 1.3.1
[packages/python-geventhttpclient.git] / python-geventhttpclient.spec
CommitLineData
07e55034
AM
1#
2# Conditional build:
99278cda 3%bcond_without tests # py.test tests
07e55034 4%bcond_without python2 # CPython 2.x module
99278cda 5%bcond_without python3 # CPython 3.x module
07e55034
AM
6
7%define module geventhttpclient
8Summary: A high performance, concurrent HTTP client library
99278cda 9Summary(pl.UTF-8): Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP
07e55034 10Name: python-%{module}
99278cda 11Version: 1.3.1
07e55034
AM
12Release: 1
13License: MIT
14Group: Libraries/Python
99278cda
JB
15#Source0Download: https://pypi.python.org/simple/geventhttpclient
16Source0: https://files.pythonhosted.org/packages/source/g/geventhttpclient/geventhttpclient-%{version}.tar.gz
17# Source0-md5: 9aaac96fa4856ac919869a261c8b3dcb
07e55034
AM
18URL: https://pypi.python.org/pypi/geventhttpclient
19BuildRequires: rpm-pythonprov
99278cda 20BuildRequires: rpmbuild(macros) >= 1.714
07e55034 21%if %{with python2}
99278cda
JB
22# older versions generate pythonegg(backports.ssl_match_hostname) dependency
23BuildRequires: python-devel >= 1:2.7.9
24BuildRequires: python-modules >= 1:2.7.9
07e55034
AM
25BuildRequires: python-setuptools
26%if %{with tests}
27BuildRequires: python-certifi
99278cda
JB
28BuildRequires: python-gevent >= 0.13
29BuildRequires: python-pytest
30BuildRequires: python-six
07e55034
AM
31%endif
32%endif
33%if %{with python3}
99278cda
JB
34BuildRequires: python3-devel >= 1:3.4
35BuildRequires: python3-modules >= 1:3.4
07e55034
AM
36BuildRequires: python3-setuptools
37%if %{with tests}
38BuildRequires: python3-certifi
99278cda
JB
39BuildRequires: python3-gevent >= 0.13
40BuildRequires: python3-pytest
41BuildRequires: python3-six
07e55034
AM
42%endif
43%endif
99278cda 44Requires: python-modules >= 1:2.7.9
07e55034
AM
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
99278cda 48A high performance, concurrent HTTP client library for Python 2 using
07e55034
AM
49gevent.
50
871575a9 51geventhttpclient use a fast HTTP parser, written in C, originating
07e55034
AM
52from nginx, extracted and modified by Joyent.
53
54geventhttpclient has been specifically designed for high concurrency,
55streaming and support HTTP 1.1 persistent connections. More generally
56it is designed for efficiently pulling from REST APIs and streaming
871575a9 57API's like Twitter's.
07e55034
AM
58
59Safe SSL support is provided by default.
60
99278cda
JB
61%description -l pl.UTF-8
62Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP dla Pythona
632, wykorzystująca gevent.
64
65geventhttpclient wykorzystuje szybki parser HTTP, napisany w C,
66pochodzący z serwera nginx, wyciągniety i zmodyfikowany przez Joyenta.
67
68geventhttpclient został zaprojektowany w szczególności z myślą o
69dużym zrównolegleniu, przesyłaniu strumieni i obsłudze trwałych
70połączeń HTTP 1.1. Bardziej ogólnie, jest przeznaczony do wydajnego
71pobierania z API REST-owych oraz strumieniowych, takich jak Twitter.
72
73Domyślnie dostępna jest obsługa bezpiecznego SSL.
74
07e55034
AM
75%package -n python3-%{module}
76Summary: A high performance, concurrent HTTP client library
99278cda 77Summary(pl.UTF-8): Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP
07e55034 78Group: Libraries/Python
99278cda 79Requires: python3-modules >= 1:3.4
07e55034
AM
80
81%description -n python3-%{module}
99278cda 82A high performance, concurrent HTTP client library for Python 3 using
07e55034
AM
83gevent.
84
871575a9 85geventhttpclient use a fast HTTP parser, written in C, originating
07e55034
AM
86from nginx, extracted and modified by Joyent.
87
88geventhttpclient has been specifically designed for high concurrency,
89streaming and support HTTP 1.1 persistent connections. More generally
90it is designed for efficiently pulling from REST APIs and streaming
871575a9 91API's like Twitter's.
07e55034
AM
92
93Safe SSL support is provided by default.
94
99278cda
JB
95%description -n python3-%{module} -l pl.UTF-8
96Biblioteka bardzo wydajnego, wielowątkowego klienta HTTP dla Pythona
973, wykorzystująca gevent.
98
99geventhttpclient wykorzystuje szybki parser HTTP, napisany w C,
100pochodzący z serwera nginx, wyciągniety i zmodyfikowany przez Joyenta.
101
102geventhttpclient został zaprojektowany w szczególności z myślą o
103dużym zrównolegleniu, przesyłaniu strumieni i obsłudze trwałych
104połączeń HTTP 1.1. Bardziej ogólnie, jest przeznaczony do wydajnego
105pobierania z API REST-owych oraz strumieniowych, takich jak Twitter.
106
107Domyślnie dostępna jest obsługa bezpiecznego SSL.
108
07e55034
AM
109%prep
110%setup -q -n %{module}-%{version}
111
99278cda
JB
112%{__rm} -r src/geventhttpclient/tests/__pycache__ \
113 src/geventhttpclient.egg-info
114
07e55034
AM
115%build
116%if %{with python2}
99278cda
JB
117%py_build
118
119%{?with_tests:PYTHONPATH=$(pwd)/$(echo build-2/lib.*) %{__python} -m pytest src}
07e55034
AM
120%endif
121
122%if %{with python3}
99278cda
JB
123%py3_build
124
125%{?with_tests:PYTHONPATH=$(pwd)/$(echo build-3/lib.*) %{__python3} -m pytest src}
07e55034
AM
126%endif
127
128%install
129rm -rf $RPM_BUILD_ROOT
130
131%if %{with python2}
799dc142 132%py_install
07e55034
AM
133
134%py_postclean
99278cda 135%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/geventhttpclient/tests
07e55034
AM
136%endif
137
138%if %{with python3}
799dc142 139%py3_install
99278cda
JB
140
141%{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/geventhttpclient/tests
07e55034
AM
142%endif
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%if %{with python2}
148%files
149%defattr(644,root,root,755)
150%dir %{py_sitedir}/geventhttpclient
151%{py_sitedir}/geventhttpclient/*.py[co]
99278cda
JB
152%attr(755,root,root) %{py_sitedir}/geventhttpclient/_parser.so
153%{py_sitedir}/geventhttpclient-%{version}-py*.egg-info
07e55034 154%endif
07e55034
AM
155
156%if %{with python3}
157%files -n python3-%{module}
158%defattr(644,root,root,755)
99278cda
JB
159%dir %{py3_sitedir}/geventhttpclient
160%{py3_sitedir}/geventhttpclient/*.py
161%{py3_sitedir}/geventhttpclient/__pycache__
162%attr(755,root,root) %{py3_sitedir}/geventhttpclient/_parser.cpython-*.so
163%{py3_sitedir}/geventhttpclient-%{version}-py*.egg-info
07e55034 164%endif
This page took 0.100392 seconds and 4 git commands to generate.