]> git.pld-linux.org Git - packages/python-geopy.git/blame - python-geopy.spec
up to 1.23.0 (last version with python 2 support)
[packages/python-geopy.git] / python-geopy.spec
CommitLineData
7d09d443
MK
1# Conditional build:
2%bcond_with doc # don't build doc
3%bcond_with tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
4e9f3ba5
AM
7%define module geopy
8Summary: A Geocoding Toolbox for Python
9Name: python-%{module}
98b84bca
JP
10Version: 1.23.0
11Release: 1
4e9f3ba5
AM
12License: MIT
13Group: Development/Languages/Python
b34bfc80 14Source0: https://pypi.python.org/packages/source/g/geopy/geopy-%{version}.tar.gz
98b84bca 15# Source0-md5: e8b7d678665fab26ce3e8ff97f352ee8
b34bfc80 16URL: https://pypi.python.org/pypi/geopy
8e675dbd 17BuildRequires: rpmbuild(macros) >= 1.710
7d09d443
MK
18
19%if %{with python2}
20## BuildRequires: pylint
4e9f3ba5 21BuildRequires: python-devel
568c3ec1 22BuildRequires: python-setuptools
7d09d443
MK
23%endif
24%if %{with python3}
25## BuildRequires: pylint-python3
26BuildRequires: python3-devel
27BuildRequires: python3-distribute
28BuildRequires: python3-modules
29%endif
30
4e9f3ba5
AM
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35geopy makes it easy for developers to locate the coordinates of
36addresses, cities, countries, and landmarks across the globe using
37third-party geocoders and other data sources, such as wikis.
38
39geopy currently includes support for six geocoders: Google Maps,
40Yahoo! Maps, Windows Local Live (Virtual Earth), geocoder.us,
41GeoNames, MediaWiki pages (with the GIS extension), and Semantic
42MediaWiki pages.
43
7d09d443
MK
44
45%package -n python3-%{module}
46Summary: -
47Summary(pl.UTF-8): -
48Group: Libraries/Python
49Requires: python3-modules
50
51%description -n python3-%{module}
52geopy makes it easy for developers to locate the coordinates of
53addresses, cities, countries, and landmarks across the globe using
54third-party geocoders and other data sources, such as wikis.
55
56geopy currently includes support for six geocoders: Google Maps,
57Yahoo! Maps, Windows Local Live (Virtual Earth), geocoder.us,
58GeoNames, MediaWiki pages (with the GIS extension), and Semantic
59MediaWiki pages.
60
61## %description -n python3-%{module} -l pl.UTF-8
62
63%package apidocs
64Summary: %{module} API documentation
65Summary(pl.UTF-8): Dokumentacja API %{module}
66Group: Documentation
67
68%description apidocs
69API documentation for %{module}.
70
71%description apidocs -l pl.UTF-8
72Dokumentacja API %{module}.
73
4e9f3ba5
AM
74%prep
75%setup -q -n %{module}-%{version}
76
77%build
7d09d443 78%if %{with python2}
178ae869 79%py_build %{?with_tests:test}
7d09d443
MK
80%endif
81
82%if %{with python3}
178ae869 83%py3_build %{?with_tests:test}
7d09d443
MK
84%endif
85
86%if %{with doc}
87cd docs
88%{__make} -j1 html
89rm -rf _build/html/_sources
90%endif
91
4e9f3ba5
AM
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
7d09d443 96%if %{with python2}
178ae869 97%py_install
4e9f3ba5 98
4e9f3ba5 99%py_postclean
7d09d443
MK
100%endif
101
102%if %{with python3}
178ae869 103%py3_install
7d09d443
MK
104%endif
105
4e9f3ba5
AM
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(644,root,root,755)
7d09d443
MK
112%dir %{py_sitescriptdir}/%{module}
113%{py_sitescriptdir}/%{module}/*.py[co]
114%dir %{py_sitescriptdir}/%{module}/geocoders
115%{py_sitescriptdir}/%{module}/geocoders/*.py[co]
4e9f3ba5 116%if "%{py_ver}" > "2.4"
7d09d443 117%{py_sitescriptdir}/%{module}-*.egg-info
4e9f3ba5 118%endif
7d09d443
MK
119
120%if %{with python3}
121%files -n python3-%{module}
122%defattr(644,root,root,755)
123## %doc AUTHORS CHANGES LICENSE
124%{py3_sitescriptdir}/%{module}
125%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
126%endif
127
This page took 0.129418 seconds and 4 git commands to generate.