]> git.pld-linux.org Git - packages/python-fabric.git/blame - python-fabric.spec
rebuild with python 3.10
[packages/python-fabric.git] / python-fabric.spec
CommitLineData
7127e6a8
AM
1# Conditional build:
2%bcond_without tests # unit tests
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module fabric
7%define egg_name fabric
8%define pypi_name fabric
9Summary: Execute shell commands remotely over SSH, yielding useful Python objects in return
10Name: python-%{module}
11Version: 2.5.0
249645d1 12Release: 4
7127e6a8
AM
13License: - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
14Group: Libraries/Python
15Source0: https://pypi.debian.net/fabric/%{pypi_name}-%{version}.tar.gz
16# Source0-md5: de403c610dc1dd0f7c3e7ad46c620c33
17URL: http://www.fabfile.org/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-invoke
25BuildRequires: python-paramiko
26%endif
27%endif
28%if %{with python3}
29BuildRequires: python3-modules
30BuildRequires: python3-setuptools
31%if %{with tests}
32BuildRequires: python3-invoke
33BuildRequires: python3-paramiko
34%endif%
35%endif
36Requires: python-modules
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Fabric is a high level library designed to execute shell commands
42remotely over SSH, yielding useful Python objects in return.
43
44%package -n python3-%{module}
45Summary: Execute shell commands remotely over SSH, yielding useful Python objects in return
46Summary(pl.UTF-8): -
47Group: Libraries/Python
48Requires: python3-modules
49
50%description -n python3-%{module}
51Fabric is a high level library designed to execute shell commands
52remotely over SSH, yielding useful Python objects in return.
53
54%prep
55%setup -q -n %{pypi_name}-%{version}
56
57%build
58%if %{with python2}
59%py_build %{?with_tests:test}
60%endif
61
62%if %{with python3}
63%py3_build %{?with_tests:test}
64%endif
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69%if %{with python2}
70%py_install
71%endif
72
73%if %{with python3}
74%py3_install
75%endif
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%if %{with python2}
81%files
82%defattr(644,root,root,755)
83%doc README.rst
84%{py_sitescriptdir}/%{module}
85%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
86%endif
87
88%if %{with python3}
89%files -n python3-%{module}
90%defattr(644,root,root,755)
91%doc README.rst
92%attr(755,root,root) %{_bindir}/fab
93%{py3_sitescriptdir}/%{module}
94%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
95%endif
This page took 0.104666 seconds and 4 git commands to generate.