]> git.pld-linux.org Git - packages/python-eventlet.git/blame - python-eventlet.spec
- release 2 (by relup.sh)
[packages/python-eventlet.git] / python-eventlet.spec
CommitLineData
d2431ecf
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
243e0dcb 4%bcond_without tests # unit tests
d2431ecf
JB
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Highly concurrent networking library for Python 2
9Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 2
10Name: python-eventlet
243e0dcb 11Version: 0.21.0
e04ce515 12Release: 2
d2431ecf
JB
13License: MIT
14Group: Development/Languages/Python
15#Source0Download: https://pypi.python.org/simple/eventlet/
243e0dcb
JB
16Source0: https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
17# Source0-md5: 92aaac4c0abaddff9329f55d8f5bcd76
18Patch0: %{name}-deps.patch
d2431ecf
JB
19URL: https://pypi.python.org/pypi/eventlet/
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
23BuildRequires: python-devel >= 1:2.6
24BuildRequires: python-setuptools >= 5.4.1
25%if %{with tests}
243e0dcb 26BuildRequires: python-enum34
d2431ecf
JB
27BuildRequires: python-greenlet >= 0.3
28BuildRequires: python-nose >= 1.3.1
d2431ecf
JB
29%endif
30%endif
31%if %{with python3}
32BuildRequires: python3-devel >= 1:3.3
33BuildRequires: python3-setuptools >= 5.4.1
34%if %{with tests}
243e0dcb
JB
35%if "%{py3_ver}" < "3.4"
36BuildRequires: python3-enum34
37%endif
d2431ecf
JB
38BuildRequires: python3-greenlet >= 0.3
39BuildRequires: python3-nose >= 1.3.1
d2431ecf
JB
40%endif
41%endif
42%{?with_doc:BuildRequires: sphinx-pdg}
d2431ecf
JB
43Requires: python-modules >= 1:2.6
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47Eventlet is a concurrent networking library for Python that allows you
48to change how you run your code, not how you write it.
49
50It uses epoll or libevent for highly scalable non-blocking I/O.
51Coroutines ensure that the developer uses a blocking style of
52programming that is similar to threading, but provide the benefits of
53non-blocking I/O. The event dispatch is implicit, which means you can
54easily use Eventlet from the Python interpreter, or as a small part of
55a larger application.
56
57%description -l pl.UTF-8
58Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
59zmianę sposobu uruchamiania kodu bez sposobu pisania go.
60
61Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
62nieblokujących operacji we/wy. Korutyny zapewniają, że programista
63korzysta z blokującego stylu programowania, podobnego do wątkowego,
64ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
65domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
66interpretera Pythona lub jako małej części dużej aplikacji.
67
68%package -n python3-eventlet
69Summary: Highly concurrent networking library for Python 3
70Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 3
71Group: Development/Languages/Python
d2431ecf
JB
72Requires: python3-modules >= 1:3.3
73
74%description -n python3-eventlet
75Eventlet is a concurrent networking library for Python that allows you
76to change how you run your code, not how you write it.
77
78It uses epoll or libevent for highly scalable non-blocking I/O.
79Coroutines ensure that the developer uses a blocking style of
80programming that is similar to threading, but provide the benefits of
81non-blocking I/O. The event dispatch is implicit, which means you can
82easily use Eventlet from the Python interpreter, or as a small part of
83a larger application.
84
85%description -n python3-eventlet -l pl.UTF-8
86Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
87zmianę sposobu uruchamiania kodu bez sposobu pisania go.
88
89Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
90nieblokujących operacji we/wy. Korutyny zapewniają, że programista
91korzysta z blokującego stylu programowania, podobnego do wątkowego,
92ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
93domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
94interpretera Pythona lub jako małej części dużej aplikacji.
95
96%package apidocs
97Summary: API documentation for eventlet module
98Summary(pl.UTF-8): Dokumentacja API modułu eventlet
99Group: Documentation
9566f295
ER
100%if "%{_rpmversion}" >= "5"
101BuildArch: noarch
102%endif
d2431ecf
JB
103
104%description apidocs
105API documentation for eventlet module.
106
107%description apidocs -l pl.UTF-8
108Dokumentacja API modułu eventlet.
109
110%prep
111%setup -q -n eventlet-%{version}
243e0dcb 112%patch0 -p1
d2431ecf
JB
113
114%build
115%if %{with python2}
243e0dcb
JB
116%py_build
117
118%{?with_tests:PYTHONPATH=$(pwd) %{__python} -m unittest tests}
d2431ecf
JB
119%endif
120
121%if %{with python3}
243e0dcb
JB
122%py3_build
123
124%{?with_tests:PYTHONPATH=$(pwd) %{__python3} -m unittest tests}
d2431ecf
JB
125%endif
126
127%if %{with doc}
128%{__make} -C doc -j1 html
129%{__rm} -r doc/_build/html/_sources
130%endifg
131
132%install
133rm -rf $RPM_BUILD_ROOT
134
135%if %{with python2}
136%py_install
137
138%py_postclean
139%endif
140
141%if %{with python3}
142%py3_install
143%endif
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%if %{with python2}
149%files
150%defattr(644,root,root,755)
151%doc AUTHORS LICENSE NEWS README.rst
152%{py_sitescriptdir}/eventlet
153%{py_sitescriptdir}/eventlet-%{version}-py*.egg-info
154%endif
155
156%if %{with python3}
157%files -n python3-eventlet
158%defattr(644,root,root,755)
159%doc AUTHORS LICENSE NEWS README.rst
160%{py3_sitescriptdir}/eventlet
161%{py3_sitescriptdir}/eventlet-%{version}-py*.egg-info
162%endif
163
164%if %{with doc}
165%files apidocs
166%defattr(644,root,root,755)
167%doc doc/_build/html/*
168%endif
This page took 0.1202 seconds and 4 git commands to generate.