]> git.pld-linux.org Git - packages/python-eventlet.git/blame - python-eventlet.spec
rebuild with python 3.10
[packages/python-eventlet.git] / python-eventlet.spec
CommitLineData
d2431ecf
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
a9f870c5 4%bcond_with tests # unit tests (random timeouts on builders)
d2431ecf
JB
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Highly concurrent networking library for Python 2
9Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 2
10Name: python-eventlet
13dfd460 11Version: 0.33.0
c57a893c 12Release: 3
d2431ecf
JB
13License: MIT
14Group: Development/Languages/Python
f78da2d8 15#Source0Download: https://pypi.org/simple/eventlet/
243e0dcb 16Source0: https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
13dfd460 17# Source0-md5: a15ae1b585678c0bad0e89916d7c0ab4
f78da2d8 18URL: https://pypi.org/project/eventlet/
d2431ecf
JB
19BuildRequires: rpm-pythonprov
20BuildRequires: rpmbuild(macros) >= 1.714
21%if %{with python2}
6d7c3a3e
JB
22BuildRequires: python-devel >= 1:2.7
23BuildRequires: python-setuptools >= 1:5.4.1
d2431ecf 24%if %{with tests}
6d7c3a3e 25BuildRequires: python-dns >= 1.15.0
243e0dcb 26BuildRequires: python-enum34
d2431ecf 27BuildRequires: python-greenlet >= 0.3
6d7c3a3e 28BuildRequires: python-monotonic >= 1.4
d2431ecf 29BuildRequires: python-nose >= 1.3.1
6d7c3a3e 30BuildRequires: python-six >= 1.10.0
22e1cad0 31BuildRequires: python-subprocess32
d2431ecf
JB
32%endif
33%endif
34%if %{with python3}
13dfd460 35BuildRequires: python3-devel >= 1:3.5
6d7c3a3e 36BuildRequires: python3-setuptools >= 1:5.4.1
d2431ecf 37%if %{with tests}
6d7c3a3e 38BuildRequires: python3-dns >= 1.15.0
d2431ecf
JB
39BuildRequires: python3-greenlet >= 0.3
40BuildRequires: python3-nose >= 1.3.1
6d7c3a3e 41BuildRequires: python3-six >= 1.10.0
d2431ecf
JB
42%endif
43%endif
44%{?with_doc:BuildRequires: sphinx-pdg}
4ac47e07
JB
45%if %{with tests}
46# SO_REUSEPORT option for tests.convenience_test.test_socket_reuse
47BuildRequires: uname(release) >= 3.9
48%endif
6d7c3a3e 49Requires: python-modules >= 1:2.7
8a82a42a 50BuildArch: noarch
d2431ecf
JB
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54Eventlet is a concurrent networking library for Python that allows you
55to change how you run your code, not how you write it.
56
57It uses epoll or libevent for highly scalable non-blocking I/O.
58Coroutines ensure that the developer uses a blocking style of
59programming that is similar to threading, but provide the benefits of
60non-blocking I/O. The event dispatch is implicit, which means you can
61easily use Eventlet from the Python interpreter, or as a small part of
62a larger application.
63
64%description -l pl.UTF-8
65Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
66zmianę sposobu uruchamiania kodu bez sposobu pisania go.
67
68Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
69nieblokujących operacji we/wy. Korutyny zapewniają, że programista
70korzysta z blokującego stylu programowania, podobnego do wątkowego,
71ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
72domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
73interpretera Pythona lub jako małej części dużej aplikacji.
74
75%package -n python3-eventlet
76Summary: Highly concurrent networking library for Python 3
77Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 3
78Group: Development/Languages/Python
13dfd460 79Requires: python3-modules >= 1:3.5
d2431ecf
JB
80
81%description -n python3-eventlet
82Eventlet is a concurrent networking library for Python that allows you
83to change how you run your code, not how you write it.
84
85It uses epoll or libevent for highly scalable non-blocking I/O.
86Coroutines ensure that the developer uses a blocking style of
87programming that is similar to threading, but provide the benefits of
88non-blocking I/O. The event dispatch is implicit, which means you can
89easily use Eventlet from the Python interpreter, or as a small part of
90a larger application.
91
92%description -n python3-eventlet -l pl.UTF-8
93Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
94zmianę sposobu uruchamiania kodu bez sposobu pisania go.
95
96Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
97nieblokujących operacji we/wy. Korutyny zapewniają, że programista
98korzysta z blokującego stylu programowania, podobnego do wątkowego,
99ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
100domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
101interpretera Pythona lub jako małej części dużej aplikacji.
102
103%package apidocs
104Summary: API documentation for eventlet module
105Summary(pl.UTF-8): Dokumentacja API modułu eventlet
106Group: Documentation
9566f295 107BuildArch: noarch
d2431ecf
JB
108
109%description apidocs
110API documentation for eventlet module.
111
112%description apidocs -l pl.UTF-8
113Dokumentacja API modułu eventlet.
114
115%prep
116%setup -q -n eventlet-%{version}
117
22e1cad0
JB
118# uses network
119%{__rm} tests/greendns_test.py
120# requires local mysql
121%{__rm} tests/mysqldb_test.py
122
d2431ecf
JB
123%build
124%if %{with python2}
243e0dcb
JB
125%py_build
126
63c87a68
JB
127%if %{with tests}
128PYTHONPATH=$(pwd) \
129nosetests-%{py_ver} tests
4ac47e07 130%endif
d2431ecf
JB
131%endif
132
133%if %{with python3}
243e0dcb
JB
134%py3_build
135
63c87a68
JB
136%if %{with tests}
137PYTHONPATH=$(pwd) \
138nosetests-%{py3_ver} tests
4ac47e07 139%endif
d2431ecf
JB
140%endif
141
142%if %{with doc}
63c87a68 143PYTHONPATH=$(pwd) \
d2431ecf 144%{__make} -C doc -j1 html
63c87a68 145%endif
d2431ecf
JB
146
147%install
148rm -rf $RPM_BUILD_ROOT
149
150%if %{with python2}
151%py_install
152
153%py_postclean
154%endif
155
156%if %{with python3}
157%py3_install
158%endif
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%if %{with python2}
164%files
165%defattr(644,root,root,755)
166%doc AUTHORS LICENSE NEWS README.rst
167%{py_sitescriptdir}/eventlet
168%{py_sitescriptdir}/eventlet-%{version}-py*.egg-info
169%endif
170
171%if %{with python3}
172%files -n python3-eventlet
173%defattr(644,root,root,755)
174%doc AUTHORS LICENSE NEWS README.rst
175%{py3_sitescriptdir}/eventlet
176%{py3_sitescriptdir}/eventlet-%{version}-py*.egg-info
177%endif
178
179%if %{with doc}
180%files apidocs
181%defattr(644,root,root,755)
f78da2d8 182%doc doc/_build/html/{_images,_static,modules,*.html,*.js}
d2431ecf 183%endif
This page took 0.696521 seconds and 4 git commands to generate.