]> git.pld-linux.org Git - packages/python-eventlet.git/blame - python-eventlet.spec
noarch; rel 2
[packages/python-eventlet.git] / python-eventlet.spec
CommitLineData
d2431ecf
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
a9f870c5 4%bcond_with tests # unit tests (random timeouts on builders)
d2431ecf
JB
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Highly concurrent networking library for Python 2
9Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 2
10Name: python-eventlet
6d7c3a3e 11Version: 0.25.1
8a82a42a 12Release: 2
d2431ecf
JB
13License: MIT
14Group: Development/Languages/Python
f78da2d8 15#Source0Download: https://pypi.org/simple/eventlet/
243e0dcb 16Source0: https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
6d7c3a3e
JB
17# Source0-md5: 8d7145af6506d5418c5a6bee7bf0b7e7
18Patch0: %{name}-monotonic.patch
f78da2d8 19URL: https://pypi.org/project/eventlet/
d2431ecf
JB
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
6d7c3a3e
JB
23BuildRequires: python-devel >= 1:2.7
24BuildRequires: python-setuptools >= 1:5.4.1
d2431ecf 25%if %{with tests}
6d7c3a3e 26BuildRequires: python-dns >= 1.15.0
243e0dcb 27BuildRequires: python-enum34
d2431ecf 28BuildRequires: python-greenlet >= 0.3
6d7c3a3e 29BuildRequires: python-monotonic >= 1.4
d2431ecf 30BuildRequires: python-nose >= 1.3.1
6d7c3a3e 31BuildRequires: python-six >= 1.10.0
22e1cad0 32BuildRequires: python-subprocess32
d2431ecf
JB
33%endif
34%endif
35%if %{with python3}
6d7c3a3e
JB
36BuildRequires: python3-devel >= 1:3.4
37BuildRequires: python3-setuptools >= 1:5.4.1
d2431ecf 38%if %{with tests}
6d7c3a3e 39BuildRequires: python3-dns >= 1.15.0
d2431ecf
JB
40BuildRequires: python3-greenlet >= 0.3
41BuildRequires: python3-nose >= 1.3.1
6d7c3a3e 42BuildRequires: python3-six >= 1.10.0
d2431ecf
JB
43%endif
44%endif
45%{?with_doc:BuildRequires: sphinx-pdg}
4ac47e07
JB
46%if %{with tests}
47# SO_REUSEPORT option for tests.convenience_test.test_socket_reuse
48BuildRequires: uname(release) >= 3.9
49%endif
6d7c3a3e 50Requires: python-modules >= 1:2.7
8a82a42a 51BuildArch: noarch
d2431ecf
JB
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
55Eventlet is a concurrent networking library for Python that allows you
56to change how you run your code, not how you write it.
57
58It uses epoll or libevent for highly scalable non-blocking I/O.
59Coroutines ensure that the developer uses a blocking style of
60programming that is similar to threading, but provide the benefits of
61non-blocking I/O. The event dispatch is implicit, which means you can
62easily use Eventlet from the Python interpreter, or as a small part of
63a larger application.
64
65%description -l pl.UTF-8
66Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
67zmianę sposobu uruchamiania kodu bez sposobu pisania go.
68
69Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
70nieblokujących operacji we/wy. Korutyny zapewniają, że programista
71korzysta z blokującego stylu programowania, podobnego do wątkowego,
72ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
73domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
74interpretera Pythona lub jako małej części dużej aplikacji.
75
76%package -n python3-eventlet
77Summary: Highly concurrent networking library for Python 3
78Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 3
79Group: Development/Languages/Python
6d7c3a3e 80Requires: python3-modules >= 1:3.4
d2431ecf
JB
81
82%description -n python3-eventlet
83Eventlet is a concurrent networking library for Python that allows you
84to change how you run your code, not how you write it.
85
86It uses epoll or libevent for highly scalable non-blocking I/O.
87Coroutines ensure that the developer uses a blocking style of
88programming that is similar to threading, but provide the benefits of
89non-blocking I/O. The event dispatch is implicit, which means you can
90easily use Eventlet from the Python interpreter, or as a small part of
91a larger application.
92
93%description -n python3-eventlet -l pl.UTF-8
94Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
95zmianę sposobu uruchamiania kodu bez sposobu pisania go.
96
97Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
98nieblokujących operacji we/wy. Korutyny zapewniają, że programista
99korzysta z blokującego stylu programowania, podobnego do wątkowego,
100ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
101domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
102interpretera Pythona lub jako małej części dużej aplikacji.
103
104%package apidocs
105Summary: API documentation for eventlet module
106Summary(pl.UTF-8): Dokumentacja API modułu eventlet
107Group: Documentation
9566f295 108BuildArch: noarch
d2431ecf
JB
109
110%description apidocs
111API documentation for eventlet module.
112
113%description apidocs -l pl.UTF-8
114Dokumentacja API modułu eventlet.
115
116%prep
117%setup -q -n eventlet-%{version}
6d7c3a3e 118%patch0 -p1
d2431ecf 119
22e1cad0
JB
120# uses network
121%{__rm} tests/greendns_test.py
122# requires local mysql
123%{__rm} tests/mysqldb_test.py
124
d2431ecf
JB
125%build
126%if %{with python2}
243e0dcb
JB
127%py_build
128
63c87a68
JB
129%if %{with tests}
130PYTHONPATH=$(pwd) \
131nosetests-%{py_ver} tests
4ac47e07 132%endif
d2431ecf
JB
133%endif
134
135%if %{with python3}
243e0dcb
JB
136%py3_build
137
63c87a68
JB
138%if %{with tests}
139PYTHONPATH=$(pwd) \
140nosetests-%{py3_ver} tests
4ac47e07 141%endif
d2431ecf
JB
142%endif
143
144%if %{with doc}
63c87a68 145PYTHONPATH=$(pwd) \
d2431ecf 146%{__make} -C doc -j1 html
63c87a68 147%endif
d2431ecf
JB
148
149%install
150rm -rf $RPM_BUILD_ROOT
151
152%if %{with python2}
153%py_install
154
155%py_postclean
156%endif
157
158%if %{with python3}
159%py3_install
160%endif
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%if %{with python2}
166%files
167%defattr(644,root,root,755)
168%doc AUTHORS LICENSE NEWS README.rst
169%{py_sitescriptdir}/eventlet
170%{py_sitescriptdir}/eventlet-%{version}-py*.egg-info
171%endif
172
173%if %{with python3}
174%files -n python3-eventlet
175%defattr(644,root,root,755)
176%doc AUTHORS LICENSE NEWS README.rst
177%{py3_sitescriptdir}/eventlet
178%{py3_sitescriptdir}/eventlet-%{version}-py*.egg-info
179%endif
180
181%if %{with doc}
182%files apidocs
183%defattr(644,root,root,755)
f78da2d8 184%doc doc/_build/html/{_images,_static,modules,*.html,*.js}
d2431ecf 185%endif
This page took 0.087796 seconds and 4 git commands to generate.