]> git.pld-linux.org Git - packages/python-eventlet.git/blame - python-eventlet.spec
- tests BR: python-subprocess32; disable some tests requiring particular environment
[packages/python-eventlet.git] / python-eventlet.spec
CommitLineData
d2431ecf
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
6d7c3a3e 4%bcond_without tests # unit tests
d2431ecf
JB
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Highly concurrent networking library for Python 2
9Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 2
10Name: python-eventlet
6d7c3a3e
JB
11Version: 0.25.1
12Release: 1
d2431ecf
JB
13License: MIT
14Group: Development/Languages/Python
f78da2d8 15#Source0Download: https://pypi.org/simple/eventlet/
243e0dcb 16Source0: https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
6d7c3a3e
JB
17# Source0-md5: 8d7145af6506d5418c5a6bee7bf0b7e7
18Patch0: %{name}-monotonic.patch
f78da2d8 19URL: https://pypi.org/project/eventlet/
d2431ecf
JB
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
6d7c3a3e
JB
23BuildRequires: python-devel >= 1:2.7
24BuildRequires: python-setuptools >= 1:5.4.1
d2431ecf 25%if %{with tests}
6d7c3a3e 26BuildRequires: python-dns >= 1.15.0
243e0dcb 27BuildRequires: python-enum34
d2431ecf 28BuildRequires: python-greenlet >= 0.3
6d7c3a3e 29BuildRequires: python-monotonic >= 1.4
d2431ecf 30BuildRequires: python-nose >= 1.3.1
6d7c3a3e 31BuildRequires: python-six >= 1.10.0
22e1cad0 32BuildRequires: python-subprocess32
d2431ecf
JB
33%endif
34%endif
35%if %{with python3}
6d7c3a3e
JB
36BuildRequires: python3-devel >= 1:3.4
37BuildRequires: python3-setuptools >= 1:5.4.1
d2431ecf 38%if %{with tests}
6d7c3a3e 39BuildRequires: python3-dns >= 1.15.0
d2431ecf
JB
40BuildRequires: python3-greenlet >= 0.3
41BuildRequires: python3-nose >= 1.3.1
6d7c3a3e 42BuildRequires: python3-six >= 1.10.0
d2431ecf
JB
43%endif
44%endif
45%{?with_doc:BuildRequires: sphinx-pdg}
4ac47e07
JB
46%if %{with tests}
47# SO_REUSEPORT option for tests.convenience_test.test_socket_reuse
48BuildRequires: uname(release) >= 3.9
49%endif
6d7c3a3e 50Requires: python-modules >= 1:2.7
d2431ecf
JB
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54Eventlet is a concurrent networking library for Python that allows you
55to change how you run your code, not how you write it.
56
57It uses epoll or libevent for highly scalable non-blocking I/O.
58Coroutines ensure that the developer uses a blocking style of
59programming that is similar to threading, but provide the benefits of
60non-blocking I/O. The event dispatch is implicit, which means you can
61easily use Eventlet from the Python interpreter, or as a small part of
62a larger application.
63
64%description -l pl.UTF-8
65Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
66zmianę sposobu uruchamiania kodu bez sposobu pisania go.
67
68Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
69nieblokujących operacji we/wy. Korutyny zapewniają, że programista
70korzysta z blokującego stylu programowania, podobnego do wątkowego,
71ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
72domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
73interpretera Pythona lub jako małej części dużej aplikacji.
74
75%package -n python3-eventlet
76Summary: Highly concurrent networking library for Python 3
77Summary(pl.UTF-8): Biblioteka sieciowa o dużym stopniu zrównoleglenia dla Pythona 3
78Group: Development/Languages/Python
6d7c3a3e 79Requires: python3-modules >= 1:3.4
d2431ecf
JB
80
81%description -n python3-eventlet
82Eventlet is a concurrent networking library for Python that allows you
83to change how you run your code, not how you write it.
84
85It uses epoll or libevent for highly scalable non-blocking I/O.
86Coroutines ensure that the developer uses a blocking style of
87programming that is similar to threading, but provide the benefits of
88non-blocking I/O. The event dispatch is implicit, which means you can
89easily use Eventlet from the Python interpreter, or as a small part of
90a larger application.
91
92%description -n python3-eventlet -l pl.UTF-8
93Eventlet to równoległa biblioteka sieciowa dla Ptyhona, pozwalająca na
94zmianę sposobu uruchamiania kodu bez sposobu pisania go.
95
96Biblioteka wykorzystuje epoll lub libevent do wysoko skalowalnych,
97nieblokujących operacji we/wy. Korutyny zapewniają, że programista
98korzysta z blokującego stylu programowania, podobnego do wątkowego,
99ale mającego zalety nieblokującego we/wy. Przekazywania zdarzeń jest
100domyślne, co oznacza, że można łatwo używać modułu Eventlet z poziomu
101interpretera Pythona lub jako małej części dużej aplikacji.
102
103%package apidocs
104Summary: API documentation for eventlet module
105Summary(pl.UTF-8): Dokumentacja API modułu eventlet
106Group: Documentation
22e1cad0 107%if "%{_rpmversion}" >= "4.6"
9566f295
ER
108BuildArch: noarch
109%endif
d2431ecf
JB
110
111%description apidocs
112API documentation for eventlet module.
113
114%description apidocs -l pl.UTF-8
115Dokumentacja API modułu eventlet.
116
117%prep
118%setup -q -n eventlet-%{version}
6d7c3a3e 119%patch0 -p1
d2431ecf 120
22e1cad0
JB
121# uses network
122%{__rm} tests/greendns_test.py
123# requires local mysql
124%{__rm} tests/mysqldb_test.py
125
d2431ecf
JB
126%build
127%if %{with python2}
243e0dcb
JB
128%py_build
129
63c87a68
JB
130%if %{with tests}
131PYTHONPATH=$(pwd) \
132nosetests-%{py_ver} tests
4ac47e07 133%endif
d2431ecf
JB
134%endif
135
136%if %{with python3}
243e0dcb
JB
137%py3_build
138
63c87a68
JB
139%if %{with tests}
140PYTHONPATH=$(pwd) \
141nosetests-%{py3_ver} tests
4ac47e07 142%endif
d2431ecf
JB
143%endif
144
145%if %{with doc}
63c87a68 146PYTHONPATH=$(pwd) \
d2431ecf 147%{__make} -C doc -j1 html
63c87a68 148%endif
d2431ecf
JB
149
150%install
151rm -rf $RPM_BUILD_ROOT
152
153%if %{with python2}
154%py_install
155
156%py_postclean
157%endif
158
159%if %{with python3}
160%py3_install
161%endif
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166%if %{with python2}
167%files
168%defattr(644,root,root,755)
169%doc AUTHORS LICENSE NEWS README.rst
170%{py_sitescriptdir}/eventlet
171%{py_sitescriptdir}/eventlet-%{version}-py*.egg-info
172%endif
173
174%if %{with python3}
175%files -n python3-eventlet
176%defattr(644,root,root,755)
177%doc AUTHORS LICENSE NEWS README.rst
178%{py3_sitescriptdir}/eventlet
179%{py3_sitescriptdir}/eventlet-%{version}-py*.egg-info
180%endif
181
182%if %{with doc}
183%files apidocs
184%defattr(644,root,root,755)
f78da2d8 185%doc doc/_build/html/{_images,_static,modules,*.html,*.js}
d2431ecf 186%endif
This page took 0.064843 seconds and 4 git commands to generate.