]> git.pld-linux.org Git - packages/python-elixir.git/blame - python-elixir.spec
sqlalchemy 0.8+ fix
[packages/python-elixir.git] / python-elixir.spec
CommitLineData
1909230f
MK
1%define module elixir
2Summary: Declarative layer on top of the SQLAlchemy library
3Summary(pl.UTF-8): Warstwa nad biblioteką SQLAlchemy.
4Name: python-%{module}
2c434366 5Version: 0.7.1
975ba576 6Release: 4
1909230f
MK
7License: MIT
8Group: Development/Languages/Python
975ba576 9Source0: https://pypi.python.org/packages/source/E/Elixir/Elixir-%{version}.tar.gz
2c434366 10# Source0-md5: 5615ec9693e3a8e44f69623d58f54116
975ba576 11Patch0: sqlalchemy-0.8.patch
1909230f 12URL: http://elixir.ematia.de/trac/wiki
edef4522 13BuildRequires: python-setuptools
1909230f 14BuildRequires: rpm-pythonprov
1909230f 15BuildRequires: rpmbuild(macros) >= 1.219
975ba576 16Requires: python-sqlalchemy >= 0.8
1909230f
MK
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21A declarative layer on top of SQLAlchemy. It is a fairly thin wrapper,
22which provides the ability to create simple Python classes that map
23directly to relational database tables (this pattern is often referred
24to as the Active Record design pattern), providing many of the
25benefits of traditional databases without losing the convenience of
26Python objects.
27
28%description -l pl.UTF-8
29Cienka dodatkowa warstwa ponad SQLAlchemy. Pozwala tworzyć proste
30klasy Pythonowe bezpośrednio mapowane do tabel relacyjnej bazy danych
2e9dbf33
ER
31(często nazywane też wzorcem projektowym Active Record) dając wiele z
32zalet tradycyjnych baz danych bez straty wygody obiektów Pythonowych.
1909230f
MK
33
34%prep
35%setup -q -n Elixir-%{version}
975ba576 36%patch0 -p1
1909230f
MK
37
38%build
2e9dbf33 39CFLAGS="%{rpmcflags}" \
1909230f
MK
40%{__python} setup.py build
41
42%install
43rm -rf $RPM_BUILD_ROOT
44%{__python} setup.py install \
45 --optimize=2 \
46 --root=$RPM_BUILD_ROOT
47
48%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
49%py_comp $RPM_BUILD_ROOT%{py_sitedir}
50%py_postclean
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
2e9dbf33
ER
57%{py_sitescriptdir}/elixir
58%{py_sitescriptdir}/Elixir-%{version}-py*.egg-info
This page took 0.073531 seconds and 4 git commands to generate.