]> git.pld-linux.org Git - packages/python-efl.git/blame - python-efl.spec
- release 4 (by relup.sh)
[packages/python-efl.git] / python-efl.spec
CommitLineData
2c1e215e 1%define efl_ver 1.10.0
5f6fc0df 2%define ecore_ver %{efl_ver}
5f6fc0df
JB
3%define edje_ver %{efl_ver}
4%define eina_ver %{efl_ver}
5%define emotion_ver %{efl_ver}
6%define eo_ver %{efl_ver}
2c1e215e 7%define ethumb_ver %{efl_ver}
5f6fc0df 8%define evas_ver %{efl_ver}
2c1e215e 9%define elementary_ver 1.10.0
68342a85
JB
10%define py_dbus_ver 0.83.0
11
12Summary: Python bindings for Enlightenment Foundation Libraries
13Summary(pl.UTF-8): Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
14Name: python-efl
a51b1055 15Version: 1.10.1
ab444184 16Release: 4
68342a85
JB
17License: LGPL v3+
18Group: Development/Languages/Python
bd4ad564 19Source0: http://download.enlightenment.org/rel/bindings/python/%{name}-%{version}.tar.bz2
a51b1055
JB
20# Source0-md5: 5f95d3ee5c4bb2a1a616d44d0cc5f0d0
21Patch0: %{name}-cython.patch
68342a85
JB
22URL: http://trac.enlightenment.org/e/wiki/Python
23BuildRequires: python-dbus-devel >= %{py_dbus_ver}
24BuildRequires: ecore-devel >= %{ecore_ver}
2c1e215e
JB
25BuildRequires: ecore-file-devel >= %{ecore_ver}
26BuildRequires: ecore-input-devel >= %{ecore_ver}
27BuildRequires: ecore-x-devel >= %{ecore_ver}
68342a85
JB
28BuildRequires: edje-devel >= %{edje_ver}
29BuildRequires: eina-devel >= %{eina_ver}
30BuildRequires: elementary-devel >= %{elementary_ver}
31BuildRequires: emotion-devel >= %{emotion_ver}
32BuildRequires: eo-devel >= %{eo_ver}
2c1e215e 33BuildRequires: ethumb-devel >= %{ethumb_ver}
68342a85
JB
34BuildRequires: evas-devel >= %{evas_ver}
35BuildRequires: pkgconfig
36# when using *.pyx sources, not pregenerated *.c
2c1e215e 37#BuildRequires: python-Cython >= 0.19
68342a85
JB
38BuildRequires: python-Sphinx
39BuildRequires: python-devel >= 1:2.7
40BuildRequires: rpm-pythonprov
8872be02 41BuildRequires: rpmbuild(macros) >= 1.710
68342a85
JB
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45EFL is a collection of libraries for handling many common tasks a
46developer man have such as data structures, communication, rendering,
47widgets and more. PYTHON-EFL are the Python bindings for EFL and
48Elementary.
49
50%description -l pl.UTF-8
51EFL to zbiór bibliotek do obsługi wielu częstych zadań programisty,
52takich jak struktury danych, komunikacja, renderowanie, widgety itp.
53PYTHON-EFL to wiązania Pythona do bibliotek EFL i Elementary.
54
55%package base
56Summary: Python bindings for Enlightenment Foundation Libraries - base common part
57Summary(pl.UTF-8): Wiązania Pythona do bibliotek EFL - wspólna część podstawowa
58Group: Development/Languages/Python
59Requires: eina >= %{eina_ver}
60Requires: eo >= %{eina_ver}
61
62%description base
63Python bindings for Enlightenment Foundation Libraries - base common
64part:
65- Eo library binding
66- efl.utils modules
67
68%description base
69Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
70- wspólna część podstawowa:
71- wiązanie do biblioteki Eo
72- moduły efl.utils
73
74%package examples
75Summary: Examples for PYTHON-EFL bindings
76Summary(pl.UTF-8): Przykłady do wiązań PYTHON-EFL
77Group: Development/Libraries
78Requires: python-dbus >= %{py_dbus_ver}
79Requires: python-e_dbus = %{version}-%{release}
80Requires: python-ecore = %{version}-%{release}
2c1e215e 81Requires: python-ecore-x = %{version}-%{release}
68342a85
JB
82Requires: python-edje = %{version}-%{release}
83Requires: python-elementary = %{version}-%{release}
84Requires: python-emotion = %{version}-%{release}
85Requires: python-evas = %{version}-%{release}
86
87%description examples
88Examples for PYTHON-EFL bindings.
89
90%description examples -l pl.UTF-8
91Przykłady do wiązań PYTHON-EFL.
92
93%package -n python-e_dbus
94Summary: D-Bus Python integration for Ecore main loop
95Summary(pl.UTF-8): Integracja Python i DBus z główną pętlą Ecore
96Group: Development/Languages/Python
97Requires: %{name}-base = %{version}-%{release}
98Requires: ecore >= %{ecore_ver}
99Obsoletes: python-e_dbus < 1.8.0
ab4592f4 100Obsoletes: python-e_dbus-devel < 1.8.0
68342a85
JB
101
102%description -n python-e_dbus
103D-Bus Python integration for Ecore main loop. There is also e_dbus
104API provided for compatibility with EFL 1.7.0 bindings.
105
106%description -n python-e_dbus -l pl.UTF-8
107Integracja Python i DBus z główną pętlą Ecore. Dołączone jest także
108API e_dbus dla kompatybilności z wiązaniami EFL 1.7.0.
109
110%package -n python-ecore
111Summary: Python bindings for Ecore library
112Summary(pl.UTF-8): Wiązania Pythona do biblioteki Ecore
113Group: Development/Languages/Python
114Requires: %{name}-base = %{version}-%{release}
115Requires: ecore >= %{ecore_ver}
2c1e215e 116Requires: ecore-file >= %{ecore_ver}
68342a85
JB
117Obsoletes: python-ecore-devel < 1.8.0
118Obsoletes: python-ecore-evas < 1.8.0
119Obsoletes: python-ecore-evas-devel < 1.8.0
120Obsoletes: python-ecore-file < 1.8.0
121Obsoletes: python-ecore-file-devel < 1.8.0
122Obsoletes: python-ecore-imf < 1.8.0
123Obsoletes: python-ecore-imf-devel < 1.8.0
68342a85
JB
124
125%description -n python-ecore
126Python bindings for Ecore library.
127
128%description -n python-ecore -l pl.UTF-8
129Wiązania Pythona do biblioteki Ecore.
130
2c1e215e
JB
131%package -n python-ecore-x
132Summary: Python bindings for Ecore X library
133Summary(pl.UTF-8): Wiązania Pythona do biblioteki Ecore X
134Group: Development/Languages/Python
135Requires: python-ecore = %{version}-%{release}
136Requires: ecore-input >= %{ecore_ver}
137Requires: ecore-x >= %{ecore_ver}
ab4592f4 138Obsoletes: python-ecore-x-devel < 1.8.0
2c1e215e
JB
139
140%description -n python-ecore-x
141Python bindings for Ecore X library.
142
143%description -n python-ecore-x -l pl.UTF-8
144Wiązania Pythona do biblioteki Ecore X.
145
68342a85
JB
146%package -n python-edje
147Summary: Python bindings for Edje library
148Summary(pl.UTF-8): Wiązania Pythona do biblioteki Edje
149Group: Development/Languages/Python
150Requires: %{name}-base = %{version}-%{release}
151Requires: edje-libs >= %{edje_ver}
152Requires: eina >= %{eina_ver}
153Obsoletes: python-edje-devel < 1.8.0
154
155%description -n python-edje
156Python bindings for Edje library.
157
158%description -n python-edje -l pl.UTF-8
159Wiązania Pythona do biblioteki Edje.
160
161%package -n python-elementary
162Summary: Python bindings for Elementary library
163Summary(pl.UTF-8): Wiązania Pythona do biblioteki Elementary
164Group: Development/Languages/Python
165Requires: %{name}-base = %{version}-%{release}
166Requires: eina >= %{eina_ver}
167Requires: elementary-libs >= %{elementary_ver}
168Requires: evas >= %{evas_ver}
169Obsoletes: python-elementary-devel < 1.8.0
170
171%description -n python-elementary
172Python bindings for Elementary library.
173
174%description -n python-elementary -l pl.UTF-8
175Wiązania Pythona do biblioteki Elementary.
176
177%package -n python-emotion
178Summary: Python bindings for Emotion library
179Summary(pl.UTF-8): Wiązania Pythona do biblioteki Emotion
180Group: Development/Languages/Python
181Requires: %{name}-base = %{version}-%{release}
182Requires: emotion >= %{emotion_ver}
183Requires: evas >= %{evas_ver}
184Obsoletes: python-emotion-devel < 1.8.0
185
186%description -n python-emotion
187Python bindings for Emotion library.
188
189%description -n python-emotion -l pl.UTF-8
190Wiązania Pythona do biblioteki Emotion.
191
2c1e215e
JB
192%package -n python-ethumb
193Summary: Python bindings for Ethumb library
194Summary(pl.UTF-8): Wiązania Pythona do biblioteki Ethumb
195Group: Development/Languages/Python
196Requires: %{name}-base = %{version}-%{release}
197Requires: ethumb-libs >= %{ethumb_ver}
ab4592f4 198Obsoletes: python-ethumb-devel < 1.8.0
2c1e215e
JB
199
200%description -n python-ethumb
201Python bindings for Ethumb library.
202
203%description -n python-ethumb -l pl.UTF-8
204Wiązania Pythona do biblioteki Ethumb.
205
68342a85
JB
206%package -n python-evas
207Summary: Python bindings for Evas library
208Summary(pl.UTF-8): Wiązania Pythona do biblioteki Evas
209Group: Development/Languages/Python
210Requires: %{name}-base = %{version}-%{release}
211Requires: eina >= %{eina_ver}
212Requires: evas >= %{evas_ver}
213Obsoletes: python-evas-devel < 1.8.0
214
215%description -n python-evas
216Python bindings for Evas library.
217
218%description -n python-evas -l pl.UTF-8
219Wiązania Pythona do biblioteki Evas.
220
221%prep
222%setup -q
a51b1055 223%patch0 -p1
68342a85
JB
224
225%{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' \
226 examples/dbus/*.py \
227 examples/elementary/*.py \
228 examples/emotion/*.py \
229
230%build
231CC="%{__cc}" \
232CFLAGS="%{rpmcflags}" \
a51b1055 233DISABLE_CYTHON=1 \
505c16d5 234%py_build
68342a85
JB
235
236%install
237rm -rf $RPM_BUILD_ROOT
238
a51b1055 239DISABLE_CYTHON=1 \
505c16d5 240%py_install
68342a85
JB
241
242%py_postclean
243
244install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
245cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
246
247%clean
248rm -rf $RPM_BUILD_ROOT
249
250%files base
251%defattr(644,root,root,755)
2c1e215e 252%doc AUTHORS README.rst changes.html
68342a85
JB
253%dir %{py_sitedir}/efl
254%{py_sitedir}/efl/__init__.py[co]
255%attr(755,root,root) %{py_sitedir}/efl/eo.so
256%dir %{py_sitedir}/efl/utils
257%{py_sitedir}/efl/utils/__init__.py[co]
258%attr(755,root,root) %{py_sitedir}/efl/utils/*.so
259%{py_sitedir}/python_efl-%{version}-py*.egg-info
260
261%files examples
262%defattr(644,root,root,755)
263%dir %{_examplesdir}/%{name}-%{version}
264%dir %{_examplesdir}/%{name}-%{version}/dbus
265%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/dbus/*.py
2c1e215e
JB
266%dir %{_examplesdir}/%{name}-%{version}/ecore
267%dir %{_examplesdir}/%{name}-%{version}/ecore/x
268%{_examplesdir}/%{name}-%{version}/ecore/x/*.py
68342a85
JB
269%dir %{_examplesdir}/%{name}-%{version}/elementary
270%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/elementary/test.py
271%{_examplesdir}/%{name}-%{version}/elementary/test_*.py
272%{_examplesdir}/%{name}-%{version}/elementary/*.edc
273%{_examplesdir}/%{name}-%{version}/elementary/*.edj
274%{_examplesdir}/%{name}-%{version}/elementary/images
275%dir %{_examplesdir}/%{name}-%{version}/emotion
276%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/emotion/test_emotion.py
bd4ad564 277%{_examplesdir}/%{name}-%{version}/emotion/theme.edj
68342a85
JB
278
279%files -n python-e_dbus
280%defattr(644,root,root,755)
281%attr(755,root,root) %{py_sitedir}/efl/dbus_mainloop.so
282%{py_sitedir}/e_dbus
283
284%files -n python-ecore
285%defattr(644,root,root,755)
2c1e215e
JB
286%dir %{py_sitedir}/efl/ecore
287%attr(755,root,root) %{py_sitedir}/efl/ecore/__init__.so
288%{py_sitedir}/efl/ecore/__init__.py[co]
68342a85
JB
289%{py_sitedir}/ecore
290
2c1e215e
JB
291%files -n python-ecore-x
292%defattr(644,root,root,755)
293%attr(755,root,root) %{py_sitedir}/efl/ecore/x.so
294
68342a85
JB
295%files -n python-edje
296%defattr(644,root,root,755)
297%attr(755,root,root) %{py_sitedir}/efl/edje.so
bd4ad564 298%attr(755,root,root) %{py_sitedir}/efl/edje_edit.so
68342a85
JB
299%{py_sitedir}/edje
300
301%files -n python-elementary
302%defattr(644,root,root,755)
303%dir %{py_sitedir}/efl/elementary
304%{py_sitedir}/efl/elementary/__init__.py[co]
305%attr(755,root,root) %{py_sitedir}/efl/elementary/*.so
306%{py_sitedir}/elementary
307
308%files -n python-emotion
309%defattr(644,root,root,755)
310%attr(755,root,root) %{py_sitedir}/efl/emotion.so
311%{py_sitedir}/emotion
312
2c1e215e
JB
313%files -n python-ethumb
314%defattr(644,root,root,755)
315%attr(755,root,root) %{py_sitedir}/efl/ethumb.so
316%attr(755,root,root) %{py_sitedir}/efl/ethumb_client.so
317
68342a85
JB
318%files -n python-evas
319%defattr(644,root,root,755)
320%attr(755,root,root) %{py_sitedir}/efl/evas.so
321%{py_sitedir}/evas
This page took 0.095616 seconds and 5 git commands to generate.