]> git.pld-linux.org Git - packages/python-ecdsa.git/blame - python-ecdsa.spec
- release 4 (by relup.sh)
[packages/python-ecdsa.git] / python-ecdsa.spec
CommitLineData
dbb99fda
AM
1#
2# Conditional build:
3%bcond_without python2 # Python 2.x module
4%bcond_without python3 # Python 3.x module
5c144cc7
ER
5
6%define module ecdsa
dbb99fda 7Summary: ECDSA cryptographic signature library
5c144cc7 8Name: python-%{module}
85e04b5d 9Version: 0.11
5a70f09b 10Release: 4
dbb99fda
AM
11License: GPL
12Group: Development/Languages/Python
5c144cc7 13Source0: http://pypi.python.org/packages/source/e/ecdsa/%{module}-%{version}.tar.gz
85e04b5d 14# Source0-md5: 8ef586fe4dbb156697d756900cb41d7c
dbb99fda 15URL: https://pypi.python.org/pypi/ecdsa
5c144cc7 16BuildRequires: rpm-pythonprov
dbb99fda
AM
17%if %{with python2}
18BuildRequires: python-devel
19BuildRequires: python-modules
dbb99fda
AM
20%endif
21%if %{with python3}
22BuildRequires: python3-2to3
23BuildRequires: python3-devel
24BuildRequires: python3-modules
25%endif
5c144cc7 26Requires: python
dbb99fda
AM
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31This is an easy-to-use implementation of ECDSA cryptography (Elliptic
32Curve Digital Signature Algorithm), implemented purely in Python,
33released under the MIT license. With this library, you can quickly
34create keypairs (signing key and verifying key), sign messages, and
35verify the signatures. The keys and signatures are very short, making
36them easy to handle and incorporate into other protocols.
37
85e04b5d 38%package -n python3-%{module}
dbb99fda 39Summary: ECDSA cryptographic signature library
dbb99fda
AM
40Group: Libraries/Python
41Requires: python3
42
43%description -n python3-%{module}
44This is an easy-to-use implementation of ECDSA cryptography (Elliptic
45Curve Digital Signature Algorithm), implemented purely in Python,
46released under the MIT license. With this library, you can quickly
47create keypairs (signing key and verifying key), sign messages, and
48verify the signatures. The keys and signatures are very short, making
49them easy to handle and incorporate into other protocols.
50
51%prep
52%setup -q -n ecdsa-%{version}
53
54%build
55%if %{with python2}
0796a7a6 56%py_build --build-base py2
dbb99fda
AM
57%endif
58%if %{with python3}
0796a7a6 59%py3_build --build-base py3
dbb99fda
AM
60%endif
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%if %{with python2}
65install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
0796a7a6 66%py_build \
dbb99fda
AM
67 --build-base py2 \
68 install \
69 --optimize 2 \
70 --root=$RPM_BUILD_ROOT
71%endif
72
73%if %{with python3}
74install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
0796a7a6 75%py3_build \
dbb99fda
AM
76 --build-base py3 \
77 install \
78 --optimize 2 \
79 --root=$RPM_BUILD_ROOT
80%endif
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%files
87%defattr(644,root,root,755)
88%doc LICENSE NEWS README.md
dbb99fda 89%{py_sitescriptdir}/%{module}
5c144cc7
ER
90%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
91%{_examplesdir}/python-%{module}-%{version}
dbb99fda
AM
92%endif
93
94%if %{with python3}
95%files -n python3-%{module}
96%defattr(644,root,root,755)
97%doc LICENSE NEWS README.md
dbb99fda 98%{py3_sitescriptdir}/%{module}
5c144cc7
ER
99%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
100%{_examplesdir}/python3-%{module}-%{version}
dbb99fda 101%endif
This page took 0.10448 seconds and 4 git commands to generate.