]> git.pld-linux.org Git - packages/python-dotenv.git/blame - python-dotenv.spec
rebuild with python 3.10
[packages/python-dotenv.git] / python-dotenv.spec
CommitLineData
01b745f2
JP
1# Conditional build:
2%bcond_without python2 # CPython 2.x module
3%bcond_without python3 # CPython 3.x module
4
5%define module dotenv
6%define pypi_name python-dotenv
7%define egg_name python_dotenv
8Summary: Add .env support to your django/flask apps in development and deployments
9Name: python-%{module}
f84d6390 10Version: 0.17.0
64cc3a94 11Release: 3
01b745f2
JP
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/python-dotenv/
15Source0: https://files.pythonhosted.org/packages/source/p/python-dotenv/%{pypi_name}-%{version}.tar.gz
f84d6390 16# Source0-md5: 664e1fd991a2dd109c95b743bb9eecd5
01b745f2
JP
17URL: https://pypi.org/project/python-dotenv/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.5
20BuildRequires: python-setuptools
21%endif
22%if %{with python3}
23BuildRequires: python3-modules >= 1:3.2
24BuildRequires: python3-setuptools
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28Requires: python-modules >= 1:2.5
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Add .env support to your django/flask apps in development and
34deployments.
35
36%package -n python3-%{module}
37Summary: -
38Summary(pl.UTF-8): -
39Group: Libraries/Python
40Requires: python3-modules >= 1:3.2
41
42%description -n python3-%{module}
43Add .env support to your django/flask apps in development and
44deployments.
45
46%prep
47%setup -q -n %{pypi_name}-%{version}
48
49%build
50%if %{with python2}
51%py_build
52%endif
53
54%if %{with python3}
55%py3_build
56%endif
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%if %{with python2}
62%py_install
63
64%py_postclean
65%endif
66
67%if %{with python3}
68%py3_install
69%endif
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%if %{with python2}
75%files
76%defattr(644,root,root,755)
77%doc CHANGELOG.md CONTRIBUTING.md README.md
78%{py_sitescriptdir}/%{module}
79%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
80%endif
81
82%if %{with python3}
83%files -n python3-%{module}
84%defattr(644,root,root,755)
85%doc CHANGELOG.md CONTRIBUTING.md README.md
86%{py3_sitescriptdir}/%{module}
87%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
88%endif
This page took 0.207568 seconds and 4 git commands to generate.