]> git.pld-linux.org Git - packages/python-docker-pycreds.git/blame - python-docker-pycreds.spec
up to 0.2.2
[packages/python-docker-pycreds.git] / python-docker-pycreds.spec
CommitLineData
0a5f1baa
ER
1#
2# Conditional build:
3%bcond_without doc # don't build doc
4%bcond_with tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module dockerpycreds
9%define egg_name docker_pycreds
10%define pypi_name docker-pycreds
11Summary: Python bindings for the docker credentials store API
12Name: python-%{pypi_name}
738dd5f7
ER
13Version: 0.2.2
14Release: 1
f969b51b 15License: Apache v2.0
0a5f1baa
ER
16Group: Libraries/Python
17Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
738dd5f7 18# Source0-md5: ae63c7def3e58cb51a4d8f5810683030
6424983d 19URL: https://github.com/shin-/dockerpy-creds
0a5f1baa
ER
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
23BuildRequires: python-modules
24BuildRequires: python-setuptools
25%if %{with tests}
26BuildRequires: python-flake8 = 2.4.1
27BuildRequires: python-pytest = 3.0.2
28BuildRequires: python-pytest-cov = 2.3.1
29%endif
30%endif
31%if %{with python3}
32BuildRequires: python3-modules
33BuildRequires: python3-setuptools
34%if %{with tests}
35BuildRequires: python3-flake8 = 2.4.1
36BuildRequires: python3-pytest = 3.0.2
37BuildRequires: python3-pytest-cov = 2.3.1
38%endif
39%endif
0a5f1baa
ER
40BuildArch: noarch
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44Python 2 bindings for the docker credentials store API
45
46%package -n python3-%{pypi_name}
47Summary: Python bindings for the docker credentials store API
48Group: Libraries/Python
0a5f1baa
ER
49
50%description -n python3-%{pypi_name}
51Python 3 bindings for the docker credentials store API
52
53%prep
54%setup -q -n %{pypi_name}-%{version}
55
56# Remove bundled egg-info
4f078be4 57%{__rm} -r %{egg_name}.egg-info
0a5f1baa
ER
58
59%build
60%if %{with python2}
61%py_build %{?with_tests:test}
62%endif
63
64%if %{with python3}
65%py3_build %{?with_tests:test}
66%endif
67
68%install
69rm -rf $RPM_BUILD_ROOT
70%if %{with python2}
71%py_install
72%py_postclean
73%endif
74
75%if %{with python3}
76%py3_install
77%endif
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%if %{with python2}
83%files
84%defattr(644,root,root,755)
85%doc README.md
86%{py_sitescriptdir}/%{module}
87%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
88%endif
89
90%if %{with python3}
91%files -n python3-%{pypi_name}
92%defattr(644,root,root,755)
93%doc README.md
94%{py3_sitescriptdir}/%{module}
95%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
96%endif
97
This page took 0.105576 seconds and 4 git commands to generate.