]> git.pld-linux.org Git - packages/python-distutils-extra.git/blame - python-distutils-extra.spec
- python 3.7 rebuild
[packages/python-distutils-extra.git] / python-distutils-extra.spec
CommitLineData
aeb7cd40
ER
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7%define pkgname distutils-extra
8%define module DistUtilsExtra
9%define egg_name python_distutils_extra
ec9e802c
JB
10Summary: Python 2 DistUtilsExtra module - i18n, documentation and icons support for distutils
11Summary(pl.UTF-8): Moduł Pythona 2 DistUtilsExtra - obsługa i18n, dokumentacji i ikon dla distutils
aeb7cd40
ER
12Name: python-%{pkgname}
13Version: 2.39
c7f0e875 14Release: 3
b57aaf20 15License: GPL v2
8031193d 16Group: Libraries/Python
aeb7cd40
ER
17Source0: http://launchpad.net/python-distutils-extra/trunk/%{version}/+download/%{name}-%{version}.tar.gz
18# Source0-md5: 16e06db0ef73a35b4bff4b9eed5699b5
8031193d 19URL: http://www.glatzor.de/projects/python-distutils-extra/
5aab193c 20BuildRequires: rpm-pythonprov
40bf793f 21BuildRequires: rpmbuild(macros) >= 1.710
aeb7cd40
ER
22%if %{with python2}
23BuildRequires: python-devel >= 1:2.5
ec9e802c 24BuildRequires: python-modules >= 1:2.5
aeb7cd40
ER
25BuildRequires: python-setuptools
26%endif
27%if %{with python3}
ec9e802c
JB
28BuildRequires: python3-devel >= 1:3.2
29BuildRequires: python3-modules >= 1:3.2
aeb7cd40
ER
30BuildRequires: python3-setuptools
31%endif
32BuildArch: noarch
8031193d
MWP
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Python-distutils-extra allows to easily integrate themable icons,
37scrollkeeper based documentation and gettext based translations in
aeb7cd40 38your Python install and build tools. It can be used with Python's
8031193d
MWP
39distutils or the enhanced setuptools.
40
5aab193c
JB
41%description -l pl.UTF-8
42Ten pakiet pozwala łatwo zintegrować ikony z obsługą motywów,
43dokumentacje opartą na scrollkeeperze i tłumaczenia oparte na
44gettekście w tworzonych narzędziach do budowania i instalacji pakietów
45pythonowych. Może być używany z pythonowymi distutils lub
46rozszerzonymi setuptools.
47
aeb7cd40 48%package -n python3-%{pkgname}
ec9e802c
JB
49Summary: Python 3 DistUtilsExtra module - i18n, documentation and icons support for distutils
50Summary(pl.UTF-8): Moduł Pythona 3 DistUtilsExtra - obsługa i18n, dokumentacji i ikon dla distutils
aeb7cd40
ER
51Group: Libraries/Python
52
53%description -n python3-%{pkgname}
54Python-distutils-extra allows to easily integrate themable icons,
55scrollkeeper based documentation and gettext based translations in
56your Python install and build tools. It can be used with Python's
57distutils or the enhanced setuptools.
58
ec9e802c
JB
59%description -n python3-%{pkgname} -l pl.UTF-8
60Ten pakiet pozwala łatwo zintegrować ikony z obsługą motywów,
61dokumentacje opartą na scrollkeeperze i tłumaczenia oparte na
62gettekście w tworzonych narzędziach do budowania i instalacji pakietów
63pythonowych. Może być używany z pythonowymi distutils lub
64rozszerzonymi setuptools.
65
8031193d 66%prep
2a7c3ca3 67%setup -q
8031193d
MWP
68
69%build
aeb7cd40
ER
70%if %{with python2}
71%py_build %{?with_tests:test}
72%endif
73
74%if %{with python3}
75%py3_build %{?with_tests:test}
76%endif
8031193d
MWP
77
78%install
79rm -rf $RPM_BUILD_ROOT
aeb7cd40 80%if %{with python2}
1bc8fa89 81%py_install
5aab193c 82%py_postclean
aeb7cd40
ER
83%endif
84
85%if %{with python3}
86%py3_install
87%endif
8031193d
MWP
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
aeb7cd40 92%if %{with python2}
8031193d
MWP
93%files
94%defattr(644,root,root,755)
aeb7cd40
ER
95%{py_sitescriptdir}/%{module}
96%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
97%endif
98
99%if %{with python3}
100%files -n python3-%{pkgname}
101%defattr(644,root,root,755)
102%{py3_sitescriptdir}/%{module}
103%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
104%endif
This page took 0.099025 seconds and 4 git commands to generate.