]> git.pld-linux.org Git - packages/python-dicttoxml.git/blame - python-dicttoxml.spec
rebuild with python 3.10
[packages/python-dicttoxml.git] / python-dicttoxml.spec
CommitLineData
7cdfb220
AM
1# Conditional build:
2%bcond_with tests # unit tests
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6# NOTES:
7# - 'module' should match the Python import path (first component?)
8# - 'egg_name' should equal to Python egg name
9# - 'pypi_name' must match the Python Package Index name
10%define module dicttoxml
11%define egg_name dicttoxml
12%define pypi_name dicttoxml
13Summary: Converts a Python dictionary or other native data type into a valid XML string
14Summary(pl.UTF-8): -
15Name: python-%{module}
c59c98a9 16Version: 1.7.4
e5f61461 17Release: 3
7cdfb220
AM
18License: GPL v2+
19Group: Libraries/Python
c59c98a9
AM
20Source0: https://pypi.debian.net/dicttoxml/%{module}-%{version}.tar.gz
21# Source0-md5: ec5643a048cf32dad3c28db236b923e4
7cdfb220
AM
22URL: https://github.com/quandyfactory/dicttoxml
23%if %{with python2}
24BuildRequires: python-modules >= 1:2.5
25BuildRequires: python-setuptools
26%if %{with tests}
27#BuildRequires: python-
28%endif
29%endif
30%if %{with python3}
31BuildRequires: python3-modules >= 1:3.2
32BuildRequires: python3-setuptools
33%if %{with tests}
34#BuildRequires: python3-
35%endif
36%endif
37BuildRequires: rpm-pythonprov
38BuildRequires: rpmbuild(macros) >= 1.714
39Requires: python-modules >= 1:2.5
40BuildArch: noarch
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44Converts a Python dictionary or other native data type into a valid
45XML string.
46
47%package -n python3-%{module}
48Summary: -
49Summary(pl.UTF-8): -
50Group: Libraries/Python
51Requires: python3-modules >= 1:3.2
52
53%description -n python3-%{module}
54Converts a Python dictionary or other native data type into a valid
55XML string.
56
57%prep
58%setup -q -n %{pypi_name}-%{version}
59
60%build
61%if %{with python2}
62%py_build %{?with_tests:test}
63%endif
64
65%if %{with python3}
66%py3_build %{?with_tests:test}
67%endif
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%if %{with python2}
73%py_install
74
75%py_postclean
76%endif
77
78%if %{with python3}
79%py3_install
80%endif
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%files
87%defattr(644,root,root,755)
88%doc README.markdown
89%{py_sitescriptdir}/%{module}.py*
90%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
91%endif
92
93%if %{with python3}
94%files -n python3-%{module}
95%defattr(644,root,root,755)
96%doc README.markdown
97%{py3_sitescriptdir}/%{module}.py*
98%{py3_sitescriptdir}/__pycache__/dicttoxml*
99%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
100%endif
This page took 0.16597 seconds and 4 git commands to generate.