]> git.pld-linux.org Git - packages/python-dictdiffer.git/blame - python-dictdiffer.spec
- pl, python2 note
[packages/python-dictdiffer.git] / python-dictdiffer.spec
CommitLineData
2860bf67
JP
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module dictdiffer
6dde2f34
JB
7Summary: Dictdiffer - a library that helps you to diff and patch dictionaries
8Summary(pl.UTF-8): Dictdiffer - biblioteka pomagająca porównywać i łatać słowniki
2860bf67 9Name: python-%{module}
6dde2f34 10# keep 0.8.x here for python2 support
2860bf67 11Version: 0.8.1
599bafb0 12Release: 6
2860bf67
JP
13License: MIT
14Group: Libraries/Python
15#Source0Download: https://pypi.org/simple/dictdiffer/
16Source0: https://files.pythonhosted.org/packages/source/d/dictdiffer/%{module}-%{version}.tar.gz
17# Source0-md5: 3185fe683d976282bf6313de14b7c7e9
18URL: https://github.com/inveniosoftware/dictdiffer
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.7
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-modules >= 1:3.4
25BuildRequires: python3-setuptools
26%endif
27BuildRequires: rpm-pythonprov
28BuildRequires: rpmbuild(macros) >= 1.714
29Requires: python-modules >= 1:2.7
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Dictdiffer is a helper module that helps you to diff and patch
35dictionaries.
36
6dde2f34
JB
37%description -l pl.UTF-8
38Dictdiffer to moduł pomocniczy, pomagający porównywać i łatać
39słowniki.
40
2860bf67 41%package -n python3-%{module}
6dde2f34
JB
42Summary: Dictdiffer - a library that helps you to diff and patch dictionaries
43Summary(pl.UTF-8): Dictdiffer - biblioteka pomagająca porównywać i łatać słowniki
2860bf67
JP
44Group: Libraries/Python
45Requires: python3-modules >= 1:3.4
46
47%description -n python3-%{module}
48Dictdiffer is a helper module that helps you to diff and patch
49dictionaries.
50
6dde2f34
JB
51%description -n python3-%{module} -l pl.UTF-8
52Dictdiffer to moduł pomocniczy, pomagający porównywać i łatać
53słowniki.
54
2860bf67
JP
55%prep
56%setup -q -n %{module}-%{version}
57
58%build
59%if %{with python2}
60%py_build
61%endif
62
63%if %{with python3}
64%py3_build
65%endif
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%if %{with python2}
71%py_install
72
73%py_postclean
74%endif
75
76%if %{with python3}
77%py3_install
78%endif
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%if %{with python2}
84%files
85%defattr(644,root,root,755)
86%doc AUTHORS CHANGES CONTRIBUTING.rst MAINTAINERS README.rst
87%{py_sitescriptdir}/%{module}
88%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
89%endif
90
91%if %{with python3}
92%files -n python3-%{module}
93%defattr(644,root,root,755)
94%doc AUTHORS CHANGES CONTRIBUTING.rst MAINTAINERS README.rst
95%{py3_sitescriptdir}/%{module}
96%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
97%endif
This page took 0.114704 seconds and 4 git commands to generate.