]> git.pld-linux.org Git - packages/python-debugpy.git/blame - python-debugpy.spec
rebuild with python 3.10
[packages/python-debugpy.git] / python-debugpy.spec
CommitLineData
348f232b
JB
1# TODO: unvendor pydevd? (then debugpy would be noarch)
2#
3# Conditional build:
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Implementation of the Debug Adapter Protocol for Python 2
8Summary(pl.UTF-8): Implementacja protokołu Debug Adapter Protocol dla Pythona 2
9Name: python-debugpy
10Version: 1.3.0
7e3af274 11Release: 2
348f232b
JB
12License: MIT with EPL v1.0, PSF v2, BSD parts
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/debugpy/
15Source0: https://files.pythonhosted.org/packages/source/d/debugpy/debugpy-%{version}.zip
16# Source0-md5: 84900a0cbb80b172d75909b4edcbc736
17URL: https://pypi.org/project/debugpy/
18BuildRequires: libstdc++-devel
19%if %{with python2}
20BuildRequires: python-Cython
21BuildRequires: python-devel >= 1:2.7
22BuildRequires: python-modules >= 1:2.7
23BuildRequires: python-setuptools
24%endif
25%if %{with python3}
26BuildRequires: python3-Cython
27BuildRequires: python3-devel >= 1:3.5
28BuildRequires: python3-modules >= 1:3.5
29BuildRequires: python3-setuptools
30%endif
31BuildRequires: rpm-pythonprov
32BuildRequires: rpmbuild(macros) >= 1.714
33BuildRequires: unzip
34Requires: python-modules >= 1:2.7
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38debugpy is an implementation of the Debug Adapter Protocol for Python.
39
40%description -l pl.UTF-8
41debugpy to implementacja protokołu Debug Adapter Protocol dla Pythona.
42
43%package -n python3-debugpy
44Summary: Implementation of the Debug Adapter Protocol for Python 3
45Summary(pl.UTF-8): Implementacja protokołu Debug Adapter Protocol dla Pythona 3
46Group: Libraries/Python
47Requires: python3-modules >= 1:3.5
48
49%description -n python3-debugpy
50debugpy is an implementation of the Debug Adapter Protocol for Python.
51
52%description -n python3-debugpy -l pl.UTF-8
53debugpy to implementacja protokołu Debug Adapter Protocol dla Pythona.
54
55%prep
56%setup -q -n debugpy-%{version}
57
58%{__rm} src/debugpy/_vendored/pydevd/pydevd_attach_to_process/*.{dll,dylib,exe,pdb,so}
59
60%build
61cd src/debugpy/_vendored/pydevd/pydevd_attach_to_process/linux_and_mac
62%ifarch %{ix86}
63%{__cxx} -shared %{rpmldflags} %{rpmcxxflags} %{rpmcppflags} -fPIC -o ../attach_linux_x86.so attach.cpp
64%endif
65%ifarch %{x8664}
66%{__cxx} -shared %{rpmldflags} %{rpmcxxflags} %{rpmcppflags} -fPIC -o ../attach_linux_amd64.so attach.cpp
67%endif
68cd ../../../../../..
69
70%if %{with python2}
71%py_build
72%endif
73
74%if %{with python3}
75%py3_build
76%endif
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81%if %{with python2}
82%py_install \
83 --install-lib=%{py_sitedir}
84
85%py_postclean
86%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/debugpy/ThirdPartyNotices.txt
87%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.{c,cpython-*.so}
88%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/{.gitignore,pydevd_frame_evaluator.{c,cpython-*.so},release_mem.h}
89%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/{README.txt,common,linux_and_mac/{.gitignore,attach.cpp,compile_*},winappdbg,windows}
90%endif
91
92%if %{with python3}
93%py3_install \
94 --install-lib=%{py3_sitedir}
95
96%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/debugpy/ThirdPartyNotices.txt
97%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.{c,so}
98%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/{.gitignore,pydevd_frame_evaluator.c,release_mem.h}
99%{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/{README.txt,common,linux_and_mac/{.gitignore,attach.cpp,compile_*},winappdbg,windows}
100%endif
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%if %{with python2}
106%files
107%defattr(644,root,root,755)
108%doc DESCRIPTION.md LICENSE README.md src/debugpy/ThirdPartyNotices.txt
109%dir %{py_sitedir}/debugpy
110%dir %{py_sitedir}/debugpy/_vendored
111%dir %{py_sitedir}/debugpy/_vendored/pydevd
112%{py_sitedir}/debugpy/_vendored/pydevd/_pydev_bundle
113%{py_sitedir}/debugpy/_vendored/pydevd/_pydev_imps
114%{py_sitedir}/debugpy/_vendored/pydevd/_pydev_runfiles
115%dir %{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle
116%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/_debug_adapter
117%attr(755,root,root) %{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.so
118%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.pxd
119%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.pyx
120%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/*.py[co]
121%dir %{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval
122%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/vendored
123%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/pydevd_frame_evaluator.pxd
124%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/*.py[co]
125%{py_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/*.pyx
126%{py_sitedir}/debugpy/_vendored/pydevd/pydev_ipython
127%{py_sitedir}/debugpy/_vendored/pydevd/pydev_sitecustomize
128%dir %{py_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process
77978184 129%ifarch %{ix86} %{x8664}
348f232b 130%attr(755,root,root) %{py_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/attach_linux_*.so
77978184 131%endif
348f232b
JB
132%{py_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/linux_and_mac
133%{py_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/*.py[co]
134%{py_sitedir}/debugpy/_vendored/pydevd/pydevd_concurrency_analyser
135%{py_sitedir}/debugpy/_vendored/pydevd/pydevd_plugins
136%{py_sitedir}/debugpy/_vendored/pydevd/*.py[co]
137%{py_sitedir}/debugpy/_vendored/*.py[co]
138%{py_sitedir}/debugpy/adapter
139%{py_sitedir}/debugpy/common
140%{py_sitedir}/debugpy/launcher
141%{py_sitedir}/debugpy/server
142%{py_sitedir}/debugpy/*.py[co]
143%{py_sitedir}/debugpy-%{version}-py*.egg-info
144%endif
145
146%if %{with python3}
147%files -n python3-debugpy
148%defattr(644,root,root,755)
149%doc DESCRIPTION.md LICENSE README.md src/debugpy/ThirdPartyNotices.txt
150%dir %{py3_sitedir}/debugpy
151%dir %{py3_sitedir}/debugpy/_vendored
152%dir %{py3_sitedir}/debugpy/_vendored/pydevd
153%{py3_sitedir}/debugpy/_vendored/pydevd/_pydev_bundle
154%{py3_sitedir}/debugpy/_vendored/pydevd/_pydev_imps
155%{py3_sitedir}/debugpy/_vendored/pydevd/_pydev_runfiles
156%dir %{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle
157%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/_debug_adapter
158%attr(755,root,root) %{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.cpython-*.so
159%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.pxd
160%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/pydevd_cython.pyx
161%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/*.py
162%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_bundle/__pycache__
163%dir %{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval
164%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/vendored
165%attr(755,root,root) %{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/pydevd_frame_evaluator.cpython-*.so
166%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/pydevd_frame_evaluator.pxd
167%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/*.py
168%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/*.pyx
169%{py3_sitedir}/debugpy/_vendored/pydevd/_pydevd_frame_eval/__pycache__
170%{py3_sitedir}/debugpy/_vendored/pydevd/pydev_ipython
171%{py3_sitedir}/debugpy/_vendored/pydevd/pydev_sitecustomize
172%dir %{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process
3853f75c 173%ifarch %{ix86} %{x8664}
348f232b 174%attr(755,root,root) %{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/attach_linux_*.so
3853f75c 175%endif
348f232b
JB
176%{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/linux_and_mac
177%{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/*.py
178%{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_attach_to_process/__pycache__
179%{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_concurrency_analyser
180%{py3_sitedir}/debugpy/_vendored/pydevd/pydevd_plugins
181%{py3_sitedir}/debugpy/_vendored/pydevd/*.py
182%{py3_sitedir}/debugpy/_vendored/pydevd/__pycache__
183%{py3_sitedir}/debugpy/_vendored/*.py
184%{py3_sitedir}/debugpy/_vendored/__pycache__
185%{py3_sitedir}/debugpy/adapter
186%{py3_sitedir}/debugpy/common
187%{py3_sitedir}/debugpy/launcher
188%{py3_sitedir}/debugpy/server
189%{py3_sitedir}/debugpy/*.py
190%{py3_sitedir}/debugpy/__pycache__
191%{py3_sitedir}/debugpy-%{version}-py*.egg-info
192%endif
This page took 0.112332 seconds and 4 git commands to generate.