]> git.pld-linux.org Git - packages/python-daemon.git/blame - python-daemon.spec
- release 4 (by relup.sh)
[packages/python-daemon.git] / python-daemon.spec
CommitLineData
a7c6cef5
ER
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
4# Disabled tests as pidlockfile is not anymore in the lastest python-lockfile
5
6%define module daemon
7Summary: Library to implement a well-behaved Unix daemon process
8Name: python-%{module}
9Version: 1.6
2013bd14 10Release: 4
a7c6cef5
ER
11License: Python
12Group: Development/Languages
a7c6cef5 13Source0: http://pypi.python.org/packages/source/p/python-daemon/%{name}-%{version}.tar.gz
41f92aea 14# Source0-md5: c774eda27d6c5d80b42037826d29e523
835b8c11 15URL: http://pypi.python.org/pypi/python-daemon/
a7c6cef5
ER
16BuildRequires: python-devel
17BuildRequires: python-setuptools
835b8c11 18BuildRequires: rpm-pythonprov
cd2865ab 19BuildRequires: rpmbuild(macros) >= 1.710
a7c6cef5
ER
20BuildRequires: sed >= 4.0
21%if %{with tests}
22BuildRequires: python-lockfile
23BuildRequires: python-minimock
24%endif
25Requires: python-lockfile
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30This library implements the well-behaved daemon specification of PEP
313143, "Standard daemon process library".
32
33%prep
34%setup -q
35
36%{__sed} -i -e '/^#!\//, 1d' daemon/version/version_info.py
37
38%build
ce275acd 39%py_build
a7c6cef5
ER
40
41# Test suite requires minimock and lockfile
42%if %{with tests}
835b8c11 43PYTHONPATH=$(pwd) nosetests-%{py_ver}
a7c6cef5
ER
44%endif
45
46%install
47rm -rf $RPM_BUILD_ROOT
ce275acd 48%py_install
a7c6cef5
ER
49
50%py_postclean
51
52%{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(644,root,root,755)
59%doc LICENSE.PSF-2
60%dir %{py_sitescriptdir}/daemon
61%dir %{py_sitescriptdir}/daemon/version
62%{py_sitescriptdir}/daemon/*.py[co]
63%{py_sitescriptdir}/daemon/version/*.py[co]
64%{py_sitescriptdir}/python_daemon-%{version}-py%{py_ver}.egg-info
This page took 0.063451 seconds and 4 git commands to generate.