]> git.pld-linux.org Git - packages/python-cinderclient.git/blame - python-cinderclient.spec
rebuild with python 3.10
[packages/python-cinderclient.git] / python-cinderclient.spec
CommitLineData
fbe48e32
JK
1#
2# Conditional build:
3%bcond_with doc # do build doc (missing deps)
4%bcond_with tests # do perform "make test" (missing deps)
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: OpenStack Block Storage API Client Library
9Name: python-cinderclient
10Version: 3.1.0
a5d3b034 11Release: 6
fbe48e32
JK
12License: Apache
13Group: Libraries/Python
14Source0: https://files.pythonhosted.org/packages/source/p/python-cinderclient/%{name}-%{version}.tar.gz
15# Source0-md5: 476881992a4b28b458a513dea61fb17f
16URL: https://pypi.python.org/pypi/python-cinderclient
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with python2}
20BuildRequires: python-pbr >= 2.0.0
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-pbr >= 2.0.0
25BuildRequires: python3-setuptools
26%endif
27Requires: python-babel >= 2.3.4
28Requires: python-keystoneauth1 >= 3.0.1
29Requires: python-oslo.i18n >= 2.1.0
30Requires: python-oslo.utils >= 3.20.0
31Requires: python-pbr >= 2.0.0
32Requires: python-prettytable >= 0.7.1
33Requires: python-simplejson >= 2.2.0
34Requires: python-six >= 1.9.0
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39This is a client for the OpenStack Cinder API. There's a Python API
40(the cinderclient module), and a command-line script (cinder). Each
41implements 100% of the OpenStack Cinder API.
42
43%package -n python3-cinderclient
44Summary: OpenStack Block Storage API Client Library
45Group: Libraries/Python
46Requires: python3-babel >= 2.3.4
47Requires: python3-keystoneauth1 >= 3.0.1
48Requires: python3-oslo.i18n >= 2.1.0
49Requires: python3-oslo.utils >= 3.20.0
50Requires: python3-prettytable >= 0.7.1
51Requires: python3-simplejson >= 2.2.0
52Requires: python3-six >= 1.9.0
53
54%description -n python3-cinderclient
55This is a client for the OpenStack Cinder API. There's a Python API
56(the cinderclient module), and a command-line script (cinder). Each
57implements 100% of the OpenStack Cinder API.
58
59%package -n cinderclient
60Summary: OpenStack Block Storage API Client
61Group: Applications
62%if %{with python3}
63Requires: python3-cinderclient = %{version}-%{release}
64%else
65Requires: %{name} = %{version}-%{release}
66%endif
67
68%description -n cinderclient
69This is a client for the OpenStack Cinder API.
70
71%package apidocs
72Summary: API documentation for Python cinderclient module
73Summary(pl.UTF-8): Dokumentacja API modułu Pythona cinderclient
74Group: Documentation
75
76%description apidocs
77API documentation for Pythona cinderclient module.
78
79%description apidocs -l pl.UTF-8
80Dokumentacja API modułu Pythona cinderclient.
81
82%prep
83%setup -q
84
85%build
86%if %{with python2}
87%py_build %{?with_tests:test}
88%endif
89
90%if %{with python3}
91%py3_build %{?with_tests:test}
92%endif
93
94%if %{with doc}
95cd doc
96%{__make} -j1 html
97rm -rf _build/html/_sources
98%endif
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%if %{with python2}
104%py_install
105
106%py_postclean
107%endif
108
109%if %{with python3}
110%py3_install
111%endif
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%if %{with python2}
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS ChangeLog README.rst
120%{py_sitescriptdir}/cinderclient
121%{py_sitescriptdir}/python_cinderclient-%{version}-py*.egg-info
122%endif
123
124%if %{with python3}
125%files -n python3-cinderclient
126%defattr(644,root,root,755)
127%doc AUTHORS ChangeLog README.rst
128%{py3_sitescriptdir}/cinderclient
129%{py3_sitescriptdir}/python_cinderclient-%{version}-py*.egg-info
130%endif
131
132%files -n cinderclient
133%defattr(644,root,root,755)
134%doc AUTHORS ChangeLog README.rst
135%attr(755,root,root) %{_bindir}/cinder
136
137%if %{with doc}
138%files apidocs
139%defattr(644,root,root,755)
140%doc doc/_build/html/*
141%endif
This page took 0.088447 seconds and 4 git commands to generate.