]> git.pld-linux.org Git - packages/python-cffi.git/blame - python-cffi.spec
rebuild with separate debuginfo build-ids
[packages/python-cffi.git] / python-cffi.spec
CommitLineData
a3ed0930
JB
1#
2# Conditional build:
5cd26f14
JB
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_without doc # Sphinx based documentation
6%bcond_without tests # unit tests
a3ed0930
JB
7#
8Summary: Foreign Function Interface for Python 2 calling C code
9Summary(pl.UTF-8): Interfejs funkcji obcych (FFI) dla Pythona 2 wywołującego kod w C
10Name: python-cffi
89bb58dd 11Version: 1.14.4
9215f18f 12Release: 4
a3ed0930
JB
13License: MIT
14Group: Libraries/Python
5cd26f14
JB
15#Source0Download: https://pypi.org/simple/cffi/
16Source0: https://files.pythonhosted.org/packages/source/c/cffi/cffi-%{version}.tar.gz
89bb58dd 17# Source0-md5: ad3d8537b1516bad6bcdc36c458788be
a3ed0930 18URL: http://cffi.readthedocs.org/
2617e1cf
JB
19BuildRequires: libffi-devel >= 3
20BuildRequires: pkgconfig
a3ed0930
JB
21%if %{with python2}
22BuildRequires: python >= 1:2.6
23BuildRequires: python-devel >= 1:2.6
5cd26f14
JB
24%if %{with tests}
25BuildRequires: python-pycparser
26BuildRequires: python-pytest
27%endif
a3ed0930
JB
28%endif
29%if %{with python3}
2617e1cf
JB
30BuildRequires: python3 >= 1:3.2
31BuildRequires: python3-devel >= 1:3.2
5cd26f14
JB
32%if %{with tests}
33BuildRequires: python3-pycparser
34BuildRequires: python3-pytest
35%endif
a3ed0930 36%endif
a3ed0930 37BuildRequires: rpm-pythonprov
5cd26f14 38BuildRequires: rpmbuild(macros) >= 1.714
2617e1cf 39%{?with_doc:BuildRequires: sphinx-pdg}
5cd26f14 40Requires: python-modules >= 1:2.6
494e0686 41Requires: python-pycparser
a3ed0930
JB
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Foreign Function Interface for Python calling C code. The aim of this
46project is to provide a convenient and reliable way of calling C code
47from Python without learning additional language or API.
48
49This package contains Python 2 module.
50
51%description -l pl.UTF-8
52CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
53wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
54wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
55potrzeby nauki dodatkowego języka lub API.
56
57Ten pakiet zawiera moduł Pythona 2.
58
59%package -n python3-cffi
60Summary: Foreign Function Interface for Python 3 calling C code
61Summary(pl.UTF-8): Interfejs funkcji obcych (FFI) dla Pythona 3 wywołującego kod w C
62Group: Libraries/Python
5cd26f14 63Requires: python3-modules >= 1:3.2
494e0686 64Requires: python3-pycparser
a3ed0930
JB
65
66%description -n python3-cffi
67Foreign Function Interface for Python calling C code. The aim of this
68project is to provide a convenient and reliable way of calling C code
69from Python without learning additional language or API.
70
71This package contains Python 3 module.
72
73%description -n python3-cffi -l pl.UTF-8
74CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
75wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
76wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
77potrzeby nauki dodatkowego języka lub API.
78
79Ten pakiet zawiera moduł Pythona 3.
80
5cd26f14
JB
81%package apidocs
82Summary: API documentation for Python CFFI module
83Summary(pl.UTF-8): Dokumentacja API modułu Pythona CFFI
84Group: Documentation
5cd26f14 85BuildArch: noarch
5cd26f14
JB
86
87%description apidocs
88API documentation for Python CFFI module.
89
90%description apidocs -l pl.UTF-8
91Dokumentacja API modułu Pythona CFFI.
92
a3ed0930
JB
93%prep
94%setup -q -n cffi-%{version}
95
96%build
97%if %{with python2}
8084c254 98%py_build
5cd26f14
JB
99
100%if %{with tests}
62cfd150 101PYTHONPATH=$(pwd):$(echo $(pwd)/build-2/lib.linux-*) \
20c11398 102py.test-2 c testing
5cd26f14 103%endif
a3ed0930 104%endif
5cd26f14 105
a3ed0930 106%if %{with python3}
8084c254 107%py3_build
5cd26f14
JB
108
109%if %{with tests}
62cfd150 110PYTHONPATH=$(pwd):$(echo $(pwd)/build-3/lib.linux-*) \
20c11398 111py.test-3 c testing
5cd26f14 112%endif
a3ed0930
JB
113%endif
114
115%if %{with doc}
116%{__make} -C doc html
117%endif
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%if %{with python2}
8084c254 123%py_install
a3ed0930
JB
124
125%py_postclean
126%endif
127
128%if %{with python3}
8084c254 129%py3_install
a3ed0930
JB
130%endif
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%if %{with python2}
136%files
137%defattr(644,root,root,755)
5cd26f14 138%doc AUTHORS LICENSE README.md
a3ed0930
JB
139%attr(755,root,root) %{py_sitedir}/_cffi_backend.so
140%dir %{py_sitedir}/cffi
5cd26f14 141%{py_sitedir}/cffi/_cffi_errors.h
f4001aff 142%{py_sitedir}/cffi/_cffi_include.h
bf62289b 143%{py_sitedir}/cffi/_embedding.h
f4001aff 144%{py_sitedir}/cffi/parse_c_type.h
a3ed0930
JB
145%{py_sitedir}/cffi/*.py[co]
146%{py_sitedir}/cffi-%{version}-py*.egg-info
147%endif
148
149%if %{with python3}
150%files -n python3-cffi
151%defattr(644,root,root,755)
5cd26f14 152%doc AUTHORS LICENSE README.md
a3ed0930 153%attr(755,root,root) %{py3_sitedir}/_cffi_backend.cpython-*.so
494e0686 154%dir %{py3_sitedir}/cffi
5cd26f14 155%{py3_sitedir}/cffi/_cffi_errors.h
f4001aff 156%{py3_sitedir}/cffi/_cffi_include.h
bf62289b 157%{py3_sitedir}/cffi/_embedding.h
f4001aff 158%{py3_sitedir}/cffi/parse_c_type.h
a3ed0930
JB
159%{py3_sitedir}/cffi/*.py
160%{py3_sitedir}/cffi/__pycache__
161%{py3_sitedir}/cffi-%{version}-py*.egg-info
162%endif
5cd26f14
JB
163
164%if %{with doc}
165%files apidocs
166%defattr(644,root,root,755)
167%doc doc/build/html/{_static,*.html,*.js}
168%endif
This page took 0.074283 seconds and 4 git commands to generate.